Couple of bugs [#15589]

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Couple of bugs [#15589]

Re: Couple of bugs [#15589]

by Richard127 » Thu May 16, 2019 5:01 am

Interesting. No idea why I'm having that issue. It is annoying because I can't directly upgrade; I always have to start layout from scratch, although it does import most other settings. Weirdly, the new portable install, which is in a folder of its own, inside my previous install, saves DB backups into the previous folder! TBH MM5 is close enough to stable for me to do a full install. I'll see what happens next time around. Thanks.

Re: Couple of bugs [#15589]

by Barry4679 » Thu May 16, 2019 3:18 am

Richard127 wrote:
Wed May 15, 2019 12:15 pm
I also hadn't realised that I needed to re-enter my gold licence number each time I installed a new portable version.
FWIIW I install new portable versions of MM5 beta on a regular basis, and don't ever have to re-enter my gold licence number ... well, I did once, but that was a bug, and it was a while ago, and they fixed it.

I believe that all beta testers have gold status, up until when MM5 is out of beta.

Re: Couple of bugs [#15589]

by Richard127 » Wed May 15, 2019 12:15 pm

I'll look into the watched folder problem and send you a debug log. The other problem regarding the Art panel was a legacy problem for me and it has indeed cleared up. I'd had problems when I tried updating v.2173 with another portable version (v.2175) and hadn't realised it hadn't written over the previous version, but had created a new folder inside the old portable folder. So I was still launching v.2173. Apologies for that. I also hadn't realised that I needed to re-enter my gold licence number each time I installed a new portable version.

Re: Couple of bugs

by MiPi » Wed May 15, 2019 1:37 am

Richard127 wrote:
Tue May 14, 2019 7:49 am
1) Artwork panel still requires at least one other panel below it for it to remain at selected size after re-start.
What do you mean? When there is only one panel, it should be stretched to the whole left panel. And for me it works this way even after restart. Maybe some old persistent.json? Could you remove it and test again with the new one?

Re: Couple of bugs [#15589]

by PetrCBR » Wed May 15, 2019 1:16 am

Can you make me a debuglog with that operation (when you copy tracks into monitored folder) ?

Re: Couple of bugs [#15589]

by Richard127 » Tue May 14, 2019 5:24 pm

There was a third problem I added from mobile but didn't upload for some reason... Physically adding albums to artist folders in Windows (10) File Explorer, with MM5 watched folder set to "Continuously" doesn't seem to find and add album. I have to make a manual scan.

Re: Couple of bugs [#15589]

by Richard127 » Tue May 14, 2019 3:49 pm

Ah, I understand re: item 2. My confusion was caused because MM defaulted back to a previous layout for some reason. It's okay now. Thanks.

Re: Couple of bugs [#15589]

by PetrCBR » Tue May 14, 2019 3:27 pm

I'm not sure i understand item 2 ? In options you just configure layouts (with live preview), but when you close Options it will apply current layout. Selecting layout in options will not make it as current.

Re: Couple of bugs [#15589]

by Peke » Tue May 14, 2019 8:41 am

Reopened.

Re: Couple of bugs

by Richard127 » Tue May 14, 2019 7:49 am

Hi. Fantastic work on the bugs. MM5 is stable enough for me now to be used as my main media player. However...

1) Artwork panel still requires at least one other panel below it for it to remain at selected size after re-start.
2) Using "View/Configure Layout" panel always regresses to "Default" as the active layout. Both immediately after leaving and returning to the panel and after re-start.

Re: Couple of bugs

by MiPi » Wed May 01, 2019 5:01 am

Right, reopened. Thanks.

Re: Couple of bugs

by Richard127 » Tue Apr 30, 2019 12:16 pm

As of V.2173, I am still having problems with this, although you report it as being fixed (error 15589). The album view panel is obscuring the right hand side when Viz is on left panel. I do, however, have access to the "minimize" icon for the visualisation, unlike before (although it doesn't appear in screen-grabs). So I don't have to quit out and restart. One thing I didn't mention before is I have 2 screens (MM displaying on main screen - screen 1), but I have disabled 2nd screen and it didn't make any difference. See image below:

Also, still require at least one other panel below album art panel (whether on left or right) to avoid Album Art becoming too small at the top of the screen after re-boot.

Many thanks.

Image

Re: Couple of bugs

by MiPi » Mon Apr 15, 2019 9:44 am

You're right, Added column was in reverse order in MM4, will be fixed in the next build.

Re: Couple of bugs

by Richard127 » Fri Apr 12, 2019 7:31 pm

That's great. Always happy when it can be reproduced and I know it's not something stupid I'm doing :-)

Whilst I'm here: In the column browser sub menu, when I add the column "Added", it lists the latest items at the bottom of the list (reverse order). Can this either be changed (as it was in MM4) or could users be given the choice of reversing the order of those columns?

Thanks for all the great work. It's been worth the wait.

Re: Couple of bugs

by MiPi » Fri Apr 12, 2019 5:39 am

The problem with visualization is caused by moving the Art&Details panel to the left side, reproduced, thanks. Tracked as: https://www.ventismedia.com/mantis/view.php?id=15589

Top