1384 Unregistering events doesn't work [#7934]

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: 1384 Unregistering events doesn't work [#7934]

Re: 1384 Unregistering events doesn't work [#7934]

by Steegy » Wed Jun 08, 2011 1:34 pm

Verified: Fixed in build 1385.

Re: 1384 Unregistering events doesn't work

by Ludek » Tue Jun 07, 2011 9:24 am

Re: 1384 Unregistering events doesn't work

by Ludek » Tue Jun 07, 2011 5:15 am

Re: 1384 Unregistering events doesn't work

by Bex » Mon Jun 06, 2011 7:10 pm

I'm not sure it'll help but what if you create a separate Uninstall.vbs containing the stuff you want to happen on an uninstall, which you then reference from the uninstall.ini?

Re: 1384 Unregistering events doesn't work

by Steegy » Mon Jun 06, 2011 4:03 pm

It's the debug version, I double-checked and even re-downloaded/installed.
But I'm more concerned about unregistering the events.

Re: 1384 Unregistering events doesn't work

by nohitter151 » Sun Jun 05, 2011 4:07 pm

Steegy wrote:During uninstallation of the script LinkedTracks, ScriptControl's method UnRegisterAllEvents is called, but this has no effect. The OnPlay event handler that was registered in the running script is still called, even when it is explicitly unregistered using ScriptControl's UnRegisterHandler method.
On MM3 the methods work fine (but this is on 32 bit Windows XP).

Sorry, for some reason DebugView is logging nothing at all.
Maybe you didn't install the debug build?

1384 Unregistering events doesn't work [#7934]

by Steegy » Sun Jun 05, 2011 2:54 pm

During uninstallation of the script LinkedTracks, ScriptControl's method UnRegisterAllEvents is called, but this has no effect. The OnPlay event handler that was registered in the running script is still called, even when it is explicitly unregistered using ScriptControl's UnRegisterHandler method.
On MM3 the methods work fine (but this is on 32 bit Windows XP).

Sorry, for some reason DebugView is logging nothing at all.

I'm using MM 4.0 build 1384, on 64 bit Windows 7 all normal setup.

Top