Bookmarker 2.0 - Updated 20/04/2010

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Bookmarker 2.0 - Updated 20/04/2010

Re: Bookmarker 2.0 - Updated 20/04/2010

by MMFrLife » Mon Jan 18, 2016 5:51 am

Ok, I've noticed something that will perhaps help to pinpoint the problem noted in my above post.
Anything bookmarked at around 30 to 31 seconds or less is labeled accurately. Above 30 - 31 seconds is labeled as an exact minute ahead.
So, at about 31 seconds you get :31 = "(0:01:31)", :32 = "(0:01:32)", and so on.

I've had one track in particular that displayed this behavior as early as :25s, but it was on a track that I had edited a few years back
(not sure if that has anything to do with it, though).

Re: Bookmarker 2.0 - Updated 20/04/2010

by MMFrLife » Thu Jan 14, 2016 9:59 pm

Great idea but has a serious flaw :( . When I bookmark a track it adds it and when I click on it it resumes at the correct time that I did it at.
However, it labels the time as a minute ahead of what was marked. For example, if I bookmark at 2:35 the name of the bookmark will
state 3:35 even though the actual playback/resume is correct.

Yes, I know you can rename it. But that is seriously annoying. I would like to add something to the name not always have to correct the time.
I did it once where it labled the correct time but so far everything else has been wrong.

Is anyone else getting this or have people moved on to a similar but better script that I just don't know about?
Or, is there a setting I can tweak that I just don't know about?

Anyone seen Trix lately? :wink:
He's pushin' 6 months since his last visit.

Re: Bookmarker 2.0 - Updated 20/04/2010

by trixmoto » Sun Nov 02, 2014 5:56 pm

I'm glad it's working for you now.

Re: Bookmarker 2.0 - Updated 20/04/2010

by tarasdi » Fri Oct 31, 2014 4:40 pm

Hi Trixmoto,

I've restarted MM and the bookmarks are working now. I think the cause may have something to do with me moving my music to a new computer, and the database being in an inconsistent state (I was in the middle of 'locating missing files').

Thanks anyway for your response - very much appreciated!

Re: Bookmarker 2.0 - Updated 20/04/2010

by trixmoto » Thu Oct 30, 2014 4:55 pm

Is there a line number with the error message?

Re: Bookmarker 2.0 - Updated 20/04/2010

by tarasdi » Thu Oct 30, 2014 5:36 am

Hi again!

I've moved computers again - my bookmarks are appearing in the bookmarks node, but when I go to play them I get an error message:

Code: Select all

Error executing script event.
Object required: 'SDB.Player.CurrentSong'
I'm using MM 4.1.5.1719 Gold, and migrated all extensions & scripts by copy/pasting them from the AppData/Roaming folder.

Any ideas how to fix?

Thanks!

Taras

Re: Bookmarker 2.0 - Updated 20/04/2010

by tarasdi » Sat Jun 16, 2012 9:45 pm

Yep, works.. thanks! :)

Re: Bookmarker 2.0 - Updated 20/04/2010

by trixmoto » Sat Jun 16, 2012 9:03 pm

All bookmarks are stored in the MediaMonkey.ini file, so it should be possible to move them over, yes.

Re: Bookmarker 2.0 - Updated 20/04/2010

by tarasdi » Sat Jun 16, 2012 2:31 am

Hi,

I've just had to do a new OS install - where does Bookmarker store bookmarks, and is it possible to migrate them over?

Thanks

Taras

Re: Bookmarker 2.0 - Updated 20/04/2010

by trixmoto » Wed Apr 21, 2010 3:16 am

Apologies, slight typo on my website, I tried to publish version 3.0 when I've only written 2.0! :lol:

Re: Bookmarker 2.0 - Updated 20/04/2010

by nynaevelan » Tue Apr 20, 2010 7:04 pm

I get a message the file doesn't exist.

Re: Bookmarker 2.0 - Updated 20/04/2010

by trixmoto » Tue Apr 20, 2010 1:51 pm

New version (2.0) is now available to download from my website. I have rewritten the script as a node within the tree and allowed unlimited bookmarks to be stored - please refer to the first post for details.

by trixmoto » Thu Jan 24, 2008 8:46 am

Well "Resume Play" isn't mine so I don't know how it works. It sound like it performs the same job though, so no need to install both! :)

Yes I love MM, and I also love programming/scripting so it's a match made in heaven! :D

by GargantulaKon » Thu Jan 24, 2008 6:01 am

Thanks, but is this different from ResumePlay (v3.1)? I finally found something that works right.

In addition, thanks for your hard work in making Batch Art Finder work with MM3 and your other wonderful scripts. You must love MediaMonkey so much to make so many of them.

by trixmoto » Tue Jan 22, 2008 4:37 pm

New version (1.2) is now available to download from my website. I have now resolved the MM3 compatibility issues. :)

Top