[1726] Sort doesn't always work correctly on MM start

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: [1726] Sort doesn't always work correctly on MM start

[1726] Sort doesn't always work correctly on MM start

by alistair4711 » Sat Jan 17, 2015 6:18 pm

Hello,

sort doesn't always work correctly on MM start when "show art with details" is enabled. It works correctly though when "show details" is enabled.

Description: MM is set to "Entire Library" and displaying about 100000 files (in my case).

I sort my files by "Title descending" and restart MM. The status line says "reading files..." and the sort order will update as more files are being read. This works correctly, regardless of whether "show details" or "show art with details" is enabled.

Now I sort my files by "Added descending" and restart MM. The status line says "reading files..." and the sort order will update as more files are being read... but only if "show details" is enabled. However, if "show art with details" is enabled, the sort order will not update as more files are being read and the files will remain in an incompletely sorted state. (Btw, the same thing happens when I sort by "Custom 1 descending", which I use to store a "first added" timestamp.)

I've only recently upgraded from MM3 to MM4 and noticed this odd sort problem. That's why I've tried the beta now, but behavior is the same as the official release.

Top