How to prevent files located in C from being added to the library?

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

albertocruz
Posts: 9
Joined: Fri May 31, 2013 5:07 pm

How to prevent files located in C from being added to the library?

Post by albertocruz » Thu Jul 18, 2019 11:27 am

Hi. My library is on an external hard drive with the letter M.

I do not know if I changed some settings, but now every time I open the software, my files from disk C are added to the library.

I have the option to auto-organize the library with files from my external hard drive M. The problem is that every time I open the software, it starts monitoring from C and moves the files

I already put the rule in Tools / options / autoorganize but the problem persists.

What will have been the option that I changed?
What can I do to prevent the C files from being monitored?

Thanks
Alberto

dtsig
Posts: 3031
Joined: Mon Jan 24, 2011 6:34 pm

Re: How to prevent files located in C from being added to the library?

Post by dtsig » Thu Jul 18, 2019 12:26 pm

Check File-Add Rescan files this is where it should know what to scan
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

Lowlander
Posts: 46172
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: How to prevent files located in C from being added to the library?

Post by Lowlander » Thu Jul 18, 2019 1:11 pm

You may have the C drive enabled for Monitoring. This is set on the right side of the Add/Rescan Files dialog. Deselecting it on the left side doesn't disable Monitoring settings (it deselects it from manual scanning).

Removing locations from scanning does not remove the files from the Library.
Lowlander (MediaMonkey user since 2003)

albertocruz
Posts: 9
Joined: Fri May 31, 2013 5:07 pm

Re: How to prevent files located in C from being added to the library?

Post by albertocruz » Thu Jul 18, 2019 2:51 pm

You are right!!! In the add/rescan Files

I can see my "Music" folder - located on hard disk C - below Monitored Folders. But ... How can I exclude it?

It is not selected in the folder tree. The only thing that is selected is the folder of my library located on the hard disk M.

I want Media Monkey to return to the normal status with which I used it: I opened media monkey and scanned exclusively my folder on the M \ Music hard drive.

In fact, it is even weirder for me to do a scan when the options "Scan continuously" and "Scan at startup" are disabled!

How can I exclude C: \ Music from "Monitored Folders"?


Lowlander wrote:
Thu Jul 18, 2019 1:11 pm
You may have the C drive enabled for Monitoring. This is set on the right side of the Add/Rescan Files dialog. Deselecting it on the left side doesn't disable Monitoring settings (it deselects it from manual scanning).

Removing locations from scanning does not remove the files from the Library.

albertocruz
Posts: 9
Joined: Fri May 31, 2013 5:07 pm

Re: How to prevent files located in C from being added to the library?

Post by albertocruz » Thu Jul 18, 2019 3:00 pm

Apparently I did it!

I closed and opened MMW, opened the Add / rescan folder dialog. I selected C: \ Music and accepted the options of Scan Continuously and Scan at Startup ... then I removed the options...and the Music folder (c: \ music) of the Monitored Folders disappeared.

I selected M: \ Music and again selected Scan Continuously and Scan at startup.

Now, the sync symbol is already pointing to M: \ Music !!

I will only have to correct the songs that went from C: \ Music to M: \ Music

Many thanks.

albertocruz wrote:
Thu Jul 18, 2019 2:51 pm
You are right!!! In the add/rescan Files

I can see my "Music" folder - located on hard disk C - below Monitored Folders. But ... How can I exclude it?

It is not selected in the folder tree. The only thing that is selected is the folder of my library located on the hard disk M.

I want Media Monkey to return to the normal status with which I used it: I opened media monkey and scanned exclusively my folder on the M \ Music hard drive.

In fact, it is even weirder for me to do a scan when the options "Scan continuously" and "Scan at startup" are disabled!

How can I exclude C: \ Music from "Monitored Folders"?


Lowlander wrote:
Thu Jul 18, 2019 1:11 pm
You may have the C drive enabled for Monitoring. This is set on the right side of the Add/Rescan Files dialog. Deselecting it on the left side doesn't disable Monitoring settings (it deselects it from manual scanning).

Removing locations from scanning does not remove the files from the Library.

albertocruz
Posts: 9
Joined: Fri May 31, 2013 5:07 pm

Re: How to prevent files located in C from being added to the library?

Post by albertocruz » Thu Jul 18, 2019 3:21 pm

Nooooo!!

I failed! Every time I open and close Media Monkey, the option to scan the C: \ Music files instead of M: \ Music returns in the Add/rescan Folder dialog!

Is there any way to exclude C: \?


albertocruz wrote:
Thu Jul 18, 2019 3:00 pm
Apparently I did it!

I closed and opened MMW, opened the Add / rescan folder dialog. I selected C: \ Music and accepted the options of Scan Continuously and Scan at Startup ... then I removed the options...and the Music folder (c: \ music) of the Monitored Folders disappeared.

I selected M: \ Music and again selected Scan Continuously and Scan at startup.

Now, the sync symbol is already pointing to M: \ Music !!

I will only have to correct the songs that went from C: \ Music to M: \ Music

Many thanks.

albertocruz wrote:
Thu Jul 18, 2019 2:51 pm
You are right!!! In the add/rescan Files

I can see my "Music" folder - located on hard disk C - below Monitored Folders. But ... How can I exclude it?

It is not selected in the folder tree. The only thing that is selected is the folder of my library located on the hard disk M.

I want Media Monkey to return to the normal status with which I used it: I opened media monkey and scanned exclusively my folder on the M \ Music hard drive.

In fact, it is even weirder for me to do a scan when the options "Scan continuously" and "Scan at startup" are disabled!

How can I exclude C: \ Music from "Monitored Folders"?


Lowlander wrote:
Thu Jul 18, 2019 1:11 pm
You may have the C drive enabled for Monitoring. This is set on the right side of the Add/Rescan Files dialog. Deselecting it on the left side doesn't disable Monitoring settings (it deselects it from manual scanning).

Removing locations from scanning does not remove the files from the Library.

Lowlander
Posts: 46172
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: How to prevent files located in C from being added to the library?

Post by Lowlander » Thu Jul 18, 2019 3:36 pm

Did you OK the Add/Rescan Files dialog after you disabled Monitoring for C? Then make sure you properly exit MediaMonkey as settings are saved on a proper exit.
Lowlander (MediaMonkey user since 2003)

albertocruz
Posts: 9
Joined: Fri May 31, 2013 5:07 pm

Re: How to prevent files located in C from being added to the library?

Post by albertocruz » Thu Jul 18, 2019 3:59 pm

Yes i did =(

Yes, I gave OK to the Add / rescan dialog. I left Media Monkey using File / Exit.

I just restarted the computer, I opened Media Monkey and now it's monitoring the entire hard disk M: \

It's strange, because in Add / Scan File Dialog M: \ music is selected with green and checked.

M: \ Only appears in green without the checked symbol.

C: \ isn't green (this is the good notice)

Do you have any idea what I could be doing wrong?

Best regards
Lowlander wrote:
Thu Jul 18, 2019 3:36 pm
Did you OK the Add/Rescan Files dialog after you disabled Monitoring for C? Then make sure you properly exit MediaMonkey as settings are saved on a proper exit.

albertocruz
Posts: 9
Joined: Fri May 31, 2013 5:07 pm

Re: How to prevent files located in C from being added to the library?

Post by albertocruz » Thu Jul 18, 2019 4:32 pm

FI-NA-LLY

The problem was that I had to select M: \ in the Add / rescan File dialog. And only in M: \ did the uncheck to Scan Continuously and Scan at startup options appear.

I was just checked those options in M: \ Music.

Thank you very much Lowlander!! =)


albertocruz wrote:
Thu Jul 18, 2019 3:59 pm
Yes i did =(

Yes, I gave OK to the Add / rescan dialog. I left Media Monkey using File / Exit.

I just restarted the computer, I opened Media Monkey and now it's monitoring the entire hard disk M: \

It's strange, because in Add / Scan File Dialog M: \ music is selected with green and checked.

M: \ Only appears in green without the checked symbol.

C: \ isn't green (this is the good notice)

Do you have any idea what I could be doing wrong?

Best regards
Lowlander wrote:
Thu Jul 18, 2019 3:36 pm
Did you OK the Add/Rescan Files dialog after you disabled Monitoring for C? Then make sure you properly exit MediaMonkey as settings are saved on a proper exit.

Post Reply