Sync to Fiio X1 has suddenly started hanging

Get answers about syncing the current release of MediaMonkey with iPods and other devices.

Moderator: Gurus

Marbrien
Posts: 18
Joined: Thu Feb 16, 2017 8:30 am

Sync to Fiio X1 has suddenly started hanging

Post by Marbrien » Wed Jul 04, 2018 11:55 am

I have MMW version 4.1.20.1864, the free version (not Gold), running on a laptop under Windows 10. My music player is a Fiio X1 with a 64 GB SD card. It is not an Android device.

Until recently I have had no problems with syncing the device to WWM, the sync started automatically when I connected the Fiio via USB to the laptop when MMW was running, and finished quite speedily.

Today I Added/Rescanned about 40 tracks into WWM, and removed some duplicates. I then connected the Fiio via USB as normal to initiate the sync. The sync began as normal, by asking to delete some content from the Fiio. It then hung on the message Copying 0 of 40.

The first time it happened I waited several minutes then right-clicked on the sync progress bar and selected Terminate. I received a message box indicating there was a problem copying an artwork file, but it was not from any album I have amended recently or which has ever given problems before. Unfortunately I did not keep a record of the message.

I tried again, still the sync hung, but I no longer get the message box when I terminate.

I can right-click on a file in MMW and use 'Send to' to copy it onto the Fiio, I can also inspect the Fiio's contents normally via Windows Explorer.

I have tried closing MMW, restarting Windows, turning the Fiio off and reconnecting it via another USB port, all to no avail.

As I was writing this I had the Fiio connected for about 20 minutes. Suddenly the sync has started, but with very lengthy pauses (several minutes) on certain tracks, whilst others sync at the kind of speed I used to experience. It has now stuck again on the penultimate file to copy.

Does anyone know what might have caused this problem to appear, and how it can be resolved? Thanks.

Lowlander
Posts: 46091
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Sync to Fiio X1 has suddenly started hanging

Post by Lowlander » Wed Jul 04, 2018 1:16 pm

It may be an MTP driver hang: http://www.mediamonkey.com/support/inde ... tion-fails

You could also try a different cable.

Ps. MediaMonkey 4.1.21 is available: viewtopic.php?f=3&t=8811&sd=d
Lowlander (MediaMonkey user since 2003)

Marbrien
Posts: 18
Joined: Thu Feb 16, 2017 8:30 am

Re: Sync to Fiio X1 has suddenly started hanging

Post by Marbrien » Wed Jul 04, 2018 2:38 pm

I did say the Fiio is not an Android device, and that I had tried another USB port. I don't have another cable, but Windows itself can see the contents of the Fiio. I also tried checking for a new version of MMW, but MMW told me I had the latest version. I will look for the update myself, but are you sure you are pointing me in the right direction?

Marbrien
Posts: 18
Joined: Thu Feb 16, 2017 8:30 am

Re: Sync to Fiio X1 has suddenly started hanging

Post by Marbrien » Wed Jul 04, 2018 3:07 pm

I have updated to MMW version 4.1.21.1873, but the problem remains.

I tried again. Normally I have the Fiio set to be automatically unmounted after a sync, but even if there are no files to sync the 'Copying 0 of 0' message is not clearing from MMW. So I set the device to not automatically unmount after a sync, and still the 'Copying 0 of 0' message remains on MMW.

Also MMW displayed an error message again, it said there was a problem copying a music file to c:\Users\<my name>\AppData\Local\Temp\D67.mp3. The Temp folder is there, and seems to be set to Read Only. There is no D67.mp3 file in it.

Lowlander
Posts: 46091
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Sync to Fiio X1 has suddenly started hanging

Post by Lowlander » Wed Jul 04, 2018 6:16 pm

MediaMonkey will need write permissions on the Temp folder (Tools > Options > General for Location).
Lowlander (MediaMonkey user since 2003)

Marbrien
Posts: 18
Joined: Thu Feb 16, 2017 8:30 am

Re: Sync to Fiio X1 has suddenly started hanging

Post by Marbrien » Thu Jul 05, 2018 2:57 am

Tools -> Options -> General shows that MMW is set up to use the Temp directory in question.

I cannot change the write permissions of that folder within MMW.

In Windows, the folder has full read/write access for System, myself as an individual user, myself as an Administrator. Shouldn't that be enough? I have made no changes to the write permissions of that directory at any time.

Marbrien
Posts: 18
Joined: Thu Feb 16, 2017 8:30 am

Re: Sync to Fiio X1 has suddenly started hanging

Post by Marbrien » Sun Jul 15, 2018 4:53 am

I think I have discovered the cause of the problem.

The Fiio X1 cannot handle file paths longer than 128 characters in length. I had previously created a File Location for Music mask in the Fiio's Device Profile config settings which ensured that paths would not exceed this length.

Somehow the file mask had been reset to its default, which caused paths to exceed 128 characters on the Fiio in some instances.

I don't know what caused this reset within the Fiio's config settings. It was not something I did, so I wonder if one of the MMW updates may have caused it.

Anyway, putting the mask back to the way I had it before has removed the problem.

Post Reply