Tagging Inconsistencies 4.0.1 (2014-02-27)

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by chrisjj » Thu Mar 27, 2014 7:11 am

Bex wrote:1. See the download section of the first post
Thanks. For anyone else looking for the answer, there I found the latest offered for MM3 is 3.9.4, and the download URL is http://www.mediamonkey.com/addons/download/233/
Bex wrote:2. Tools->Extension
Thanks. It showed 4.0.1.128. That follows my install from a _download_ click in the Add-on page offered by _Get more extensions..._. Nothing on that page warned that the version offered should not be used on MM3. The installer warned, but offered no way to cancel, and said "Product was successfully installed."

Uninstall failed with:

Code: Select all

Error
There was a problem querying the database:
Error executing SQL "SELECT ID FROM Filters WHERE VisibleInMainTree>0 UNION SELECT 0 ORDER BY ID
" : no such column: VisibleInMainTree (1, 1)
and Cancel produced two further SQL errors.

Restart gave this: http://i.imgur.com/B6VAKDV.png

I installed 3.9.4 regardless, and it appears to be working fine. Thanks.

Suggestion: add a note to the add-on page http://i.imgur.com/CQP2ejM.png indicating that the latest version is NOT suitable for MM3.
Chris

chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by chrisjj » Thu Mar 27, 2014 6:28 pm

chrisjj wrote:I installed 3.9.4 regardless, and it appears to be working fine.
Hmm... not quite.

MM lauch shows a warning dialogue box which, once pulled out from under the splash screen, is seen to say:

Code: Select all

This version of Tagging Inconsistencies is only compatible with MediaMonkey 4.0.3.1392 and later.
Please Update your version of MediaMonkey. You might need to download from the Beta Forum to get the required version.
The script will be disabled.
and Tools, Extensions says

Code: Select all

Tagging Inconsistencies               Script                3.9.4
EDIT: After uninstall, the warning dialogue box remains on launch, despite that now no TI script shows present in Tools, Extensions.

Any ideas?
Chris

Mizery_Made
Posts: 2283
Joined: Tue Aug 29, 2006 1:09 pm
Location: Kansas City, Missouri, United States

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by Mizery_Made » Thu Mar 27, 2014 10:33 pm

Check in the scripts folder. Perhaps you have the non-MM3 "TaggingInconsistencies.vbs" left over from your failed uninstall?

Bex
Posts: 6316
Joined: Fri May 21, 2004 5:44 am
Location: Sweden

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by Bex » Fri Mar 28, 2014 2:29 am

Yes, since the installer failed. I guess you still have the new version installed.
"TaggingInconsistencies.vbs" is the new one for MM4. Delete this one and restart MM.
"TaggingInconsistenciesMM3.vbs" is for MM3

I'll try to fix the installer so this doesn't happen.
Advanced Duplicate Find & Fix Find More From Same - Custom Search. | Transfer PlayStat & Copy-Paste Tags/AlbumArt between any tracks.
Tagging Inconsistencies Do you think you have your tags in order? Think again...
Play History & Stats Node Like having your Last-FM account stored locally, but more advanced.
Case & Leading Zero Fixer Works on filenames too!

All My Scripts

chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by chrisjj » Fri Mar 28, 2014 5:53 am

Mizery_Made wrote:Check in the scripts folder. Perhaps you have the non-MM3 "TaggingInconsistencies.vbs" left over from your failed uninstall?
Thanks. Yes, it was in C:\Program Files\MediaMonkey\Scripts\Auto.
Bex wrote:"TaggingInconsistencies.vbs" is the new one for MM4. Delete this one and restart MM.
Thanks - that worked.
Bex wrote:since the installer failed. I guess you still have the new version installed.
Note that the installer did not say it failed. It gave a warning, said the script would be disabled, and said "successfully installed":

Image Image
If the installer did fail, then I think it would be good to tell the user.

Also I think it would be good to make the 4.0.3 script uninstaller work, fixing the SQL errors. Meanwhile, FTR the workaround I used was to install the 3.9.4 script.

Thanks for your help.
Chris

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by gpzbc » Mon Apr 21, 2014 1:55 pm

Phew! My life has finally calmed down a bit (newborn baby) and I just got some time to install the update. I LOVE IT! This is definitely my favorite script. I love the new Custom Searches.

Thank you so much for updating this! It has become even more powerful.

Would anyone mind helping me understand?:
- "More PlayCount than in MM's internal History"
- "Less PlayCount than in MM's internal History"

More importantly, how do I resolve these?
--
The gpzbc

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by nynaevelan » Mon Apr 21, 2014 6:45 pm

gpzbc wrote:Phew! My life has finally calmed down a bit (newborn baby)
Congrats on the addition to your family. :D
gpzbc wrote: - "More PlayCount than in MM's internal History"
This means you have more plays in the playcount of the songs table than those in the playhistory table/field.
gpzbc wrote:- "Less PlayCount than in MM's internal History"
This is the opposite of the above, you now have more playcounts in the playhistory table/field than in the playcounts field in the songs table.
gpzbc wrote:More importantly, how do I resolve these?
You can resolve them both using Bex's Add Plays script. Depending on how you want to resolve them will depend on which feature you will use. For me when I have more playcounts, I usually use the Add Plays, Timestamp X. I usually get these when I sync my portable player.

To resolve the less plays I usually use the Adjust Only Playcounter/Set to Count of PlayHistory, though here I usually do not get too many of these.
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by gpzbc » Mon Apr 21, 2014 9:55 pm

@nynaevelan - thank you for the congrats, and for your help.

I have Bex's Add Plays script installed and do use it, but it has always been more of a trial and error process with very little understanding of what I am doing. Your explanation helps. In short, plays are tracked in two different counters; MM internal history, and the song table. Right? I guess mine are out of sync from when I played songs on my iPod. Now that I am using the latest, greatest MediaMonkey for Android that syncs play counts, this problem should go away for me... I think.

One last question if you don't mind. How do I resolve "Last Played Date" <> "Last Play History Date"? I can see how to use Bex's script to fix play counters, but how do I resolve play dates that are out of whack? EDIT: I see those options in the Add Plays script. Maybe I will post in that thread for questions about how to use those options.

Thanks again. I appreciate you helping me understand this.
--
The gpzbc

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by nynaevelan » Mon Apr 21, 2014 11:43 pm

gpzbc wrote:@nynaevelan - thank you for the congrats, and for your help.

I have Bex's Add Plays script installed and do use it, but it has always been more of a trial and error process with very little understanding of what I am doing. Your explanation helps. In short, plays are tracked in two different counters; MM internal history, and the song table. Right? I guess mine are out of sync from when I played songs on my iPod. Now that I am using the latest, greatest MediaMonkey for Android that syncs play counts, this problem should go away for me... I think.

One last question if you don't mind. How do I resolve "Last Played Date" <> "Last Play History Date"? I can see how to use Bex's script to fix play counters, but how do I resolve play dates that are out of whack? EDIT: I see those options in the Add Plays script. Maybe I will post in that thread for questions about how to use those options.

Thanks again. I appreciate you helping me understand this.
This one is a little tricky I do not always get results the first time around. So first I use SetLastPlayDate to LastHistoryPlay. Then I run the Tracks discrepancies again, for those that it was not able to fix, I just add a new play, which of course resolve the issue. And yes my discrepancies come from my player too.
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by gpzbc » Tue Apr 22, 2014 10:18 am

nynaevelan wrote:This one is a little tricky I do not always get results the first time around. So first I use SetLastPlayDate to LastHistoryPlay. Then I run the Tracks discrepancies again, for those that it was not able to fix, I just add a new play, which of course resolve the issue. And yes my discrepancies come from my player too.
I appreciate it. I spent some time scouring the Add/Remove PlayStat forum thread and was able to resolve all of my inconsistencies. All is good... everything except my OCD. This script is feeding it. :lol:
--
The gpzbc

GuidoR13
Posts: 14
Joined: Sun Mar 13, 2005 7:38 am

Tagging Inconsistencies Accent Inconsistencies

Post by GuidoR13 » Sat Nov 01, 2014 4:37 pm

Hello Bex,

this script is really on of my favorites, and it's getting better and better - thank you very much.

May it be possible to check with the accent inconsistencies for additional ones? I have in mind:
  • German Umlauts: "ä" (a-Umlaut) is often written as "ae" and sometimes as just "a", same for u-Umlaut (ü-ue-u) and o-Umlaut (ö-oe-o)
  • Also the German "ß" (&szlig;), this is found as "sz", "ss" and sometimes just "s"
  • Ligatures are generally something I go mad, just mentioning Æ, which is hopefully "ae" but sometimes only "a", I had it also as "ä"
Thanks, G.

mtp9
Posts: 3
Joined: Tue Jan 13, 2015 3:31 pm

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by mtp9 » Tue Jan 13, 2015 3:45 pm

Hi,

Firstly I would like to apologise for my question, as I am new to MM and I'm sure the answer is going to be something really simple.

I have installed this script, and it shows as installed under Tools > Extensions however I cannot find any trace of it under any sub menus (including right click, in the media tree etc) in order to use the script.

Would anyone be kind enough to help me resolve this.

Thank you.

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by gpzbc » Tue Jan 13, 2015 9:17 pm

Welcome!
Check under the Files to Edit node in the file tree.
Let us know if you have any other questions.
--
The gpzbc

mtp9
Posts: 3
Joined: Tue Jan 13, 2015 3:31 pm

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by mtp9 » Wed Jan 14, 2015 10:06 am

gpzbc wrote:Welcome!
Check under the Files to Edit node in the file tree.
Let us know if you have any other questions.
Thanks gpzbc, I didn't have the files to edit option but I found it after a bit of digging. I knew it would be something simple.

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Tagging Inconsistencies 4.0.1 (2014-02-27)

Post by gpzbc » Wed Jan 14, 2015 10:22 am

Sorry. I should have clarified that the Files to Edit sub-node is under the Entire Library node. But I'm glad you found it. This script is one of the more useful scripts. It feeds all of our obsessive compulsive disorders.
--
The gpzbc

Post Reply