RegExp Find & Replace 4.3 w/ 253 presets (2011-07-06) [MM2+]

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

ZvezdanD
Posts: 3084
Joined: Thu Jun 08, 2006 7:40 pm

Re: RegExp Find & Replace 4.3 w/ 253 presets (2011-07-06) [M

Post by ZvezdanD » Fri Feb 05, 2016 2:40 am

macmcd wrote:Error #424 - Microsoft VBScript runtime error
I still cannot reproduce this problem. Did you try the modified version that I sent you?
Magic Nodes 4.3.3 / 5.2 RegExp Find & Replace 4.4.9 / 5.2  Invert Selection/Select None 1.5.1  Export/Create Playlists for Child Nodes 4.1 / 5.4  Expand Child Nodes/Expand All 1.1.2  Event Logger 2.7  Filtered Statistics Report 1.6  Track Redirection & Synchronization 3.4.2  Restore/Synchronize Database 3.1.7 / 4.0  Find Currently Playing Track 1.3.2  Queue List 1.2.1  Add to Library on Play 1.0.1  Tree Report for Child Nodes 1.1.1  Update Location of Files in Database 1.4.3 / 2.2.2  Inherit Child Playlists 1.0.2  Add Currently Playing/Selected Track(s) to Playlist 1.1.2

macmcd
Posts: 95
Joined: Wed Jul 09, 2008 7:22 am

Re: RegExp Find & Replace 4.3 w/ 253 presets (2011-07-06) [M

Post by macmcd » Fri Feb 05, 2016 4:45 am

Sorry, I didn't see your email until today. Thanks very much for the update and I will try it today. Incidentally, I have always had so many error messages from MediaMonkey for years now. At the moment, I am experiencing continuos errors just scanning my music library for changed files which may have something to do with it possibly. I have reinstalled MM many times but I am still plagued with errors, crashes and the program not responding. I'll let you know how I get on.

ZvezdanD
Posts: 3084
Joined: Thu Jun 08, 2006 7:40 pm

Re: RegExp Find & Replace 4.3 w/ 253 presets (2011-07-06) [M

Post by ZvezdanD » Fri Feb 05, 2016 6:23 am

macmcd wrote:I have reinstalled MM many times but I am still plagued with errors, crashes and the program not responding.
I suppose your database is broken. In that case the reinstallation of the program hardly could help. Maybe you should start with the new database.
Magic Nodes 4.3.3 / 5.2 RegExp Find & Replace 4.4.9 / 5.2  Invert Selection/Select None 1.5.1  Export/Create Playlists for Child Nodes 4.1 / 5.4  Expand Child Nodes/Expand All 1.1.2  Event Logger 2.7  Filtered Statistics Report 1.6  Track Redirection & Synchronization 3.4.2  Restore/Synchronize Database 3.1.7 / 4.0  Find Currently Playing Track 1.3.2  Queue List 1.2.1  Add to Library on Play 1.0.1  Tree Report for Child Nodes 1.1.1  Update Location of Files in Database 1.4.3 / 2.2.2  Inherit Child Playlists 1.0.2  Add Currently Playing/Selected Track(s) to Playlist 1.1.2

TheMcShan
Posts: 24
Joined: Thu Dec 27, 2012 6:55 am

Re: RegExp Find & Replace 4.3 w/ 253 presets (2011-07-06) [M

Post by TheMcShan » Fri Feb 05, 2016 6:40 pm

Is it possible to make an action that removes all but the first artwork in files?

Peke
Posts: 12221
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: RegExp Find & Replace 4.3 w/ 253 presets (2011-07-06) [M

Post by Peke » Fri Feb 05, 2016 9:43 pm

yes use trixmoto Album Art Tagger from http://trixmoto.net/mm/scripts.php?id=1
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

macmcd
Posts: 95
Joined: Wed Jul 09, 2008 7:22 am

Re: RegExp Find & Replace 4.3 w/ 253 presets (2011-07-06) [M

Post by macmcd » Sun Feb 07, 2016 7:38 am

ZvezdanD wrote:
macmcd wrote:I have reinstalled MM many times but I am still plagued with errors, crashes and the program not responding.
I suppose your database is broken. In that case the reinstallation of the program hardly could help. Maybe you should start with the new database.
I've been using version 5.0.1.4 for a day or so with no errors until I had this one today:

With 45 TV shows selected, using preset 7 'Clear <Into Field>...' I swapped the 'Into:' field to 'Artist' selected 'Replace All' and then repeated the process with 'Album Artist'. With the window still open I noticed that some of the Artist field didn't appear to have been cleared so I reselected 'Artist' in the 'Into:' field and received the following error message:

Object required

Count=45
Index=46
Value=1

I cancelled the error message, quit and restarted RegExp F&R but had to select 'Replace All' a few times before the 'Artist' field was cleared. I then changed the 'Into:' field back to 'Album Artist' and received:

Object required

Count=45
Index=46
Value=45

The preview pane at the bottom of the window was still displaying the information for the 'Artist' field.

As to the database, unfortunately I have been having similar problems with multiple databases on multiple computers, so starting again probably won't help

ZvezdanD
Posts: 3084
Joined: Thu Jun 08, 2006 7:40 pm

Re: RegExp Find & Replace 4.3 w/ 253 presets (2011-07-06) [M

Post by ZvezdanD » Sun Feb 07, 2016 11:46 am

macmcd wrote:received the following error message:

Object required
Sorry, but I still cannot reproduce the problem. Please answer to the following questions:
- did you apply the mentioned action on files in some folder from My Computer or Location branches?
- if the answer to the previous question is yes, is that folder selected for Folder Monitoring?
- is the selected folder updated during replacement in background by the program in any way?
- did you do something with the program during replacement, e.g. selected another folder or files in the main filelist?
- did you click on the box showing the number of selected/visible files on the left side of the Find button?
- is that box showing the number of selected or visible files when you got the error?
- could you reproduce the same problem always with the same files using the same actions?
- could you try to reproduce the problem with turned off the "Display of tracks ... synchronized with main window" option?
- could you make a video of your desktop showing the action that leads to the error using some video capture software, e.g. HyperCam?
- could you upload your database to some file server like Dropbox, so I could try to reproduce your problem?

Question to all: is there anybody else having the similar problem?
Magic Nodes 4.3.3 / 5.2 RegExp Find & Replace 4.4.9 / 5.2  Invert Selection/Select None 1.5.1  Export/Create Playlists for Child Nodes 4.1 / 5.4  Expand Child Nodes/Expand All 1.1.2  Event Logger 2.7  Filtered Statistics Report 1.6  Track Redirection & Synchronization 3.4.2  Restore/Synchronize Database 3.1.7 / 4.0  Find Currently Playing Track 1.3.2  Queue List 1.2.1  Add to Library on Play 1.0.1  Tree Report for Child Nodes 1.1.1  Update Location of Files in Database 1.4.3 / 2.2.2  Inherit Child Playlists 1.0.2  Add Currently Playing/Selected Track(s) to Playlist 1.1.2

Hdhntr23
Posts: 77
Joined: Tue Nov 27, 2012 10:21 am

Re: RegExp Find & Replace 4.3 w/ 253 presets (2011-07-06) [M

Post by Hdhntr23 » Mon Feb 15, 2016 7:01 pm

Hey guys...

I am currently (yes again if you follow this thread) running thru my library and getting all the song titles capitalized. I think the shortcut preset is #235.

I want to add some exceptions though... for example: "CD", "iTunes" and "DJ" can anyone tell me how I would go about editing the preset and adding exceptions please?

I would really appreciate it!

Thanks!

MMFrLife
Posts: 2774
Joined: Fri Oct 26, 2012 9:04 pm

Re: Clearing Tag Fields?

Post by MMFrLife » Fri Feb 19, 2016 6:07 am

This is Clearing Tag FIelds? continued from here
ZvezdanD wrote:MMFrLife, you should have posted a new post instead of editing the old one, because I didn't get the report about it in the e-mail and could not know about it if Eyal didn't have a new post in this thread. Besides, I suggest that your questions regarding RegExp should be posted in the related forum, not here.
Sorry, since it didn't specifically start out as a RegExpF&R question, I got a bit side-tracked.
I did think about a new post, but I didn't bother because I came back to it fairly quick.
I didn't realize your primary way of returning is via e-mail notification through the add-on
thread and not just occassional perusal. Good to know :)
ZvezdanD wrote:
MMFrLife wrote:The toolbar button option is really a menu item that is button-like. Is there a way to get it to show as it's own button/icon next
to the add-on/preset menu buttons? I associated an icon with it.
I don't understand what you are talking. Every preset that has the Toolbar option turned on would get its own toolbar button in the same row as "RegExp Find and Replace" and "RegExp Tagging Presets" toolbar buttons. If you are talking about the "RegExp Tagging Presets" button, yes indeed, you would get the dropdown menu when you click on it, but that was always the case, even with the last freely available version of the add-on; the only difference is that that new menu has added several add-on options beside of the preset groups.
There is no issue with the drop-down menu. I very much love it. It was merely written
as an intro statement to set the scene for the issue/point I was
trying to figure out. The button issue is discussed below.
ZvezdanD wrote:
MMFrLife wrote:is it possible, using the same or a similar method as employed in the above example, to batch together presets that are different (not based on the same
core preset)?
Yes, of course. You just need to specify the same batch using the Menu option. Please read the Usage section of the Web page of the new version, if you didn't already, since it has the information about batches.
I tried this previous to your reply and managed to associate a different one
with an already existing batch without any error or hiccup. However, the different one
added just doesn't do anything. Taking into account what you say below about
presets for text fields and presets with numerical values, I think that is the issue.
I tried to add auto-increment track # with specified start value and leading zero preset to the Clear Fields batch. Can I alter it
with a value somehow to get it to work in batch with the Clear Fields text one, similar to your advice about
the ratings one that has now been resolved, as stated below?
ZvezdanD wrote:
MMFrLife wrote:1.) I got the icon button to show on the toolbar for the Clear Fields batch. However, in button/icon form, it only performs the function of the first
preset in the batch :( . It works fine on the menu.
I think that I implemented it, but if you say so I will fix it in the next update.
I tried testing this out some more to be sure and for some strange reason the toolbar buttons aren't showing up at all now,
even after restart. I currently have all the toolbar button setings in options checked and have tried various setting combos
for them to no avail. I'll keep messing around with it and see if I can get it to work. Any suggestions could be helpful.
ZvezdanD wrote:
MMFrLife wrote:2.) When I try to add Lyricist to the clear batch it says that it already exists, but the preset it points to is about Lyrics not Lyricist and its find mask is
significantly different than the clear field one. It points to, Clear Lyrics greater than x line(s) but less than y lines.... It asks me if I want to modify this.
I say no, thinking it will still add what I want to the clear field batch without modifying the other one it points to, but it does not add it :( . What to do?
I am not sure, but I suppose that you are talking about the auto-complete behavior of combo boxes of the program, which is something that I cannot change. As you type the name of the preset the program will auto-suggests the name of the first existing preset that has the same begin as the typed one, in this case "Clear Lyric..." When that happen, i.e. when the program completes what you are typing with the name of some existing preset, you should delete the added text and continue with typing.
I know about auto-complete and typing over. It is not the issue here. The problem preset name only comes up in the "already exists" message, not in the name field as an
auto-complete. I got this to work before your reply. I tried it on several different ones in the Clear batch
but oddly could only achieve it by going to the conflict one
(Clear lyrics greater than x.....) and creating the new one (Clear Lyrics), by delete then cut/paste info
from Clear field preset, on top of it. I ticked batch and put it on the appropriate batch menu, and "presto chango!".

btw, the "already exists" messages also occured on about a quarter of the Clear Field
presets when I was creating them (it would point to other presets I created for the same batch), whether I went back
and created the new one on top of the first one or any of the others.
Again, oddly, I solved the issue by creating the new one on top of the "conflict" (already existing) preset.

ZvezdanD wrote:
MMFrLife wrote:3.) I added clear rating to the batch. When the batch is executed, it has an error/problem if rating is originally "-1" (unknown). It asks me,
ok - abort - retry - ignore - ignore to all. When I choose ignore to all it does not work. I have to ignore for each track :( . For other fields that are already empy and don't use a number value, they reclear just fine. Is there a way to get empty fields with values to do that without a hiccup in the batch
process? It may do this if there is any value in the field. I haven't tried anything else with rating yet. I'll test and edit back here. [EDIT] Yes, the error occurs for all
ratings values. Error shows a value of -1 for unknown, 5 for 0, 20 for 1 star, 40 for 2 star, etc.. Anyway, natively in MM (properties) if tracks are selected with unknown
track ratings and check box is selected for unknown (not that you would bother checking it if all tracks were unknown, and that's what you wanted, but still), it just seems
to skip over (no hiccup). If tracks are selected with various ratings, including some unknown, it also just seems to skip over (no hiccup) the unknowns and clear the rated ones if box is checked for unkown.
It's not a batch issue either. For rating preset, I toggled the batch off and renamed the preset menu to single it out, but I got the same error/result.
I am lost here with your description. I suppose you have a problem only when trying to clear the Rating field, right? The "Clear <Into Field>" preset that I suggested as a pattern for this batch is applicable only for textual fields, which Rating is not. If you want to clear Rating, i.e. to make it unknown, you should specify -1 in the Replace with combo box.
Eureka! The "-1" mod is all I needed. Thanks!
I was also having the problem on BPM (except you can ignore all instead of each one). They both work now and are batched to the other text presets. :D
MM user since 2003 (lifetime since 2012) "Trying to imagine life without music gives me a headache"
track properties; dir/fn mask configurations; check out ZvezdanD's scripts
MMW 4.1.18.1842b; fav scripts > RegExp Find & Replace 5.1.0; Magic Nodes 5.1.0; Advanced Duplicate Find & Fix 3.8.2;
Backup 6.0; Clear Now Playing Button 1.2
...always back it up, especially before doing anything major!!!
Win. explorer alt. for power users [free]; great file/folder renamer [used by nasa]

ZvezdanD
Posts: 3084
Joined: Thu Jun 08, 2006 7:40 pm

Re: Clearing Tag Fields?

Post by ZvezdanD » Fri Feb 19, 2016 7:42 am

MMFrLife wrote:I did think about a new post, but I didn't bother because I came back to it fairly quick.
You didn't came back quick enough, because I already read your initial post when you said that everything is working fine and I though that that case is resolved and closed, so I had no reason to open and read the same thread again.
MMFrLife wrote:I tried this previous to your reply and managed to associate a different one
with an already existing batch without any error or hiccup. However, the different one
added just doesn't do anything. Taking into account what you say below about
presets for text fields and presets with numerical values, I think that is the issue.
I tried to add auto-increment track # with specified start value and leading zero preset to the Clear Fields batch. Can I alter it
with a value somehow to get it to work in batch with the Clear Fields text one, similar to your advice about
the ratings one that has now been resolved, as stated below?

...

I tried testing this out some more to be sure and for some strange reason the toolbar buttons aren't showing up at all now,
even after restart. I currently have all the toolbar button setings in options checked and have tried various setting combos
for them to no avail. I'll keep messing around with it and see if I can get it to work. Any suggestions could be helpful.

...

I know about auto-complete and typing over. It is not the issue here. The problem preset name only comes up in the "already exists" message, not in the name field as an
auto-complete. I got this to work before your reply. I tried it on several different ones in the Clear batch
but oddly could only achieve it by going to the conflict one
(Clear lyrics greater than x.....) and creating the new one (Clear Lyrics), by delete then cut/paste info
from Clear field preset, on top of it. I ticked batch and put it on the appropriate batch menu, and "presto chango!".

btw, the "already exists" messages also occured on about a quarter of the Clear Field
presets when I was creating them (it would point to other presets I created for the same batch), whether I went back
and created the new one on top of the first one or any of the others.
Again, oddly, I solved the issue by creating the new one on top of the "conflict" (already existing) preset.
I am sorry, I would really like to fix all bugs, but from your description I cannot conclude what are the issues. Maybe it could help if you send me an e-mail with your MediaMonkey.ini file or your all exported working presets. Also, it would be nice if you tell me how I could reproduce the issues step by step.
MMFrLife wrote:Eureka! The "-1" mod is all I needed. Thanks!
I was also having the problem on BPM (except you can ignore all instead of each one). They both work now and are batched to the other text presets. :D
If they both work with other text presets in the same batch, then it is a proof that you could have a batch preset containing several presets that have different pattern preset, right? So, there is no reason that you cannot add "Auto-increment track #" or any other preset to the same batch. However, if you read the Usage section of the new version you could find this:

"Keep in mind that all presets should have unique names, even presets assigned to some batch group. So, if you want to assign some existing non-batch preset to some batch group and to keep the same preset to the existing menu group, you should rename the new preset assigned to the batch to make its name unique, e.g. you could append the " (Batch)" text to it.

If you start execution of some batch, you will not get the adjustment dialog boxes for any containing preset, even if you have turned on the Show dialog box for adjusting of the preset selected in the menu or toolbar option in the Options dialog box. This means that all presets assigned to batches should have all parameters already set using the corresponding tags in the Find what and Replace with strings, also you should have saved source and/or destination fields (if they are applicable) with the Into and From combo boxes set in the Preset Settings dialog box accordingly."
Magic Nodes 4.3.3 / 5.2 RegExp Find & Replace 4.4.9 / 5.2  Invert Selection/Select None 1.5.1  Export/Create Playlists for Child Nodes 4.1 / 5.4  Expand Child Nodes/Expand All 1.1.2  Event Logger 2.7  Filtered Statistics Report 1.6  Track Redirection & Synchronization 3.4.2  Restore/Synchronize Database 3.1.7 / 4.0  Find Currently Playing Track 1.3.2  Queue List 1.2.1  Add to Library on Play 1.0.1  Tree Report for Child Nodes 1.1.1  Update Location of Files in Database 1.4.3 / 2.2.2  Inherit Child Playlists 1.0.2  Add Currently Playing/Selected Track(s) to Playlist 1.1.2

MMFrLife
Posts: 2774
Joined: Fri Oct 26, 2012 9:04 pm

Re: Clearing Tag Fields?

Post by MMFrLife » Fri Feb 19, 2016 8:44 am

ZvezdanD wrote:I am sorry, I would really like to fix all bugs, but from your description I cannot conclude what are the issues. Maybe it could help if you send me an e-mail with your MediaMonkey.ini file or your all exported working presets. Also, it would be nice if you tell me how I could reproduce the issues step by step.
You're doing fine :wink: Bug? Maybe. It feels though, like I'm probably just doing some little something wrong that I annoyingly can't figure out :-? . Let me work on it
some more and see if I can solve it. If not, I'll get back to ya. :)
ZvezdanD wrote:
MMFrLife wrote:Eureka! The "-1" mod is all I needed. Thanks!
I was also having the problem on BPM (except you can ignore all instead of each one). They both work now and are batched to the other text presets. :D
If they both work with other text presets in the same batch, then it is a proof that you could have a batch preset containing several presets that have different pattern preset, right? So, there is no reason that you cannot add "Auto-increment track #" or any other preset to the same batch. However, if you read the Usage section of the new version you could find this:

"Keep in mind that all presets should have unique names, even presets assigned to some batch group. So, if you want to assign some existing non-batch preset to some batch group and to keep the same preset to the existing menu group, you should rename the new preset assigned to the batch to make its name unique, e.g. you could append the " (Batch)" text to it.

If you start execution of some batch, you will not get the adjustment dialog boxes for any containing preset, even if you have turned on the Show dialog box for adjusting of the preset selected in the menu or toolbar option in the Options dialog box. This means that all presets assigned to batches should have all parameters already set using the corresponding tags in the Find what and Replace with strings, also you should have saved source and/or destination fields (if they are applicable) with the Into and From combo boxes set in the Preset Settings dialog box accordingly."
Your word that it should work, from the earlier post, was proof enough for me. I trust you. All I needed to know was "how" to make it work.
The "-1" mod for rating and BPM did that. But my "only" concern when I batched the "Auto-increment" preset to the text ones is whether it also needs to be modified numerically
in some way before it will work, similar to how the rating/BPM presets had to have the Replace With field modified (like I said before, the "attatchement to the batch" aspect worked and it "rode along" with the other presets when executed without hiccup. It just didn't perform the Auto-increment funtion)? I already know about unique names (I've used things like (batch 1) on some presets already), setting Find What & Replace With and To and From boxes, and that the adjustment dialog box doesn't pop up when executing batch.

Again, let me just take some more time with it and I'll get back to ya. Thanks for your help.
MM user since 2003 (lifetime since 2012) "Trying to imagine life without music gives me a headache"
track properties; dir/fn mask configurations; check out ZvezdanD's scripts
MMW 4.1.18.1842b; fav scripts > RegExp Find & Replace 5.1.0; Magic Nodes 5.1.0; Advanced Duplicate Find & Fix 3.8.2;
Backup 6.0; Clear Now Playing Button 1.2
...always back it up, especially before doing anything major!!!
Win. explorer alt. for power users [free]; great file/folder renamer [used by nasa]

ZvezdanD
Posts: 3084
Joined: Thu Jun 08, 2006 7:40 pm

Re: Clearing Tag Fields?

Post by ZvezdanD » Fri Feb 19, 2016 10:15 am

MMFrLife wrote:The "-1" mod for rating and BPM did that. But my "only" concern when I batched the "Auto-increment" preset to the text ones is whether it also needs to be modified numerically
in some way before it will work, similar to how the rating/BPM presets had to have the Replace With field modified (like I said before, the "attatchement to the batch" aspect worked and it "rode along" with the other presets when executed without hiccup. It just didn't perform the Auto-increment funtion)?
The "-1" "mod" is just another value for another preset since Rating and BPM (and Track/Album Volume and some others) are numerical fields that cannot be empty like textual ones. You don't need to "mod" any existing preset to be able to add it to some batch. You could include any existing preset unmodified to your batches, as long as you take in consideration my suggestion about renaming them. Such presets should execute in batches as they execute when applied alone.

So, if your own batch doesn't perform the included Auto-increment preset, then it is a bug and in that case I really would like to get your MediaMonkey.ini file to try to reproduce the problem. Did you turn on the Batch option to that preset? When you hover a mouse pointer over the batch name in the menu, do you see the Auto-increment preset in the list in the hint balloon?
Magic Nodes 4.3.3 / 5.2 RegExp Find & Replace 4.4.9 / 5.2  Invert Selection/Select None 1.5.1  Export/Create Playlists for Child Nodes 4.1 / 5.4  Expand Child Nodes/Expand All 1.1.2  Event Logger 2.7  Filtered Statistics Report 1.6  Track Redirection & Synchronization 3.4.2  Restore/Synchronize Database 3.1.7 / 4.0  Find Currently Playing Track 1.3.2  Queue List 1.2.1  Add to Library on Play 1.0.1  Tree Report for Child Nodes 1.1.1  Update Location of Files in Database 1.4.3 / 2.2.2  Inherit Child Playlists 1.0.2  Add Currently Playing/Selected Track(s) to Playlist 1.1.2

MMFrLife
Posts: 2774
Joined: Fri Oct 26, 2012 9:04 pm

Re: RegExp Find & Replace 4.3 w/ 253 presets (2011-07-06) [M

Post by MMFrLife » Fri Feb 19, 2016 7:47 pm

Ok, good news, I'm making some progress on solving the issues :) . Before I get into/get back to that, first (and only) answer me this:
ZvezdanD wrote:You don't need to "mod" any existing preset to be able to add it to some batch. You could include any existing preset unmodified to your batches
Give me an example of a numerical preset that I can use to clear rating, one that doesn't have to be modified. Just give me the name of it. Don't explain it.
I'll test it out and then get back to you if I have a problem. Thanks
MM user since 2003 (lifetime since 2012) "Trying to imagine life without music gives me a headache"
track properties; dir/fn mask configurations; check out ZvezdanD's scripts
MMW 4.1.18.1842b; fav scripts > RegExp Find & Replace 5.1.0; Magic Nodes 5.1.0; Advanced Duplicate Find & Fix 3.8.2;
Backup 6.0; Clear Now Playing Button 1.2
...always back it up, especially before doing anything major!!!
Win. explorer alt. for power users [free]; great file/folder renamer [used by nasa]

ZvezdanD
Posts: 3084
Joined: Thu Jun 08, 2006 7:40 pm

Re: RegExp Find & Replace 4.3 w/ 253 presets (2011-07-06) [M

Post by ZvezdanD » Sat Feb 20, 2016 3:52 am

MMFrLife wrote:Ok, good news, I'm making some progress on solving the issues :) . Before I get into/get back to that, first (and only) answer me this:
ZvezdanD wrote:You don't need to "mod" any existing preset to be able to add it to some batch. You could include any existing preset unmodified to your batches
Give me an example of a numerical preset that I can use to clear rating, one that doesn't have to be modified. Just give me the name of it. Don't explain it.
I'll test it out and then get back to you if I have a problem. Thanks
I said you could include unmodified presets, but that doesn't mean that you should do that, i.e. that some preset should be included unmodified. There are many presets that cannot be used unmodified in every situation. For example, you _could_ include the unmodified Auto-increment preset with its default settings which have the starting value = 1, but you _should not_ use it unmodified if you want some another starting value.

I don't understand why you want that I give you an example with some "numerical preset". I already told you what you should do to create preset which could "clear" the Rating filed, i.e. to set it to "unknown" state, and you confirmed that it works fine. If you really want to use some another existing preset to do that, you could use e.g. the "Reset Peak Value field" preset which has the same all settings including the Replace with string (-1), but different Into field.

By the way, the "unknown" state is not the same for all numerical fields. It is -1 for Rating, BPM, Peak Value, Year, Original Year and maybe some others, but it is e.g. -999999 for Track and Album Volume. It is MM interpretation, not mine.
Magic Nodes 4.3.3 / 5.2 RegExp Find & Replace 4.4.9 / 5.2  Invert Selection/Select None 1.5.1  Export/Create Playlists for Child Nodes 4.1 / 5.4  Expand Child Nodes/Expand All 1.1.2  Event Logger 2.7  Filtered Statistics Report 1.6  Track Redirection & Synchronization 3.4.2  Restore/Synchronize Database 3.1.7 / 4.0  Find Currently Playing Track 1.3.2  Queue List 1.2.1  Add to Library on Play 1.0.1  Tree Report for Child Nodes 1.1.1  Update Location of Files in Database 1.4.3 / 2.2.2  Inherit Child Playlists 1.0.2  Add Currently Playing/Selected Track(s) to Playlist 1.1.2

MMFrLife
Posts: 2774
Joined: Fri Oct 26, 2012 9:04 pm

Re: RegExp Find & Replace 4.3 w/ 253 presets (2011-07-06) [M

Post by MMFrLife » Sat Feb 20, 2016 4:52 am

Sorry, I misunderstood. I thought you were saying that I would'nt need to modify any preset "at any stage". You were just saying that I did'nt need to
modify a preset "just to add it". And yes, I already got it to work (as noted in earlier posts) by using the -1 to execute proper functioning, not just to add it.

But it turns out there is at least one that is already set (not counting the field menu modification, treated as a given) with the proper string
ZvezdanD wrote:Reset Peak Value field" preset which has the same all settings including the Replace with string (-1), but different Into field.
and also very interesting to know.
ZvezdanD wrote:By the way, the "unknown" state is not the same for all numerical fields. It is -1 for Rating, BPM, Peak Value, Year, Original Year and maybe some others, but it is e.g. -999999 for Track and Album Volume. It is MM interpretation, not mine.
I think, for the most part, I have everything worked out. Let me work on it a little more and I'll return with conclusions and/or any unresolved issues.
Thanks!
MM user since 2003 (lifetime since 2012) "Trying to imagine life without music gives me a headache"
track properties; dir/fn mask configurations; check out ZvezdanD's scripts
MMW 4.1.18.1842b; fav scripts > RegExp Find & Replace 5.1.0; Magic Nodes 5.1.0; Advanced Duplicate Find & Fix 3.8.2;
Backup 6.0; Clear Now Playing Button 1.2
...always back it up, especially before doing anything major!!!
Win. explorer alt. for power users [free]; great file/folder renamer [used by nasa]

Post Reply