Discogs Tagger 3.62 (Updated: 2013-02-09)

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

steviegt
Posts: 311
Joined: Tue Mar 17, 2009 8:39 am

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by steviegt » Sat Feb 02, 2013 1:34 pm

I just did a clean install of Win 7 HP 64bit and all software includin MM. I've used the new .mmip file and done a copy/paste of .vbs info and Discogs doesn't even show in the Options menu. Neither does MusicBrainz. I've done restarts and reboots with no success. This is a new one for me. Both scripts do show up in the Extentions menu. Any suggestions?

****Update****

I uninstalled the 2 scripts and reinstalled them but this time I left the check in (selected) fo install for individual user only and both now work fine. I don't think it should make a difference but that's what fixed the problem.
MMW Gold Lifetime v4.1.21.11875
MM Pro Android v1.3.2.0824
Windows Home 10.0.17134.228 64-bit Build 1803
MS Edge


Next to MediaMonkey, the best program available: Total Commander http://www.ghisler.com/

"Being mean to someone takes more effort than being nice to them"

crap_inhuman
Posts: 674
Joined: Sat Jan 26, 2013 6:00 am
Location: Friedberg / Hessen / Germany
Contact:

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by crap_inhuman » Sat Feb 02, 2013 7:40 pm

coulz wrote:Thanks crap_inhuman for this new version with some interesting features.
I noticed a problem though. When I want to tag a track which is a featuring, I've got the "feat" in the artist field duplicated (e.g: xxxx Feat. yyyyy -> xxxx Feat. yyyy ft. yyyy). I guess this is related to your new feature "feat. Artist behind title" because when I check this box, it works as expected in most cases.

Also noticed that this problem only happens when the Featuring credits are mentionned for the track on Discogs.
Hi coulz,

thanks for your reply. I will fix it asap, but first i have to cure a bad cold. With that i can't hear myself think...
Metal up your ass !
-----------------------------------------------
I added my first 2 videos on youtube. The language is german.

Discogs Autorisierung: https://www.youtube.com/watch?v=oryxKKtnEnc
Discogs Tagger Bedienung: https://www.youtube.com/watch?v=85Wk-5rd-W0

crap_inhuman
Posts: 674
Joined: Sat Jan 26, 2013 6:00 am
Location: Friedberg / Hessen / Germany
Contact:

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by crap_inhuman » Tue Feb 05, 2013 7:44 am

I build a new version of the script. Here are the changes:

Changes from 3.5 to 3.6 by crap_inhuman in 02.2013
Implementation of eepman's great JSON-Parser
Now read the user-specific Separator characters and use it for separating
Label / Artist / Master Search now using the JSON Parser too
Some bugfixes

Get only the script-file here : http://www.germanc64.de/DiscogsAutoTagWeb.vbs

Here the "normal" installation mmip-file http://www.germanc64.de/mm/DiscogsAutoTagWeb.mmip

If you installed the previous Version 3.5 you can also use the Update-Function in MediaMonkey.

Thanks to eepman for the great Parser !

Please report bugs, wanted features,... in this forum, thank you !!
Metal up your ass !
-----------------------------------------------
I added my first 2 videos on youtube. The language is german.

Discogs Autorisierung: https://www.youtube.com/watch?v=oryxKKtnEnc
Discogs Tagger Bedienung: https://www.youtube.com/watch?v=85Wk-5rd-W0

crap_inhuman
Posts: 674
Joined: Sat Jan 26, 2013 6:00 am
Location: Friedberg / Hessen / Germany
Contact:

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by crap_inhuman » Tue Feb 05, 2013 8:03 am

coulz wrote:Thanks crap_inhuman for this new version with some interesting features.
I noticed a problem though. When I want to tag a track which is a featuring, I've got the "feat" in the artist field duplicated (e.g: xxxx Feat. yyyyy -> xxxx Feat. yyyy ft. yyyy). I guess this is related to your new feature "feat. Artist behind title" because when I check this box, it works as expected in most cases.

Also noticed that this problem only happens when the Featuring credits are mentionned for the track on Discogs.
Hi coulz,

i tested the script with some Releases but didn't see the effect you reported. I didn't tested the "right" Release i think.
Do you have a Release-Number from a Discogs-Release where the bug occur ? With a Release-Number it is much easier to find the *$&%* bug :wink:

Regards
crap_inhuman
Last edited by crap_inhuman on Fri Feb 08, 2013 6:55 am, edited 1 time in total.
Metal up your ass !
-----------------------------------------------
I added my first 2 videos on youtube. The language is german.

Discogs Autorisierung: https://www.youtube.com/watch?v=oryxKKtnEnc
Discogs Tagger Bedienung: https://www.youtube.com/watch?v=85Wk-5rd-W0

neofolk

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by neofolk » Wed Feb 06, 2013 6:19 am

Hi,

First Very good work!

I tried your script but i 've got difficulty with accent. Indeed, all special caracters are replace with � in title and result content.

All special char like é à î Î ê etc...

How can i made the change?

crap_inhuman
Posts: 674
Joined: Sat Jan 26, 2013 6:00 am
Location: Friedberg / Hessen / Germany
Contact:

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by crap_inhuman » Wed Feb 06, 2013 6:14 pm

Hi neofolk,

i tested the script with special (german) characters and there were no problem. Can you give me a Discogs Release Number to check ? That would be very useful !

Regards,
Sven
Metal up your ass !
-----------------------------------------------
I added my first 2 videos on youtube. The language is german.

Discogs Autorisierung: https://www.youtube.com/watch?v=oryxKKtnEnc
Discogs Tagger Bedienung: https://www.youtube.com/watch?v=85Wk-5rd-W0

neofolk

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by neofolk » Fri Feb 08, 2013 8:21 am

Hello,
Now, It's ok on discogs after reboot. But I've got problem with amazon FR script.

I don't know why...

Thanks for your answer.

Regards,

crap_inhuman
Posts: 674
Joined: Sat Jan 26, 2013 6:00 am
Location: Friedberg / Hessen / Germany
Contact:

Re: Discogs Tagger 3.62 (Updated: 2013-02-09)

Post by crap_inhuman » Sat Feb 09, 2013 3:48 am

I released a new Version of the Discogs-Script

Changes from 3.6 to 3.61 by crap_inhuman in 02.2013
Removed a bug in the option 'Featuring Artist behind title'
Better implementation of the option 'Featuring Artist behind title'
Inserting Master and Release URLs now work in the Search-Panel

Changes from 3.61 to 3.62 by crap_inhuman in 02.2013
Insert code for supporting french language machines
Removed bug: Comments will now be saved
Delete some unused but declared variables
New Name for ArtistRole (feat. or ft. or featuring, or whatever) can be edit (The Renaming of the ArtistRole is selectable)
The Renaming of "Various" Artists (Various Artists) is now selectable
Some small bugfixes

For Upgrading the script:
Use the MM updater (Tools->Extensions->Find Updates)

For installing the script:
Download the mmip-File http://www.germanc64.de/mm/DiscogsAutoTagWeb.mmip

Please report bugs, weird responses from discogs, feature request,... in this forum !

Happy tagging ;-)
Metal up your ass !
-----------------------------------------------
I added my first 2 videos on youtube. The language is german.

Discogs Autorisierung: https://www.youtube.com/watch?v=oryxKKtnEnc
Discogs Tagger Bedienung: https://www.youtube.com/watch?v=85Wk-5rd-W0

Simple_Man
Posts: 7
Joined: Sat Aug 27, 2011 3:55 pm

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by Simple_Man » Sat Feb 09, 2013 4:44 am

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by steviegt » Sat Feb 02, 2013 11:34 am
I just did a clean install of Win 7 HP 64bit and all software includin MM. I've used the new .mmip file and done a copy/paste of .vbs info and Discogs doesn't even show in the Options menu. Neither does MusicBrainz. I've done restarts and reboots with no success. This is a new one for me. Both scripts do show up in the Extentions menu. Any suggestions?

****Update****

I uninstalled the 2 scripts and reinstalled them but this time I left the check in (selected) fo install for individual user only and both now work fine. I don't think it should make a difference but that's what fixed the problem.

I've encountered a similar issue. Just got W8 on a new touch (but haven't used the touch much). I installed MM 4.07.151 from MM site I then installed add-ons of Discogs and Musicbrainz both from MM site. I'm not positive if I tried to find them in the options box of web autotagger first or shut down MM and then looked for them n the options box. But they were not there although they were listed in the Extensions menu with only option to uninstall. Uninstalled and opened MM as admin installing both. They were then both in the options box. Discogs worked, Amazon was it's usual self and Musicbrainz wasn't connecting. I must've shut MM down with it in Discogs mode because when I opened up MM and went to autotag from web it immediately came up but it was not in the options box nor was Musicbrainz (yet in Extensions menu). When I switched to Amazon it would not work and I could not get back to Discogs search mode. (A side note using discogs I was tagging the Decemberists Her Majesty album because I knew this was a solid album and worked in any search option with artwork. Except Discogs offered me the artwork box which I chose and it wiped out my albumcover). My background is code stupid :oops: . That being said I with lots of time and patience usually can figure out what the solutions/work arounds posted are and stumble around, amazing myself when I get the changes to work :o
I don't need to autotag from web, although I really appreciate everyone in this communities efforts and sing MM praises to anyone who will listen :wink: It is one of the features among others that made me a MM lifer. As part of the greatness of MM it is always adapting and progressing (amazing how far it's come!) so I will keep an eye out for a partial english partial code speak that I can figure out. Or hear from someone what boneheaded move I've made. Also having issues getting Last.fm scrobbler (no portable install here:-) to work but I know this is not the place (nor the time as I can mess with it more before I come crawling back for help. Thanks for all of your efforts!

btw I liked the quote about the effort it takes to be cruel vs. being kind - I'd like to add to that thought that the ripple effect one can have by just making someone smile (and vice versa) can be mind-blowing. I picked up an elderly woman hitch-hiking, had to help her into my ride and convinced me to take a day to have a focused determination to bring as many smiles to strangers (or people we don't know as 'her grandmother taught her there are no strangers just people we hadn't met yet') faces. I was unemployed at the time and kind of bummed. Spending the day with that focus was one of the happier days I'd had in some time. that's the end of my sappy tale. no more cheese. :wink:

rovingcowboy
Posts: 14153
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by rovingcowboy » Sat Feb 09, 2013 9:12 am

And i thought i was long winded?
:lol: :lol:

So trouble with last fm simple man? Sorry i cant help on that but i think peke should help i believe he made the last fm script?
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy 5 Android 5) 6. Proscan tablet Android 4.3 ) 7. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.

charlieMOGUL
Posts: 168
Joined: Fri Mar 11, 2005 5:26 am

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by charlieMOGUL » Sun Feb 17, 2013 8:41 pm

Simple_Man wrote: btw I liked the quote about the effort it takes to be cruel vs. being kind - I'd like to add to that thought that the ripple effect one can have by just making someone smile (and vice versa) can be mind-blowing. I picked up an elderly woman hitch-hiking, had to help her into my ride and convinced me to take a day to have a focused determination to bring as many smiles to strangers (or people we don't know as 'her grandmother taught her there are no strangers just people we hadn't met yet') faces. I was unemployed at the time and kind of bummed. Spending the day with that focus was one of the happier days I'd had in some time. that's the end of my sappy tale. no more cheese. :wink:
Thanks for the positive ripple... you made someone 'you haven't met yet' smile as well :D

charlieMOGUL

tobstarrr

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by tobstarrr » Sun Mar 03, 2013 4:10 pm

I receive Error #13 - Microsoft VBScript runtime error
Type mismatch: 'CDbl'
File: "C:\....\MediaMonkey\Scripts\DiscogsAuto TagWeb.vbs", Line: 243, Column: 4

when running Discogs Tagger 3.6.2

tobstarrr

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by tobstarrr » Sun Mar 03, 2013 4:28 pm

tobstarrr wrote:I receive Error #13 - Microsoft VBScript runtime error
Type mismatch: 'CDbl'
File: "C:\....\MediaMonkey\Scripts\DiscogsAuto TagWeb.vbs", Line: 243, Column: 4

when running Discogs Tagger 3.6.2
Had a look at the script and line 243 is: ParseValue = CDbl(Replace(ms(0),".",","))

i did some backreading and saw that our french friend seemed to have some problems with this code too. I don't know the language that well to know what this line is doing.
i'm using Win7 in english with swiss.german as keyboard language setting. Maybe related.

If anybody has an idea how i can fix this it is much appreciated.
After the error message, Auto-Tag opens and also shows me results in the drop down but no information about the release in the main window.
If i choose a release, the same error message appears.

achmetinternet
Posts: 18
Joined: Sat Jan 09, 2010 7:51 am

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by achmetinternet » Tue Mar 05, 2013 5:48 pm

Works perfectly!

coulz
Posts: 3
Joined: Wed Jan 16, 2013 3:10 pm

Re: Discogs Tagger 3.3 (Updated: 2011-11-10)

Post by coulz » Tue Mar 12, 2013 7:44 am

tobstarrr wrote:I receive Error #13 - Microsoft VBScript runtime error
Type mismatch: 'CDbl'
File: "C:\....\MediaMonkey\Scripts\DiscogsAuto TagWeb.vbs", Line: 243, Column: 4

when running Discogs Tagger 3.6.2
Hi, your error is kinda weird because in Swiss, I think you use either a comma or a dot as a decimal separator.

Check your settings under Control Panel (take a look right here) and change if needed the decimal separator.

If it is not that, I don't know the issue, sorry.
tobstarrr wrote: I don't know the language that well to know what this line is doing.
That line changes the "," separator into a "." separator, since it returns a decimal number. Needed for guys whose machine uses the comma as a decimal separator. You can also replace the "," in this line with your decimal separator if you don't want to change the settings under Control Panel.

Post Reply