Backup 6.0 - Updated 01/07/2014

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Re: Backup 5.8 - Updated 27/10/2010

Post by nynaevelan » Mon Aug 22, 2011 10:07 am

-SuperFunk- wrote:The directory exists.
Is there an easy way to check the access?
Right click on the folder and click properties and click the security tab, it should tell you whether you have access to it.
-SuperFunk- wrote:EDIT: and it is weird that the Backup script doesn't show in the script-section under 'extra' :(
It shows up on the Standard toolbar and in the Tools - Scripts section, what do you mean 'extra'??

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

-SuperFunk-
Posts: 45
Joined: Tue Aug 05, 2008 4:16 pm

Re: Backup 5.8 - Updated 27/10/2010

Post by -SuperFunk- » Mon Aug 22, 2011 10:28 am

ah what i mean with the 'extra'-section is the tools-section in the english version (I'm using the dutch one)
It doesn't appear in the tools/scripts-section:

Image

and it looks like i have access:

Image

I have tried to reinstall the script without success
(but somehow It remembers my preferences..)

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Re: Backup 5.8 - Updated 27/10/2010

Post by nynaevelan » Mon Aug 22, 2011 1:16 pm

I would recommend uninstalling the script, then close MM. Open the mediamonkey.ini file in notepad and look for the MMbackup section, remove that. Do another search to make sure there are no lingering copies of the same section (once I had two of them do to upgrades). Look in the scripts folder for the abackup.vbs and abackup2.vbs files and delete them if they are there, look in the scripts\auto folder and delete the backup.vbs file. Then reopen MM and reinstall. Then close MM and look in the scripts.ini file to make sure the backup section is created. Open Mm and try to run the backup again.

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

-SuperFunk-
Posts: 45
Joined: Tue Aug 05, 2008 4:16 pm

Re: Backup 5.8 - Updated 27/10/2010

Post by -SuperFunk- » Mon Aug 22, 2011 2:07 pm

I'm sorry for the bad news but the situation remains unchanged after I applied all the steps from your post.

It's a strange problem! :evil:


EDIT: I have changed the output paths to something else and now I get this error:

Code: Select all

Script: C:\Program Files (x86)\MediaMonket\Scripts\ABackup.vbs
Line: 488
Char: 9
Error: Path not found
Code: 800A004C
Source: Microsoft VBScript runtime error
EDIT 2: I think I have solved the problem, I believe it was a typo :roll:
Nyn, if I could buy you a drink I certainly would for all your help!

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Backup 5.8 - Updated 27/10/2010

Post by gpzbc » Mon Aug 22, 2011 2:31 pm

I was just going to say that I see a "MediaMonket" in there.
:lol:
--
The gpzbc

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Re: Backup 5.8 - Updated 27/10/2010

Post by nynaevelan » Mon Aug 22, 2011 3:28 pm

Well I am glad you found the culprit cause I was outta ideas... :lol: :lol:
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

-SuperFunk-
Posts: 45
Joined: Tue Aug 05, 2008 4:16 pm

Re: Backup 5.8 - Updated 27/10/2010

Post by -SuperFunk- » Mon Aug 22, 2011 6:17 pm

gpzbc wrote:I was just going to say that I see a "MediaMonket" in there.
:lol:
lol :lol:

AliZ
Posts: 48
Joined: Tue Jan 15, 2008 2:55 am

Re: Backup 5.3 - Updated 15/01/2010

Post by AliZ » Wed Aug 31, 2011 8:01 am

trixmoto wrote:Well the main reasons that the zip hasn't been created are...

1) The "XZip.dll" could not be registered, although I'd expect you to get a warning about this as well - to fix this you can register it manually.
2) The script does not have write permission to the folder that you have specified the zip to be created in - to fix this you can run MM as administrator or change the folders permissions.

Hope this helps.
I have the same problem.
I've registered the mentioned DLL.
I've run MM as Admin.
I've checked the authorizations of the Backup and Temp folder and have given the users of my machine write and change rights.

Nothing helps. Any suggestions?

thx
AliZ

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Backup 5.8 - Updated 27/10/2010

Post by gpzbc » Wed Aug 31, 2011 8:40 am

Can you take a screenshot of your Backup settings? Are you getting an error message, or just no zipped folder?
--
The gpzbc

AliZ
Posts: 48
Joined: Tue Jan 15, 2008 2:55 am

Re: Backup 5.8 - Updated 27/10/2010

Post by AliZ » Wed Aug 31, 2011 3:55 pm

gpzbc wrote:Can you take a screenshot of your Backup settings? Are you getting an error message, or just no zipped folder?
just no zipped folder.
Image

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Backup 5.8 - Updated 27/10/2010

Post by gpzbc » Wed Aug 31, 2011 4:15 pm

I noticed that the box isn't checked for "Output Archive". Try checking that box and see if it works.
--
The gpzbc

AliZ
Posts: 48
Joined: Tue Jan 15, 2008 2:55 am

Re: Backup 5.8 - Updated 27/10/2010

Post by AliZ » Mon Sep 05, 2011 2:38 pm

gpzbc wrote:I noticed that the box isn't checked for "Output Archive". Try checking that box and see if it works.
Yeah, now it works. THANKS!!

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Backup 5.8 - Updated 27/10/2010

Post by gpzbc » Mon Sep 05, 2011 3:47 pm

I 'm glad you got it working.
--
The gpzbc

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Backup 5.8 - Updated 27/10/2010

Post by gpzbc » Wed Nov 16, 2011 9:54 am

Trixmoto,
Do you plan to make this officially compatible with MM4? I know Nynaevelan posted an easy workaround, but the average user may not figure it out.
Thanks!
--
The gpzbc

AliZ
Posts: 48
Joined: Tue Jan 15, 2008 2:55 am

Re: Backup 5.8 - Updated 27/10/2010

Post by AliZ » Wed Nov 16, 2011 11:35 am

gpzbc wrote:Trixmoto,
Do you plan to make this officially compatible with MM4? I know Nynaevelan posted an easy workaround, but the average user may not figure it out.
Thanks!
can you please post the topic for the workaround? thx

Post Reply