Backup 6.0 - Updated 01/07/2014

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

carkey15

Re: Backup 5.8 - Updated 27/10/2010

Post by carkey15 » Thu Dec 02, 2010 12:53 am

I keep getting "Warning: ZIP File created but with Errors" on the confirmation. I've tried doing a clean install of MM 3.2.4.1304 leaving only my database (1.6GB) and then installing Backup 5.8. as the only extension. The database is created alongside the ZIP file successfully. I've tried unticking "Settings, Script Files, Skins, Plugins, Extensions, and Registry settings" individually and backing up each time. Always get the same warning. That eventually leaves only the "Restore.vbs" in the ZIP file and I still get the "Warning: ZIP File created but with Errors"
Its a new computer with Windows 7 Professional and my old computer had Vista Home Premium but I don't think that should make any difference in the database. I also ran "DB_Audit" and DB_Clean" before I did the clean install of MM so there should be no errors in the database.
I think I had MM open when my old computer crashed. Would there be something wrong in the database that "DB_Audit & DB_Clean" wouldn't catch?
Is there something wrong with the "restore.vbs" or am I getting a false Warning message?
Any ideas, anybody?? Please help because I really like having this script and want to be able to trust the backups it creates.

trixmoto
Posts: 10024
Joined: Fri Aug 26, 2005 3:28 am
Location: Hull, UK
Contact:

Re: Backup 5.8 - Updated 27/10/2010

Post by trixmoto » Thu Dec 02, 2010 4:20 am

The zip component that I use simply cannot cope with a file of that size, so it can't include it within the zip file. It's a known issue with the component but unfortunately it's the only free one that I can find.
Download my scripts at my own MediaMonkey fansite.
All the code for my website and scripts is safely backed up immediately and for free using Dropbox.

carkey151
Posts: 20
Joined: Fri Jan 22, 2010 9:14 am

Re: Backup 5.8 - Updated 27/10/2010

Post by carkey151 » Thu Dec 02, 2010 10:27 am

Thank you Trixmoto. I've run your script and it does create 2 files in my external backup folder; a copy(?) of the database (full size) "AND" a Zip file of everything else. I've opened the ZIP file and everything (extensions, plugins, etc.) is in there and appears to be the correct file size as the original files. I think that your script still works, for my backup, and that it just makes a copy of the .DB, when it is too large for your zip component. This is my confirmation message:
Backup complete:
Output folder created successfully
Database file copied successfully
Restoration script created successfully
Warning: ZIP file created but with errors
Database file store alongside ZIP file
This is what is created in my backup folder:
[3.2.4.1304] - 2010-12-02 - 08.13.DB
[3.2.4.1304] - 2010-12-02 - 08.13.zip

I assume that everything is backed up, and that the "Warning: ZIP File created but with Errors" message is just to alert me that the .DB could not be included in the zip file (and is just copied) and NOT that the zip file or .DB has any actual errors. I wouldn't care if the "Restore.vbs" could not be used because I could do a manual restore. Am I correct in assuming that is how your zip component works?

trixmoto
Posts: 10024
Joined: Fri Aug 26, 2005 3:28 am
Location: Hull, UK
Contact:

Re: Backup 5.8 - Updated 27/10/2010

Post by trixmoto » Thu Dec 02, 2010 12:17 pm

You need to extract the zip file before you can restore anyway, so as long as you extract into the same folder as the DB file (or move that file into the same folder after extracting) then the restore should work fine.
Download my scripts at my own MediaMonkey fansite.
All the code for my website and scripts is safely backed up immediately and for free using Dropbox.

carkey151
Posts: 20
Joined: Fri Jan 22, 2010 9:14 am

Re: Backup 5.8 - Updated 27/10/2010

Post by carkey151 » Thu Dec 02, 2010 2:22 pm

Thanks Trixmoto, for your time and effort. I appreciate you helping me figure this out. A truely great script that I'm sure will come in handy.

rrfpacker
Posts: 1041
Joined: Sat Jul 12, 2008 5:47 pm

Re: Backup 5.8 - Updated 27/10/2010

Post by rrfpacker » Sat Dec 11, 2010 9:29 pm

I'm still having troubles with error messages concerning the installation of this script (please see my post on page 60). I've had this script installed for years so I know what it is supposed to do and I always open MM as administrator. Using version 3.2.4.1304 as a lifetime user.

I've uninstalled and reinstalled the Backup script at least 10 times, the last version to work was 5.4 and that was about three weeks ago. Now when I try to install 5.4 or 5.8 I get

"Error #70 runtime error Permission denied R:\MediaMonkey\Scripts\Auto\Backup.vbs LIne 1697 column 4"

error message, even though the script seems to install (the icon appears on the toolbar, the .vbs is in the Auto Script folder, the Abackup and Abackup2 scripts appear in the scripts folder, interestingly with a modified date of 10/27/2010, not the current date).

When I use the backup script, it creates all the backups it is supposed to, but only once and with the following error.
Script: R:\MediaMonkey\Scripts\ABackup.vbs
Line: 357
Character: 18
Error: Database is locked
Code: C0000005
Sourse: LiteX.LiteStatement.1


I cannot backup again unless I close MM and reopen. When I do reopen MM, I get the error "R:\MediaMonkey\Scripts\Auto\Backup.vbs Column 1697 line something (probably 4 but I can't see it behind the splash screen).

Scratching my head over this one. Sure could use some help. Thank you.

trixmoto
Posts: 10024
Joined: Fri Aug 26, 2005 3:28 am
Location: Hull, UK
Contact:

Re: Backup 5.8 - Updated 27/10/2010

Post by trixmoto » Sun Dec 12, 2010 6:32 am

Well the first error you're getting means that your OS or possible some anti-virus-type software is blocking the script from deleting the files in your output path when trying to clear it up.

The second error seems to be saying that MM has locked the whole database, which seems a bit odd - its not an error that I've ever seen before. :-?
Download my scripts at my own MediaMonkey fansite.
All the code for my website and scripts is safely backed up immediately and for free using Dropbox.

rrfpacker
Posts: 1041
Joined: Sat Jul 12, 2008 5:47 pm

Re: Backup 5.8 - Updated 27/10/2010

Post by rrfpacker » Mon Dec 13, 2010 2:59 pm

Update;

I was able to get 5.8 to install successfully. Upon opening MM, I still get the error messages described earlier. Here is something odd. The "modified" dates in windows explorer show the following--Backup.vbs has the current date, Backup.vbs.bak is dated 10/28/2010, and both ABackup.vbs and ABackup2.vbs are dated 10/27/2010. Around 10/27-28 is around the last time I remember Backup working.

Is this any help?

As far as the data base being locked, I guess I'll have to do a search and see what I can find.

martialartsguy
Posts: 266
Joined: Mon Apr 03, 2006 9:11 am
Location: Denver, CO

Re: Backup 5.8 - Updated 27/10/2010

Post by martialartsguy » Mon Dec 13, 2010 3:26 pm

I've had a similar problem with database lockup recently as well.
Odd, but if I reboot my system, the problem doesn't happen for a few times, but then starts again, specifically with Backup.

Using Kaspersky AV.
Windows 7 Pro 64-bit.
MM 4.1.10.1778

jonisaksson
Posts: 42
Joined: Fri Apr 20, 2007 11:02 am

Re: Backup 5.8 - Updated 27/10/2010

Post by jonisaksson » Sun Dec 26, 2010 3:05 am

Hello,

sorry if this is covered elsewhere.
But my main harddisk crashed, so now rebuilt a new harddisk, luckily did I run this brilliant script so got a complete backup of MM as well of my MP3s

The problem I have is that my music is in a different location than it was prior to the crash (bought an SSD for my C-drive), so my music library is no longer in c:\audio rather in d:\audio, the rest of the file structure is the same.

I want to run a restore of the backupscript but not sure what I need to do/change as my audio files are in a different location to what the restore thinks?

I hope it makes sense

Cheers
Jon

Mizery_Made
Posts: 2283
Joined: Tue Aug 29, 2006 1:09 pm
Location: Kansas City, Missouri, United States

Re: Backup 5.8 - Updated 27/10/2010

Post by Mizery_Made » Sun Dec 26, 2010 4:19 am

The Moving MM to a new computer page on the Wiki should get you set up.

jonisaksson
Posts: 42
Joined: Fri Apr 20, 2007 11:02 am

Re: Backup 5.8 - Updated 27/10/2010

Post by jonisaksson » Sun Dec 26, 2010 4:49 am

Mizery_Made wrote:The Moving MM to a new computer page on the Wiki should get you set up.
Thank you!

killerbees19
Posts: 4
Joined: Sat Apr 08, 2006 3:42 am
Location: Vienna (Austria)
Contact:

Re: Backup 5.8 - Updated 27/10/2010

Post by killerbees19 » Thu Dec 30, 2010 10:50 am

Nice script, good job :D


Regards,
Christian

lobojon
Posts: 45
Joined: Sun Nov 02, 2008 11:02 pm

Re: Backup 5.8 - Where are my deleted files?

Post by lobojon » Sat Jan 01, 2011 2:06 am

Well, I have been trying to get this script to work routinely. For some reason, I cannot get it to keep a few back up zips, nor can I get it to back up without deleting everything in the main folder. So, I read the forum and try, try again.

In fact, while making another attempt, it (I) just deleted all of the non-MM related files in the major folder where I was attempting to back up the files.

More importantly, the script deletion did not send the files it deleted into the trash can. Therefore, I cannot restore the files from the trashcan. This is a problem for me.

I just ran the program called "my files" which scans your computer for all permanently deleted files so that you can restore them. It is a recovery program that has worked for me in the past, but did not find any of the files deleted by the script. This does not surprise me since the files were not deleted to the trashcan.

My questions:
1. Can you suggest anything so that I can find my deleted files?
2. Can you modify the script so that deleted files are moved to the trashcan so that we users who run into this problem have the chance to correct the mistake via the restore these files function in the trashcan?

This is very unfortunate and frustrating. Any advice would be greatly appreciated.
MM Lifer since 2008. Still apprentice (noob) level.
Windows 7 Ultimate 64bit
Toshiba Satellite laptop
Music collection of 2 TB located on an external hard
Spybot Search & Destroy / Iobit Anti Malware
Avast Antivirus Free Edition

I love the Monkey and the forum.
Thanks to all who provide advice, assistance, add ons and scripts. It is very much appreciated!

rrfpacker
Posts: 1041
Joined: Sat Jul 12, 2008 5:47 pm

Re: Backup 5.8 - Updated 27/10/2010

Post by rrfpacker » Sat Jan 01, 2011 3:19 pm

I'm going to try once more to find a solution to my problem(s), as it seems complicated. Below is my post from 12/11/10 and immediately below is an update from 12/31/10. I also have posts on page 60. As a reminder, whenever I install this script, ABackup and ABackup2 appear with "modified" dates back in October...no matter what the current date is. This seems significant to me but maybe it isn't. Hope I'm being clear. Thank you.

12/31/10
On this day I tried to install Backup 5.4, this was the last version to work for me and 5.8 will not install. When I double click the installation package I get the error messages documented below. Basically, I'm told I don't have permission to install the script. However, the Backup icon is installed on the toolbar, I can choose it in Right Click for Scripts, and it shows up under Extensions. I can also run the script.

But, and this is big, changes made to the library with the Backup script installed, such as editing playlists and tracks (which I spent four hours doing yesterday) are not saved when closing MM. After uninstalling the script, any changes are saved.



from 12/11/10
I'm still having troubles with error messages concerning the installation of this script (please see my post on page 60). I've had this script installed for years so I know what it is supposed to do and I always open MM as administrator. Using version 3.2.4.1304 as a lifetime user.

I've uninstalled and reinstalled the Backup script at least 10 times, the last version to work was 5.4 and that was about three weeks ago. Now when I try to install 5.4 or 5.8 I get

"Error #70 runtime error Permission denied R:\MediaMonkey\Scripts\Auto\Backup.vbs LIne 1697 column 4"

error message, even though the script seems to install (the icon appears on the toolbar, the .vbs is in the Auto Script folder, the Abackup and Abackup2 scripts appear in the scripts folder, interestingly with a modified date of 10/27/2010, not the current date).

When I use the backup script, it creates all the backups it is supposed to, but only once and with the following error.
Script: R:\MediaMonkey\Scripts\ABackup.vbs
Line: 357
Character: 18
Error: Database is locked
Code: C0000005
Sourse: LiteX.LiteStatement.1


I cannot backup again unless I close MM and reopen. When I do reopen MM, I get the error "R:\MediaMonkey\Scripts\Auto\Backup.vbs Column 1697 line something (probably 4 but I can't see it behind the splash screen).

Scratching my head over this one. Sure could use some help. Thank you.

Post Reply