Page 1 of 2

Chromecast: Now Plays One Song And Then Stops [#14264]

Posted: Sun Jun 04, 2017 11:10 am
by frankz
Samsung Galaxy S8
Android 7
MMA .0701 + pro
LOG ID: RGL4C223RR

So I was excited to read about how 701 would solve my Chromecasting problems. After trying to use it, not so much on the excitement.

Last night after update, sit down, connect to Chromecast audio, try to cast playlist. First song plays. Second song starts, time bar stays at 0, second song stops playing midway through. No "Stop Casting" option available although, in MMA's list of castable devices, still shows MMA as casting to the Chromcast audio. Force stop MM. Still can't connect to Chromecast audio with anything else. Reboot Chromecast Audio.

Restart phone.

This morning, open MMA fresh, connect to (video) Chromecast, first song plays, first song ends, next song comes up on display, time bar stays at 0, nothing plays, nothing shows up on Chromecast. MMA thinks it's disconnected from Chromecast now, so there's no "Stop Casting" option, Chromecast still thinks MMA is trying to do something and it won't go back to homescreen. Send log. Write post. Throw phone. Reboot Chromecast.

95% of what I want to do with this app is cast to the speakers in my house. This is becoming a very frustrating experience.

Re: Chromecast: Now Plays One Song And Then Stops

Posted: Sun Jun 04, 2017 11:28 am
by frankz
LOG ID: LOL

No, really, LOG ID: 5Q32YR6W7Z

After above, tried again. First song played. Second song played but Chromecast icon showed up as disconnected. Reconnected. Second song continued playing for about 15 seconds and then stopped playing with a loud squeal. MMA then started cycling through the playlist showing (on the phone) "{Song Title} Skipped as it is unsupported by the receiver" for all of my entirely supported MP3s.

Re: Chromecast: Now Plays One Song And Then Stops

Posted: Fri Jun 09, 2017 12:19 pm
by rusty
I can't replicate this with a Nexus 7 / Android 7.1.2 or S5 Mini / Android 6 or S5 / Android 7, but we'll look into the logs.

btw, does the problem happen with all types of audio files or just specific ones (e.g. mp3, m4a, flac, etc)?

Also, can you confirm that other apps that support Chromecasting work correctly (I wonder if it could be a problem with the device or a networking issue)?

Thanks.

-Rusty

Re: Chromecast: Now Plays One Song And Then Stops

Posted: Fri Jun 09, 2017 1:18 pm
by frankz
rusty wrote:I can't replicate this with a Nexus 7 / Android 7.1.2 or S5 Mini / Android 6, but we'll look into the logs.

btw, does the problem happen with all types of audio files or just specific ones (e.g. mp3, m4a, flac, etc).

Thanks.

-Rusty
I only have mp3s (mostly all VBR if it matters) on my phone. No other formats. Hope the logs help, because the problem persists on my end.

Also, and I haven't sent a log on this, if I do manage to get it going beyond 1 song, the third or fourth song usually displays no data on the Chromecast (video). The screen just goes blank - no cover image, no metadata, nothing.

Like I said on a previous post, I went walking with headphones plugged into the phone for about an hour one day last week and none of these playback problems happened. Seems to be entirely related to the Chromecasting implementation. I get huge problems with both a video Chromecast (the original one) and also my Chromecast Audio.

Re: Chromecast: Now Plays One Song And Then Stops

Posted: Sun Jun 11, 2017 10:37 am
by rusty
Thanks for the followup. With extended testing, I was able to replicate the problem with a Nexus 5x. Tracked at:
http://www.ventismedia.com/mantis/view.php?id=14264

-Rusty

Re: Chromecast: Now Plays One Song And Then Stops [#14264]

Posted: Sun Jul 09, 2017 12:19 pm
by adelosky@comcast.net
I have a similar problem. I can cast 3 or 4 songs before MMA just stops playing songs but is still connected. I can continue playing manually, but it will stop again after a few songs.

Re: Chromecast: Now Plays One Song And Then Stops [#14264]

Posted: Tue Jul 11, 2017 1:34 am
by drunknmonkey
For me this is fixed with 1.3.1.711.
Casting does not stop after each track anymore.
Testet with Samsung Galaxy S7 + Denon AVR-X4100W and NVIDIA Shild TV as cast receivers.

Re: Chromecast: Now Plays One Song And Then Stops [#14264]

Posted: Wed Jul 12, 2017 4:29 pm
by frankz
FWIW I'm still having massive Chromecasting problems with the hardware listed above to the point that I've basically given up using it except to test and make sure each new version still flakes out on me like the last one did. I'm glad it doesn't seem like everyone is still having these problems, but I am.

Re: Chromecast: Now Plays One Song And Then Stops [#14264]

Posted: Fri Jul 14, 2017 7:09 pm
by Peke
More chromecast tweaks/fixes are coming.

Re: Chromecast: Now Plays One Song And Then Stops [#14264]

Posted: Thu Feb 01, 2018 6:24 am
by vliegh@hotmail.com
Is this issue solved? I still experience problems. Casting stops after one song. Galaxy S7 MMA version 1.3.1.0745 MediaMonkey Pro

Confirming Chromecast support is still flaky (was: [#14264])

Posted: Thu Sep 27, 2018 12:09 pm
by djasonpenney
I still have problems streaming music from MMA (version 1.3.2.0824) from my VZW Samsung Galaxy S9+ to my Chromecast Ultra.

It's very erratic. It feels like a connection problem because the MMA mini-app still displays on the TV screen. Other times the music keeps playing, at least for a minute or two, even though MMA says that the connection has been lost. Attempting to reconnect to Chromecast just makes things more fubar.

The one thing that connects my problem to the current thread is that the disconnect almost always occurs at the end of a song.

In the way of problem isolation, I note that neither Plex (version 7.6.0.7019) nor Netflix (version 6.11.0 build 29552) have this problem; it seems to be isolated to MMA.

Has there been any progress root causing this issue?

Re: Chromecast: Now Plays One Song And Then Stops [#14264]

Posted: Thu Sep 27, 2018 1:22 pm
by Lowlander
Send a debug log (from About) right after you have an issue and reply here with the logID.

Re: Chromecast: Now Plays One Song And Then Stops [#14264]

Posted: Fri Sep 28, 2018 5:43 pm
by Peke
Hi,
You should also try using latest <MMA beta and see if that fixes the problem, as we were done some optimization chromecasting.

Re: Confirming Chromecast support is still flaky (was: [#14264])

Posted: Mon Nov 05, 2018 10:48 pm
by cokehearth
djasonpenney wrote:
Thu Sep 27, 2018 12:09 pm
I still have problems streaming music from MMA (version 1.3.2.0824) from my VZW Samsung Galaxy S9+ to my Chromecast Ultra.

It's very erratic. It feels like a connection problem because the MMA mini-app still displays on the TV screen. Other times the music keeps playing, at least for a minute or two, even though MMA says that the connection has been lost. Attempting to reconnect to Chromecast just makes things more fubar.

The one thing that connects my problem to the current thread is that the disconnect almost always occurs at the end of a song.

In the way of problem isolation, I note that neither Plex (version 7.6.0.7019) nor Netflix (version 6.11.0 build 29552) have this problem; it seems to be isolated to MMA.

Has there been any progress root causing this issue?
I have this problem intermittently on my Samsung Tab S4, and I think it is something to do with 'Power Saving' mode or battery optimisation. The problem started again suddenly last night, and I turned off Power Saving mode about fifteen minutes ago, and now the problem appears to have stopped.

Re: Chromecast: Now Plays One Song And Then Stops [#14264]

Posted: Fri Dec 28, 2018 8:08 pm
by Seanny123
This is also still happening to me using Mediamonkey 1.3.4.0844.