Page 1 of 1

Sync to Google broken until MM5 rebooted [#15676]

Posted: Thu May 09, 2019 8:28 pm
by Barry4679
Google Play Music Sync fails until MM5 is rebooted.

Sync starts, but completes immediately "normally", ie. 0 files updated|added.

Steps:
  • fresh install MM5 portable
  • open Devices&Servives, add GPM service, sign in and authorise
  • configure for GPM account ... toggle on Scan GPM content, and Only include matched contents .... toggle off Sync metadata to MM5 db
  • press Apply
  • press Sync Now
==> Sync completes "normally", but does nothing.

Workaround: close and restart MM5

Re: Sync to Google broken until MM5 rebooted

Posted: Fri May 10, 2019 5:47 am
by Ludek
Hi,
if you have fresh install of MM5 portable with no content then I guess that settings like:
Scan GPM content, and Only include matched contents
does nothing as there is no content in MM5, isn't it?

Or did you scan an additional a content to MM5 in between ?

BTW: I can't test now as I am experiancing crash when adding GPM profile after fresh install,to be fixed as https://www.ventismedia.com/mantis/view.php?id=15659

Re: Sync to Google broken until MM5 rebooted

Posted: Fri May 10, 2019 7:20 am
by Ludek
I can confirm that after fresh install (when there is no content in MM5 yet) then the choice
[x] Only include content that matches files already in the database
causes that all the track as "skipped" -- seeing them in the Scan log as "Did not match import criteria"

But this is expected behaviour.

Re: Sync to Google broken until MM5 rebooted

Posted: Fri May 10, 2019 7:40 am
by Barry4679
Ludek wrote:
Fri May 10, 2019 5:47 am
if you have fresh install of MM5 portable with no content then I guess that settings like:
Scan GPM content, and Only include matched contents
does nothing as there is no content in MM5, isn't it?
There was content. The fresh install of MM5 imported my data from MM4 db.

The initial scans as described completed "normally", but did nothing.

I closed and restarted MM5, and then rerun the scan. This time it synced GPM IDs to all my MM5 tracks, as expected.
Ludek wrote:
Fri May 10, 2019 5:47 am
But this is expected behaviour.
No.

I should have mentioned that I accepted offer to import data from MM4.

Re: Sync to Google broken until MM5 rebooted

Posted: Fri May 10, 2019 11:44 am
by Ludek
I can't seem to replicate, could you please attach debug log?

Re: Sync to Google broken until MM5 rebooted

Posted: Sat May 11, 2019 2:31 am
by Barry4679
link to log file sent via PM

[UPDATE] Retested with version 2175 published today ... problem persists

Re: Sync to Google broken until MM5 rebooted

Posted: Thu May 16, 2019 8:09 am
by Ludek
As debugged via PMs we have found that there is kind of XSRF error in the Barry's environment.

Tracked as https://www.ventismedia.com/mantis/view.php?id=15676

Thinking about it could be just another regression related to the shared dialog windows.

Could you please test build pre 2169, e. g. build 2165 to see whether the issue exists also in that build?

Let me know, thx.

Re: Sync to Google broken until MM5 rebooted

Posted: Thu May 16, 2019 8:44 pm
by Barry4679
Ludek wrote:
Thu May 16, 2019 8:09 am
Could you please test build pre 2169, e. g. build 2165 to see whether the issue exists also in that build?
I can't find any version 2165 ... installed 2164 ... the problem was already there in 2164

Re: Sync to Google broken until MM5 rebooted

Posted: Fri May 17, 2019 3:44 am
by Ludek
Resolved offline with Barry via PMs.

Fixed as https://www.ventismedia.com/mantis/view.php?id=15676