2221 - Album sub node - fails to load albums

Report bugs & feature requests for MediaMonkey 5 and learn about the newest builds.

Moderator: Gurus

Davo
Posts: 348
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

2221 - Album sub node - fails to load albums

Post by Davo » Thu Jan 23, 2020 10:34 pm

David
____________________________
Windows 10
MM 5 Beta

Ludek
Posts: 3341
Joined: Fri Mar 09, 2007 9:00 am

Re: 2221 - Album sub node - fails to load albums

Post by Ludek » Mon Jan 27, 2020 7:08 am

Hi, in the log I see that it took 25 seconds to load whole album list (from the tracklist filtered by Column filter).
How large is your database? I can imagine that it could took so long only on very large databases, would you mind sharing your MM5.DB ?

Nevertheless to improve the performance you can just disable the "Column filter" sub-view and then the albums will be loaded directly from DB (without a need to read tracks at first and filter them by "Column filter" before showing the resulting album list). So I guess it is much faster without "Column filter", right?

Davo
Posts: 348
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Re: 2221 - Album sub node - fails to load albums

Post by Davo » Thu Jan 30, 2020 10:07 pm

The DB is 1.69GB Maybe too big to send you.
Yes it loads much faster without the Column Filter & i understand why now. So it is probably better to load the Grid first then apply the filter.

I'm noticing that when using the Column Filter & Grid together if i swap between sub nodes the Grid view fails to load & the system just stops.
https://drive.google.com/open?id=1R6_3V ... JahVJZaJE5
David
____________________________
Windows 10
MM 5 Beta

Peke
Posts: 13070
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: 2221 - Album sub node - fails to load albums

Post by Peke » Fri Jan 31, 2020 8:21 am

Hi,
Ludek meant, how many tracks you have in library?

ALso if you compress it it will be usually 1/10 of non compressed size so you can send Ludek a PM with download link.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

Davo
Posts: 348
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Re: 2221 - Album sub node - fails to load albums

Post by Davo » Fri Jan 31, 2020 2:26 pm

Thanks Peke - I've PM Ludek with info
David
____________________________
Windows 10
MM 5 Beta

Post Reply