Poor or no highlighting for selected sub node item in Grid View

Report bugs & feature requests for MediaMonkey 5 and learn about the newest builds.

Moderator: Gurus

Davo
Posts: 348
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Poor or no highlighting for selected sub node item in Grid View

Post by Davo » Fri Jan 24, 2020 6:22 pm

The selected item is highlighted either by 2 light grey vertical or horizontal bars which are difficult to see against a black background & artwork of many colours incl. Black & White & various shades of grey. In many cases there is no highlighting at all ??

Perhaps if there are only a small number of albums involved it doesn't matter that much, but when you have a screen full of coloured boxes it becomes much more important.
David
____________________________
Windows 10
MM 5 Beta

dtsig
Posts: 3196
Joined: Mon Jan 24, 2011 6:34 pm

Re: Poor or no highlighting for selected sub node item in Grid View

Post by dtsig » Fri Jan 24, 2020 8:12 pm

Davo .. does it do the same in all skins?
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

Davo
Posts: 348
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Re: Poor or no highlighting for selected sub node item in Grid View

Post by Davo » Fri Jan 24, 2020 9:24 pm

i only use the Material Design (dark).
David
____________________________
Windows 10
MM 5 Beta

Barry4679
Posts: 1047
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: Poor or no highlighting for selected sub node item in Grid View

Post by Barry4679 » Sat Jan 25, 2020 7:55 pm

I agree Davo.

Here is the dark Material Design skin ... the 2nd of the three albums is selected, but the selection is invisible.

The other Material design skin is not much better. Here is the dark material skins compared to several others ... in all cases the 2nd album is selected.

Ludek
Posts: 3341
Joined: Fri Mar 09, 2007 9:00 am

Re: Poor or no highlighting for selected sub node item in Grid View

Post by Ludek » Mon Jan 27, 2020 8:04 am

I cannot seem to replicate, for me:

- selected albums have the tick triangle, see: https://www.dropbox.com/s/ycn4jxjfg1q3l ... 9.png?dl=0
- focused album has the rectangle: https://www.dropbox.com/s/nplit20tn3msb ... 1.png?dl=0 (Two Golden Greats)
- clicked album opens the popup: https://www.dropbox.com/s/57nieeac24su6 ... 5.png?dl=0 (20 greatest hits)

Barry4679
Posts: 1047
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: Poor or no highlighting for selected sub node item in Grid View

Post by Barry4679 » Mon Jan 27, 2020 8:53 am

Ludek wrote:
Mon Jan 27, 2020 8:04 am
I cannot seem to replicate, for me:

- selected albums have the tick triangle, see: https://www.dropbox.com/s/ycn4jxjfg1q3l ... 9.png?dl=0
- focused album has the rectangle: https://www.dropbox.com/s/nplit20tn3msb ... 1.png?dl=0 (Two Golden Greats)
- clicked album opens the popup: https://www.dropbox.com/s/57nieeac24su6 ... 5.png?dl=0 (20 greatest hits)
Have no problem with selected albums with tick triangles.

You image showing the rectangle on the focused album looks OK, but I have never seen that before. ... I have now been able to replicate what you are seeing. ... It looks like you are navigating using the arrow keys .. were it looks OK as you demonstrate ... I was navigating by mouse, and using that method the selection rectangle is not displayed.

The album with the popup is usually OK, unless the predominant colour in the album art approaches the skin's background colour ... in these cases your little pointing triangle disappears like this where I can't see which of the two Bob Dylan albums I have chosen. ... Maybe you can see it .... I can't.

I have many albums in this category.

Barry4679
Posts: 1047
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: Poor or no highlighting for selected sub node item in Grid View

Post by Barry4679 » Thu Jan 30, 2020 8:25 pm

Additional to the above (unacknowledged) post .

This lack of highlighting becomes a more irritating issue when using MM5 Scroll To search when in album Grid view.

The view scrolls, but there is zero highlighting, so it is not possible to determine what you have scrolled to.
Rocking the left|right arrows doesn't help, because this doesn't trigger the selection box to appear.

Peke
Posts: 13070
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Poor or no highlighting for selected sub node item in Grid View

Post by Peke » Fri Jan 31, 2020 8:30 am

Hi,
In davo pictures I see that its Album Art is with black background. If Album art is close or same as skin color than it is not possible for us to re render each Triangle colors.

I can't replicate using Monkey Groove skin that I use.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

Barry4679
Posts: 1047
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: Poor or no highlighting for selected sub node item in Grid View

Post by Barry4679 » Fri Jan 31, 2020 8:49 am

Peke wrote:
Fri Jan 31, 2020 8:30 am
In davo pictures I see that its Album Art is with black background. If Album art is close or same as skin color than it is not possible for us to re render each Triangle colors.

I can't replicate using Monkey Groove skin that I use.
That picture was from me, not David.
I have a lot of albums in this situation; ie. there are many albums with minimalist black and white cover design.
I am using your default skin.

"not possible" is a big claim to make.

Ludek
Posts: 3341
Joined: Fri Mar 09, 2007 9:00 am

Re: Poor or no highlighting for selected sub node item in Grid View

Post by Ludek » Fri Jan 31, 2020 10:30 am

FYI: The visibility of selected grid items on Material Design skins was improved in build 2225.

Peke
Posts: 13070
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Poor or no highlighting for selected sub node item in Grid View

Post by Peke » Fri Jan 31, 2020 10:58 pm

Barry4679 wrote:
Fri Jan 31, 2020 8:49 am
"not possible" is a big claim to make.
It may sound big, but I wanted to explain that in order to make sure that is seen, we need to fetch/analyze colors of each image and then find contrast color, which hard to make and at what cost. Everything is possible, but is it worth the regression rist.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

Barry4679
Posts: 1047
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: Poor or no highlighting for selected sub node item in Grid View

Post by Barry4679 » Sat Feb 01, 2020 9:31 pm

Peke wrote:
Fri Jan 31, 2020 10:58 pm
we need to fetch/analyze colors of each image and then find contrast color, which hard to make and at what cost. Everything is possible, but is it worth the regression rist.
Peke, that's a rather naughty Straw Man argument .... ie. that's not the way that they would address this issue.

It is a simple UI design failing ... ie. looks pretty; doesn't work ... the fix is simple

The problem is pervasive. Here is the top of my album grid ... albums are sorted by title, so we are looking at albums whose title are before A ... in the 1st row (!) there are three albums where the UI design has failed ... ie. the little indicator difficult to see in a busy grid. I also have many albums where the indicator is invisible.

I know that it is a little problem ... Since the indicator is often pretty much invisible, so why not delete it everywhere? ... The answer to that is that of course you wouldn't delete it, because its useful ... So ... ?

The current design is to have the arrow thing look pretty by sharing a colour tone with the album cover ... That is a UI design idea that in practice is just "form over function" ... ie. looks pretty; doesn't work

The simple fix is just to make the arrow thing a constant, easily visible contrasting colour, that is part of the skins colour pallet. .... ie. just like the colour of the selection box ... the one whose visibility is triggered by arrow-key movements, but which is AWOL when selecting by mouse, and also AWOL during scroll-to navigation .... that is the most most important issue being discussed in this thread.

Davo
Posts: 348
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Re: Poor or no highlighting for selected sub node item in Grid View

Post by Davo » Sat Feb 01, 2020 10:19 pm

I agree, as a basic principle the symbol or text should be readable irrespective of the color of the background image.
a simple rule is to set the fill colour as white and use a thin black outline. The text captions will be readable over any other colour and brightness. Another solution would be to add a semi-transparent or opaque background.
These are the usual approaches used for video sub titles & text captioning & i imagine could be adapted to solve the MM highlighting problem.
David
____________________________
Windows 10
MM 5 Beta

Ludek
Posts: 3341
Joined: Fri Mar 09, 2007 9:00 am

Re: Poor or no highlighting for selected sub node item in Grid View

Post by Ludek » Sun Feb 02, 2020 1:39 pm

I guess that 2226 resolves the issue, isn't it?

Post Reply