playcounts of iPod zero after rebuilding device database

Beta Testing for Windows Products and plugins

Moderator: Gurus

charlieMOGUL
Posts: 171
Joined: Fri Mar 11, 2005 5:26 am

playcounts of iPod zero after rebuilding device database

Post by charlieMOGUL » Thu Aug 10, 2006 6:10 am

Hi,

I was wondering whether this is a bug or a harmless feature.
I'm using MediaMonkey build 2.5.4.971 and an iPod Photo.
When rebuilding the complete device database of the iPod, all the playcounts of the songs on the iPod are reset to zero. The playcounts of the songs itself (which reside in the local library) are still intact.
So after rebuilding the device database there's a difference between the device (iPod) and the MediaMonkey library regarding playcounts of the same song.

When playing a song on the iPod and synchronizing afterwards with MediaMonkey the playcount of the song in the library is correctly updated. The playcount of the song on the iPod is also correctly after synchronizing.
So after synchronizing the only songs having a correct playcount on the iPod are the songs which required synchronization (eg. were played).

New songs which are added after the database was rebuilt get the correct playcount as well.

charlieMOGUL

charlieMOGUL
Posts: 171
Joined: Fri Mar 11, 2005 5:26 am

iPod synching issues / SoundCheck

Post by charlieMOGUL » Tue Apr 10, 2007 2:31 am

Hi,

I'm using an iPod 5.5G 80GB with MediaMonkey version 2.5.5.998.
When I rebuild the iPod device database, not only all the playcounts on the iPod become zero, but also the added date becomes a strange date in the future (eg. 4-2-2036).

Also, as mentioned in other posts, the iPod album artwork gets messed up (eg. wrong picture is shown) after a few synchs.

Third, I get the impression that the conversion of mp3gain (volume leveling) tags to iPod's soundcheck tags doesn't always work. Not all songs are equally leveled with soundcheck enabled on the iPod.
When I check the SoundCheck values in the iTunesDB file after synchronizing with MM, all the SoundCheck values are zero (0).
From what I understand from the MM manual, it should convert those values.
MediaMonkey supports Soundcheck, reading Soundcheck values and converting them to Replay Gain (if no Replay Gain co-efficient exists) as well as converting Replay Gain to Soundcheck on the fly when Synchronizing to an iPod.
Developers, is it worthwile to create debug logs for these issues, or should I wait for version 3?

Thanks in advance,

Post Reply