Page 2 of 2

Re: Long load time [#13265]

Posted: Tue May 15, 2018 6:17 am
by Duke999R
Turned out to be RegExp Find & Replace 4.3 http://www.mediamonkey.com/forum/viewto ... =2&t=28510 causing my issue. Uninstalled the script and I'm back to normal start up behaviour.

Thanks for your help and patience Ludek!

Re: Long load time [#13265]

Posted: Wed May 16, 2018 3:36 am
by Panchdara
Duke999R wrote:
Tue May 15, 2018 6:17 am
Turned out to be RegExp Find & Replace 4.3 http://www.mediamonkey.com/forum/viewto ... =2&t=28510 causing my issue. Uninstalled the script and I'm back to normal start up behaviour.

Thanks for your help and patience Ludek!
Yup, I can concur. I uninstalled everything to do with this extension and MM 4 fired up fine. I then reinstalled to verify and have concluded it is the 500 odd presets that are causing the delay. Install the extension without the presets and all is fine again. I'll pop a message to Zvezdan Dimitrijevic to point him to this thread.

Thanks Ludek - well spotted.

Re: Long load time [#13265]

Posted: Wed May 16, 2018 6:23 am
by ZvezdanD
Panchdara wrote:
Wed May 16, 2018 3:36 am
I'll pop a message to Zvezdan Dimitrijevic to point him to this thread.
Thanks for the report, but I already gave my opinion about this problem in the RegExp thread. I am sorry because of that, but I think it is not my fault why this is happening. I have used standard MM API functions to create menu items, nothing extravagant. Yes, I know there are many menu items in the menu, but each preset requires its own menu item to be available. And I want to give all presets that I developed so far to the users because I think they could be useful for someone. It is up to the users to remove some or all of them if they found they are causing slow down on startup.

I think it is MM developers' responsibility to fix this problem, not mine.

Re: Long load time [#13265]

Posted: Thu May 17, 2018 1:16 pm
by Panchdara
Hi Zvezdan. Thanks very much for your reply. I did find that thread. I doubt MM4 or 5 will solve it. I will continue to use your great extension... and create my own presets when required, but for the most part I use my own anyway. Now that that is exposed, is there a way to selectively install presets? or is install all and then start weeding ones out? Great extension.

Best

Re: Long load time [#13265]

Posted: Thu May 17, 2018 1:38 pm
by ZvezdanD
No, you cannot choose which predefined presets to install during installation of the add-on; you could only install all or none of them.

However, if you chose to skip installation of the predefined presets, you could later selectively install some (or all) of them. Just open the Manage Presets dialog box, choose File option, specify RegExpReplace.ini file from the add-on's folder (Scripts\Auto) and you will get a list of presets from the specified file with check boxes that you could use to select which presets you want to import.

By the way, it seems that Ludek fixed the mentioned problem in build 1867.

Re: Long load time [#13265]

Posted: Mon Oct 15, 2018 2:15 am
by ZvezdanD
The enhanced donation-only versions of the RegExp Find & Replace and Magic Nodes add-ons have implemented a workaround for the slow startup problem, making them as fast as before the mentioned Windows Update.

Re: Long load time [#13265]

Posted: Sun Feb 03, 2019 2:42 am
by ZvezdanD
Kayla219 wrote:
Sat Feb 02, 2019 2:41 am
I have the same problem after the installation of Windows 10 April Update
I don't use Windows Defender but Kaspersky Internet Security
My MediaMonkey version is 4.1.21.1866 Beta
The user, whose entire post you copy/pasted, now has the enhanced version of the mentioned add-on, and he reported to me that the program is loading fine now without any slow down. It seems that Windows Defender, being an integral part of Windows, is working in background even with Kaspersky installed.