Multiple Albums Missing in Show Art View

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

arette
Posts: 4
Joined: Fri May 18, 2012 11:25 am

Multiple Albums Missing in Show Art View

Post by arette » Fri May 18, 2012 12:56 pm

To Whom It May Concern:

I just switched from iTunes to MediaMonkey v4.0.3.1476 (portable mode). So far, I've found MM to be far superior in many ways. Unfortunately, however, many of my albums "disappear" when I'm in the Show Art view and column sorting by Artist or Album Artist. Yes, I have triple-checked the detailed info for each individual track in the missing albums, and the Artist and Album Artist fields are correctly populated; even other albums with the same exact Artist and Album Artist field properties do appear in the Show Art view! :cry:

The missing albums do appear when in any of the other views, or even in the Show Art view when I column sort by say Album or Genre instead of Artist or Album Artist. To further demonstrate and/or narrow down the issue, I've attempted to start playing a track from one of the albums in a view besides Show Art, then switched to Show Art view while the track is still playing and MM "loses focus" (i.e. the album is not selected when I switched to Show Art view) and takes me to the top of the list (0-9). This is not the behavior that is typically exhibited by repeating this test with a track on an album that does appear in both views; i.e. the album will still be selected once you switch to Show Art view and MM automatically scrolls down to the right spot in the Show Art view, regardless of which column sort is set, so it can easily be seen that the album is still selected.

It may also be important to note that, when I close and re-open MM, the albums will appear for a short time and then disappear again while MM is scanning my Music folders for any changes (I have MM set to do this on each startup). Based on the evidence I've gathered and described above, I'm confident that this is some sort of bug and would be willing to help you guys track it down and resolve it not only for me, but for the MM community.

Thanks for your time and consideration,
Tony

theta_wave
Posts: 309
Joined: Fri Apr 13, 2007 12:54 am

Re: Multiple Albums Missing in Show Art View

Post by theta_wave » Fri May 18, 2012 7:27 pm

Hmm, it might still be there. Do the artists start with the prefix "The"? If so, then they are sorted improperly by Mediamonkey under show art+detail. For example, albums by "The Band" should show between "Bailter Space" and "Bardo Pond," but under show art+details it shows underneath "Bz". I posted the bug, but not much has come out of it when the devs are trying to debug the iOS 5 compatibility.

http://www.mediamonkey.com/forum/viewto ... 3&p=334632
MM Gold Lifetime since 2.5.5.998
Computer: Lenovo Y580 System: Win7 Ultimate x64 SP1 / Arch Linux Mediamonkey 4: w/ Monkeyrok 5.6, Minilyrics 1.4b, iMonkey Skin

arette
Posts: 4
Joined: Fri May 18, 2012 11:25 am

Re: Multiple Albums Missing in Show Art View

Post by arette » Sat May 19, 2012 8:33 am

Thank you for your reply; no none of the missing albums have Artist or Album Artist starting with "The", if they had I would've checked under T's. The missing albums started near the end of my B's (@ Boyz II Men, II album) and all albums after that before the start of C. In total, I was missing Boyz II Men (II), Boyz II Men (Legacy), Bright Eyes (Digital Ash in a Digital Urn), Bright Eyes (It's Wide Awake, It's Morning), Broken Bells (Self-titled album), Bruce Hornsby & The Range (The Way It Is), Bruno Mars (Doo-Wops & Hooligans), and lastly Bush (Sixteen Stone). The next artist, Candlebox, starts with a C and was always showing up fine. So my assumption was that there was must've been something seriously wrong with the tags in the Boyz II Men, album II, and it was affecting the rest of the B's in my library...

So, even though the Artist and Album Artist field *appeared* to be correctly populated on the culprit Boyz II Men album, I tried repopulating the common fields for all of my Boyz II Men albums (editing properties for multiple tracks and albums at the same time) and this resolved the issue. So.....moral of the story....don't believe the field when you see this type of behavior even if the field looks correct. Just try retagging the entire culprit album or album(s) and see if the missing albums come back. Worked like a charm for me!

Thanks again

arette
Posts: 4
Joined: Fri May 18, 2012 11:25 am

Re: Multiple Albums Missing in Show Art View

Post by arette » Sat May 19, 2012 8:38 am

BTW, I actually like that mediamonkey ignores "The" when sorting on details....and this is not a bug it is a feature that you can change:

Go to Tools -> Options, then go to Appearance under the Library heading. There is an option to ignore prefixes when sorting by Artist that is user-customizable. The default is on and it ignores "The" by default.

For me, this is better then including "The" in the sort since it is a non descriptive article...

arette
Posts: 4
Joined: Fri May 18, 2012 11:25 am

Re: Multiple Albums Missing in Show Art View

Post by arette » Sat May 19, 2012 8:42 am

Sorry, I just read your thread about the "ignore prefix" and you were talking specifically about Autoplaylists which I do not use, so that bug could actually exist. However, when just looking at art+detail view without using autoplaylists it uses the "ignore prefix" option correctly.

Fruitlessnoodle
Posts: 1
Joined: Sun Sep 04, 2016 7:17 am

Re: Multiple Albums Missing in Show Art View

Post by Fruitlessnoodle » Sun Mar 24, 2019 5:12 am

I see that this thread goes back to 2012 but in 2019 I am unfortunately still experiencing exactly this problem of some albums not being shown when using the "Show Art" view. Deleting and rebuilding the entire database does not help. The workaround was to rename the band in question ("Muse"), prefixing their name with "The", which is not exactly a satisfactory solution.

If it is of relevance, I sort albums by date for each artist. This bug meant that every album further down the sort order didn't show (affecting not one band but many), until the listing moved on to the next letter of the alphabet.

Lowlander
Posts: 45913
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Multiple Albums Missing in Show Art View

Post by Lowlander » Mon Mar 25, 2019 11:57 am

Which version of MediaMonkey?
Lowlander (MediaMonkey user since 2003)

Post Reply