Device only syncs if started as soon as MMW started

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

daryan
Posts: 30
Joined: Wed Dec 26, 2007 5:33 pm

Device only syncs if started as soon as MMW started

Post by daryan » Sat Nov 24, 2018 11:07 am

I have a really interesting issue: I use MMA to sync from MMW and it is all set up and working (I am a long time user of MM and have been through many different devices / versions). However; I am now seeing a problem where phones will only connect to MMW if you initiate the sync immediately after starting MMW. If you miss that small window to initiate the sync then it doesn't accept the connection. I am baffled! I have obviously looked at the firewall and switching it off doesn't allow the connection, plus the connection is able to go through in that small window after the MMW app has started so the rules are obviously working. It seems to me that there is something in the MMW app (a service of some sort) that creates an application firewall that blocks the connection but that this doesn't start immediately with the app. When it has started though, there is nothing I seem to be able to do to initiate the connection from the MMW devices (I have tried multiple) to get the sync working. All suggestions gratefully received

Lowlander
Posts: 46283
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Device only syncs if started as soon as MMW started

Post by Lowlander » Sat Nov 24, 2018 1:36 pm

Which version of MMA and MMW?
Lowlander (MediaMonkey user since 2003)

daryan
Posts: 30
Joined: Wed Dec 26, 2007 5:33 pm

Re: Device only syncs if started as soon as MMW started

Post by daryan » Sat Nov 24, 2018 4:22 pm

MMA 1.3.2.0824
MMW 4.1.23

Sorry, I should have included that above

JeffV64
Posts: 146
Joined: Sat Jul 07, 2007 3:18 pm

Re: Device only syncs if started as soon as MMW started

Post by JeffV64 » Sat Nov 24, 2018 4:59 pm

I have been having trouble getting MMA to connect to MMW, but I was able to get it to work by shutting MMW down and then as the program was loading, pressing sync. It took a couple of attempts, and syncing has been working intermittently for me, but I did get a sync started this way. Hopefully this will help others, and help the devs sort the problem. ~ Jeff

MMW 4.1.23.1881 and MMA 1.3.2.0824, Pixel 3

Lowlander
Posts: 46283
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Device only syncs if started as soon as MMW started

Post by Lowlander » Sat Nov 24, 2018 5:13 pm

Related: https://www.mediamonkey.com/support/ind ... ork-at-all

They've been working on this, not sure if the fix was on MMW or MMA (would be 1.3.3).

If you want to help troubleshoot you can capture a debug log (step 4b) for MMW: viewtopic.php?f=12&t=69 Does MMA also fail using MMW Library over UPnP when wifi sync fails?
Lowlander (MediaMonkey user since 2003)

daryan
Posts: 30
Joined: Wed Dec 26, 2007 5:33 pm

Re: Device only syncs if started as soon as MMW started

Post by daryan » Sat Nov 24, 2018 9:55 pm

JeffV64 wrote:
Sat Nov 24, 2018 4:59 pm
I have been having trouble getting MMA to connect to MMW, but I was able to get it to work by shutting MMW down and then as the program was loading, pressing sync. It took a couple of attempts, and syncing has been working intermittently for me, but I did get a sync started this way.
Yes, this is exactly what I have to do and provided you get the timing right the sync connects and then completes. It sometimes takes a few attempts but always seems to work. I have tried changing the port numbers, including the 4000 number that is supposed to display the media server in MMW. Nothing.

I also ran a port scan with the app running and the port isn't open.

daryan
Posts: 30
Joined: Wed Dec 26, 2007 5:33 pm

Re: Device only syncs if started as soon as MMW started

Post by daryan » Sat Nov 24, 2018 9:57 pm

Lowlander wrote:
Sat Nov 24, 2018 5:13 pm

Does MMA also fail using MMW Library over UPnP when wifi sync fails?
Yes, the UPnP server is not visible in MMA. I'll work on getting a debug log sent through - it won't be for a couple of days though as I am away from home.

Peke
Posts: 12501
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Device only syncs if started as soon as MMW started

Post by Peke » Mon Nov 26, 2018 12:26 pm

Hi,
When you get back please test this steps. After MMA shows Scanning -> Start MMW and confirm that you access server?
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

JeffV64
Posts: 146
Joined: Sat Jul 07, 2007 3:18 pm

Re: Device only syncs if started as soon as MMW started

Post by JeffV64 » Tue Nov 27, 2018 9:44 pm

Peke, I don't know if this is what you mean, but I can verify the following (100% reproducible) in my environment:

If I have MMW running and initiate a sync on MMA, connection fails. I also cannot access the MMW media server via MMA, even though I can play access it via my Sonos app.

If I initiate either a sync or a search for the MMW server in MMA and then launch MMW, the action is successful.

I hope this helps.~ Jeff

JeffV64
Posts: 146
Joined: Sat Jul 07, 2007 3:18 pm

Re: Device only syncs if started as soon as MMW started

Post by JeffV64 » Thu Nov 29, 2018 9:20 am

I just submitted a ticket with debug logs showing a successful sync and a failed sync, and also my MMA log.

Jeff

daryan
Posts: 30
Joined: Wed Dec 26, 2007 5:33 pm

Re: Device only syncs if started as soon as MMW started

Post by daryan » Tue Dec 18, 2018 4:59 am

Ok, I have what I think may be an update to this. Completely by chance I moved my database from a network share to a local drive on the computer because I was seeing some fairly serious performance issues with MMW and I thought this might help. It did but it also appears to have let the sync start working

@JeffV64: have you by any chance got your database on a network share?

dfaa@mor19.uu.gl
Posts: 1
Joined: Wed Dec 19, 2018 6:20 am

DLNA server running but disappears from some clients

Post by dfaa@mor19.uu.gl » Wed Dec 19, 2018 6:39 am

I have used MediaMonkey for several years and haven't had this issue until the past few weeks. My DLNA server is visible to some devices on my network, but not others. I am currently unable to see it from either the MediaMonkey app or BubbleUPNP on my Android phone. After a reboot, it usually appears again and I can connect to it, but then it eventually disappears from the list again. The same problem occurs using certain other devices on my network as well, like my Panasonic smart TV. On the other hand, my Yamaha AV Receiver still sees the DLNA server and can connect and play music from it without issue. Nothing has changed in my configuration over the past few weeks that I am aware of. Does anyone have any idea what could cause this sort of behavior? Is there any debugging I can do or log I can access which might tell me why some devices can't consistently see the server anymore?

Lowlander
Posts: 46283
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: DLNA server running but disappears from some clients

Post by Lowlander » Wed Dec 19, 2018 12:35 pm

Which version of MediaMonkey and Windows?
Lowlander (MediaMonkey user since 2003)

mccracken02
Posts: 4
Joined: Tue Nov 13, 2018 1:45 pm

Re: Device only syncs if started as soon as MMW started

Post by mccracken02 » Thu Mar 07, 2019 11:57 am

I've been having this exact same problem for what seems like about a year now. I can confirm this happens with MMW: 4.1.23.1881 and MMA:1.3.3.0842

The proceedure I need to use almost every time is as follows:

Turn off wifi on android device
Close MMW
Go to MMA UPnP, which prompts me to enable wifi, enable wifi
Start MMW and then it shows up as a UPnP source
Use wireless sync

Peke
Posts: 12501
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Device only syncs if started as soon as MMW started

Post by Peke » Fri Mar 08, 2019 1:09 pm

mccracken02 wrote:
Thu Mar 07, 2019 11:57 am
Turn off wifi on android device
Close MMW
Go to MMA UPnP, which prompts me to enable wifi, enable wifi
Start MMW and then it shows up as a UPnP source
Use wireless sync
You do not need first step, just start MMW when MMA is searching for Server.

HINT: If you use latest beta after first time MMA finds MMW server you can save that setting and that will directly contact MMW instead of searching Network for available MMW servers.

HINT 2: SAme behavior is when you in options start search for MMW sync server.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

Post Reply