[SOLVED] Disable MM Auto Play

Get answers about the current release of MediaMonkey for Android

Moderator: Gurus

dwr1
Posts: 3
Joined: Mon Sep 03, 2018 4:45 pm

[SOLVED] Disable MM Auto Play

Post by dwr1 » Mon Sep 03, 2018 5:11 pm

Hello everybody,
I just registered for the Forums just to ask this question:

I have an Android 7.0 with MM for Android on it (Ver 1.3.2.0824)

I first bought it because (unlike the stock Android media player app) is displays the ENTIRE cover image when playing a song (I have 2200 mp3s that I spent months imbedding hi res cover images into every file). Stupid Android player cuts off vast chunks of it which is annoying

Since then I've come to really like this little player!

It has a behavior that I REALLY don't like.

Many times when driving to/from work I listen to audiobooks on the Audible app (1st book is free, I would recommend Ready Player One - MUCH better than the recent movie, read by Wil Wheaton).

EVERY TIME I connect my phone to a bluetooth device (my HimBox in one car, Honda HandsFree Link in my other car, my Bose SoundLink III, etc), NO MATTER WHAT APP I have open an ready to play, Media Monkey takes control and plays.

I have even tried having Audible's app ACTIVELY PLAYING my book in my hand when I turn on the car and it connects. The car's dash display quickly shows the Audible book title, narrator, chapter number, etc for about 1 second, then boom - Media Monkey is playing. Not one word from the narrator is heard before MM takes over.

Before installing MM I actually used the Android Player and it would play nicely and let Audible play when connecting to bluetooth.

Is there a way to disable or specify preferences for this behavior?

Thanks in advance for any help!

Lowlander
Posts: 46262
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Disable MM Auto Play

Post by Lowlander » Mon Sep 03, 2018 5:52 pm

In the Options you can disable it with resume play on connection.
Lowlander (MediaMonkey user since 2003)

dwr1
Posts: 3
Joined: Mon Sep 03, 2018 4:45 pm

Re: Disable MM Auto Play

Post by dwr1 » Mon Sep 03, 2018 7:21 pm

Thank you! That seems to have done it - at least on my SoundLInk I'll report back if it still behaves differently after I head to work tomorrow!

dwr1
Posts: 3
Joined: Mon Sep 03, 2018 4:45 pm

Re: Disable MM Auto Play

Post by dwr1 » Wed Sep 05, 2018 9:13 pm

OK, That DID work on the Bose Soundlink Mini and Soundlink III (note the ones I have DO NOT have the newer bluetooth control button that will pause/play the sending device).

It did NOT work with HondaLink. I got in the car, Audible player loaded and ready, but MM started playing.

I think it's because the car is sending a "play" signal once it connects to the device. MM has another setting in the Options called "Always respond to remote buttons (Responds to bluetooth or other controls even if another player was last used)". I turned that off also and not it seems to behave the way I want it to. The car display showed the Audible book title and since MM wasn't going to respond the the play command, Audible did and started playing.

Thank you Media Monkey for giving the USER control of these behaviors! I really dislike programmers that decide these things FOR you and you just better deal with it (I'm looking at you Apple, that's why I abandoned you).

Post Reply