Two bugs from me

Moderator: Gurus

kwicktech
Posts: 2
Joined: Fri Mar 22, 2013 11:59 am

Two bugs from me

Post by kwicktech » Fri Mar 22, 2013 12:04 pm

Just updated today (3/22/2013) to the latest update in the Store. I am still having these two issues (did not report previously as I just installed yesterday):

1. Scan Music folders seems to choke for me. My primary music folder is on a USB (3.0) external hard drive. I have approx. 3600 mp3s. MM will crash after trying to scan.
2. If I close MM, using the standard finger swipe from top to bottom of screen. I can still see Media Monkey (32bit) in my task list. I need to kill it from there.

I am running this primarily on a Surface Pro. But may run it on a Surface RT as well.

Thanks!

PetrCBR
Posts: 1622
Joined: Tue Mar 07, 2006 5:31 pm
Location: Czech
Contact:

Re: Two bugs from me

Post by PetrCBR » Sat Mar 23, 2013 6:53 am

Hi. Can you please try to removing folders with media to find out files causing crash?
re 2) if tou allow app to run at background, it will never close (it's not our feature)

rosa
Posts: 4
Joined: Mon Mar 25, 2013 3:01 pm

Re: Two bugs from me

Post by rosa » Mon Mar 25, 2013 3:23 pm

Hello I just register to the forum after seeing the devs reply on the windows store, that's a nice gesture.

Anyway my problem is the same one as op's . If I scan my library the program quits after 3-4 seconds.
but let explain a little bit further I hope this helps figuring this out.

CASE A:

Main desktop pc with big library (25000 songs and about 10 .mov videos) produces the same problems when scanning library.
The library's structure is \Music\[Artist Letter\[Album Artist]\[Album] everything is fully tagged and organized.

Case B:

Secondary laptop. With a recent clean install of win8. I was just transferring the music library from main pc decided to stop to try the MM app and it scanned the few albums I've had on my library (about 10 albums or so) everything looked great.
but the day after I decided to continue on transferring the music from pc A to pc B then the problem occurred.
I now have about 3000 songs on the secondary laptop but that's enough for mediamonkey app to crash
MM seem to hate big libraries.

MM still plays the first songs I scanned on the laptop the first day but nothing more.
I hope you guys have a solution because this is definitely the best music app on the windows store.

good luck

PetrCBR
Posts: 1622
Joined: Tue Mar 07, 2006 5:31 pm
Location: Czech
Contact:

Re: Two bugs from me

Post by PetrCBR » Mon Mar 25, 2013 4:33 pm

Rosa, is it crashing on specified tracks or is it random ? What tracks you cannot play ? Can you send me some ?

rosa
Posts: 4
Joined: Mon Mar 25, 2013 3:01 pm

Re: Two bugs from me

Post by rosa » Mon Mar 25, 2013 5:48 pm

PetrCBR wrote:Rosa, is it crashing on specified tracks or is it random ? What tracks you cannot play ? Can you send me some ?
NO, no. it crashes when updating the library only. when you "scan for new media" that's where MM crashes.
So if the app crashes I can never have new songs cause they won't be updated to the library. that's the main problem.
Everytime I scan for new media the app crashes.

One thing I noticed it's let's say I have a new album , and go to "open file" and select the song(s) MM does play the file(s) even though they're not added in the library, they play just fine. The problem is when attempting to scan for new media that's where the app crashes. so it's not that the the songs are buggy or anything like that.

PetrCBR
Posts: 1622
Joined: Tue Mar 07, 2006 5:31 pm
Location: Czech
Contact:

Re: Two bugs from me

Post by PetrCBR » Tue Mar 26, 2013 2:03 am

I see. When it crashes during scan, then any file causing app to crash so we will try to find it (and fix). Can you please try to scan folder by folder to see what track(s) causing crash and send it to me then, please ?

rosa
Posts: 4
Joined: Mon Mar 25, 2013 3:01 pm

Re: Two bugs from me

Post by rosa » Tue Mar 26, 2013 5:47 pm

Well I finally found the files causing the app crash. My ABBA songs :roll:

As I told you before I have my music folder structure like this:

"C:\Music\B\The Beatles\1965.-Help!\[SONGS]"

So I tried to add the "letter folders" separately in MM
I added "C:\Music\C\" and MM scanned the files just fine. Then I added "C:\Music\J\" and again everything went well.
The problem seems to be only on my "C:\Music'\A\" and I added each folder separately in my "a" folder trying to isolate the problem. The Problem is something inside my "C:\Music\ABBBA\"
So I Moved the Abba folder to my desktop and then scanned my library...AND IT WORKED!!! :D
Slowly, but it worked (2.5hrs to scan 25000files)

I'm gonna send you a pm with the abba folder. Maybe you can find something that causes MM crash.
I must say that those songs play just fine on any other player and they aapear on my iturnes, winamp, and Musicbee respective libraries.

PetrCBR
Posts: 1622
Joined: Tue Mar 07, 2006 5:31 pm
Location: Czech
Contact:

Re: Two bugs from me

Post by PetrCBR » Tue Mar 26, 2013 5:55 pm

Great job! Looking forward for your tracks.

kwicktech
Posts: 2
Joined: Fri Mar 22, 2013 11:59 am

Re: Two bugs from me

Post by kwicktech » Thu Mar 28, 2013 2:51 pm

PetrCBR wrote:Hi. Can you please try to removing folders with media to find out files causing crash?
re 2) if tou allow app to run at background, it will never close (it's not our feature)
OK, understood on #2. :)

On #1, it will be quite hard to systematically remove/add folders to see which is crashing (hundreds of folders). I do have ABBA...maybe that is the issue like the other poster :)

Thanks.

Post Reply