Knowledgebase
Apple Mobile Device (iPhone, iPod, iPad) not recognized (compatibility list)
Updated by Russell Samuels on Oct 16, 2019

Upgrades to the iOS firmware on iPhone, iPod touch, and/or iPad can break MediaMonkey's ability to communicate with these devices correctly, triggering an error that the '...firmware is not compatible with this version of MediaMonkey.'

If you see this error message it generally means that either:

  1. You're running an outdated version of iTunes or the version of iTunes from the Windows Store (which is not compatible with MediaMonkey). You need to install the latest desktop version of iTunes ( 64-bit version | 32-bit version ) to resolve this.
    Note:
    - if you attempt to download iTunes directly from the Apple site, you'll initially be presented with the Microsoft Windows Store version. To get to the desktop version manually, scroll down to "Looking for other versions?"  and click on "Windows >" and you'll be presented with the desktop version instead.
    - if you prefer to sync using iOS device drivers without installing iTunes, see this article.
  2. You're running an outdated version of MediaMonkey, and the device is only supported on a more recent release.
  3. MediaMonkey doesn't yet support the firmware on your device, and we're working on an update.

MediaMonkey 4.1.25 is compatible with:
- all iPods/iPhones/iPads running iOS 3/4/5/6/7/8/9/11/12/13 that are available as of Oct. 2019, provided iTunes desktop version is installed
- all non-iOS iPods 

MediaMonkey 4.1.23 is compatible with:
- all iPods/iPhones/iPads running iOS 3/4/5/6/7/8/9/11/12 that are available as of Oct. 2018, provided iTunes desktop version is installed
- all non-iOS iPods 

MediaMonkey 4.1.18 is compatible with:
- all iPods/iPhones/iPads running iOS 3/4/5/6/7/8/9/10/11 that are available as of Sept 2017, provided the latest version of iTunes is installed
- all non-iOS iPods

MediaMonkey 4.1.14 is compatible with:
- all iPods/iPhones/iPads running iOS 3/4/5/6/7/8/9/10 that are available as of Oct 2016, provided iTunes 12.4 is installed
- all non-iOS iPods

MediaMonkey 4.1.9 is compatible with:
- all iPods/iPhones/iPads running iOS 3/4/5/6/7/8/9 that are available as of Oct 2015, provided iTunes 12.3 is installed
- all non-iOS iPods

MediaMonkey 4.1.8 is compatible with:
- all iPods/iPhones/iPads running iOS 3/4/5/6/7/8.4 that are available as of June 2015, provided iTunes 12 is installed
- all non-iOS iPods

MediaMonkey 4.1.5 is compatible with:
- all iPods/iPhones/iPads running iOS 3/4/5/6/7/8 that are available as of Sept. 2014 (including iPhone 6 devices), provided iTunes 11.4+ is installed
- all non-iOS iPods

MediaMonkey 4.1.4 is compatible with:
- all iPods/iPhones/iPads running iOS 3/4/5/6/7 that are available as of Oct. 2013, provided iTunes 11.1+ is installed
- all non-iOS iPods including the iPod Nano 7G

The previous release of MediaMonkey (4.0.7) is compatible with:
- all iPods/iPhones/iPads running iOS 3/4/5/6 that are available as of Sept 2012, provided iTunes 10.7+ is installed
- all non-iOS iPods including the iPod Nano 7G

If you have iTunes 12.1 or newer and your device isn't recognized please see: http://www.mediamonkey.com/support/index.php?/Knowledgebase/Article/View/227/0/itunes-update-121071-of-windows-x64-breaks-synchronization


Note: MediaMonkey 4 can also sync with most any iPod, iPad, or iPhone via the following third party addon, which syncs the MediaMonkey library using iTunes:
http://www.mediamonkey.com/addons/browse/item/device-plugin-for-itunes/
(a version of this addon is also available for MediaMonkey 3).

(1083 vote(s))
Helpful
Not helpful

Comments (0)