Sony NW-A55 not all songs appear on playlist

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Sony NW-A55 not all songs appear on playlist

Re: Sony NW-A55 not all songs appear on playlist

by CosmicKnowledge » Tue Oct 27, 2020 4:25 pm

Lowlander wrote: Tue Oct 27, 2020 4:13 pm 1) What do you have selected for sync? Is it parts of Collections or do AutoPlaylists you created?
I don't know what you mean by parts of collections.... isn't any playlist or autoplaylist contained in a collection, even if it's just the default one? But I am syncing only autoplaylists.
Lowlander wrote: Tue Oct 27, 2020 4:13 pm 2) What settings do you have set for Playlist sync in the Device Profile?
I'm 1500 miles from home so I can't take screenshots right now but basically the same sync settings I had prior to the latest MM release. The prior settings worked. (although MM has an indexing problem that results in not all songs mentioned in the playlist being replicated to the device).
Lowlander wrote: Tue Oct 27, 2020 4:13 pm 3) Do the Playlist files not get created on the card (check with File Explorer) or can the device not read the Playlist files on the card?
Glad you asked because there's much misunderstanding.
a) If you browse the filesystem using any file explorer (e.g. explorer.exe, cmd.exe), you will find no M3U playlist text files anywhere on the SD card.

b) Since (a) is true, naturally the device will show no playlists.
Lowlander wrote: Tue Oct 27, 2020 4:13 pm 4) How exactly do you initiate sync?
I disabled/unchecked sync on initial connect. I press the sync button on the bottom right of the interface when the proper SD card is selected on the directory tree. The same way I've always done it.
Lowlander wrote: Tue Oct 27, 2020 4:13 pm Be as detailed as possible as sync is generally working.
It *was* (generally) working. It just didn't sync half the playlist contents.

This recent release definitely broke everything.

Re: From Bad to Worse

by CosmicKnowledge » Tue Oct 27, 2020 4:13 pm

Lowlander wrote: Tue Oct 27, 2020 2:28 pm Provide more details on your exact setup or capture this in a debug log (step 4b) and attach it to a Support Ticket: https://www.mediamonkey.com/forum/viewt ... p?f=7&t=69.

Are you syncing directly to the SD card or the SD card in a device?
What happened with all the logs and database you guys got from me for the first issue? Is that problem fixed?

Re: Sony NW-A55 not all songs appear on playlist

by Lowlander » Tue Oct 27, 2020 4:13 pm

1) What do you have selected for sync? Is it parts of Collections or do AutoPlaylists you created?

2) What settings do you have set for Playlist sync in the Device Profile?

3) Do the Playlist files not get created on the card (check with File Explorer) or can the device not read the Playlist files on the card?

4) How exactly do you initiate sync?

Be as detailed as possible as sync is generally working.

Re: From Bad to Worse

by CosmicKnowledge » Tue Oct 27, 2020 4:08 pm

Peke wrote: Tue Oct 27, 2020 3:04 pm Hi,
Are you referring to Sony NW-A55 from https://www.mediamonkey.com/forum/viewt ... 70#p472470 ?

Duplicates are worked on thru https://www.ventismedia.com/mantis/view.php?id=16901 and main issue is that A55 is not Android player where you can install MMA.

During summer I had few hours with A100 at my friends shop https://www.sony.com/electronics/walkma ... s#features and installed nightly build of MMA 2.0 it was amazing experience not a single issue with syncing to https://www.lexar.com/portfolio_page/hi ... s-i-cards/ and https://www.amazon.com/Lexar-Profession ... B088K39RBN Write speeds were around 60MB/s Direct to SDCard and around 25MB/s over Wi-Fi 802.11ac (450mbit connection). No duplicates playlist there at its place, clean folder structure, Sony native player registered all track and playlist (few tweaks needed, eg. relative path and playlists directly to music. But that is native player limitation Power player alongside MMA worked perfectly).
I'm not talking about MMA or Android. Let's not get sidetracked.

The Sony NW-A55 does nothing more than act as an SD card reader. MM simply copies files to the mounted filesystem. When are you guys going to fix this? A month ago, I gave you guys remote desktop access to my system, let you collect debug logs, gave you the MM database, etc.

I still have a paperweight.

Re: From Bad to Worse

by CosmicKnowledge » Tue Oct 27, 2020 4:06 pm

Lowlander wrote: Tue Oct 27, 2020 2:28 pm Provide more details on your exact setup or capture this in a debug log (step 4b) and attach it to a Support Ticket: https://www.mediamonkey.com/forum/viewt ... p?f=7&t=69.

Are you syncing directly to the SD card or the SD card in a device?
SD card in a device

Re: From Bad to Worse

by Peke » Tue Oct 27, 2020 3:04 pm

Hi,
Are you referring to Sony NW-A55 from https://www.mediamonkey.com/forum/viewt ... 70#p472470 ?

Duplicates are worked on thru https://www.ventismedia.com/mantis/view.php?id=16901 and main issue is that A55 is not Android player where you can install MMA.

During summer I had few hours with A100 at my friends shop https://www.sony.com/electronics/walkma ... s#features and installed nightly build of MMA 2.0 it was amazing experience not a single issue with syncing to https://www.lexar.com/portfolio_page/hi ... s-i-cards/ and https://www.amazon.com/Lexar-Profession ... B088K39RBN Write speeds were around 60MB/s Direct to SDCard and around 25MB/s over Wi-Fi 802.11ac (450mbit connection). No duplicates playlist there at its place, clean folder structure, Sony native player registered all track and playlist (few tweaks needed, eg. relative path and playlists directly to music. But that is native player limitation Power player alongside MMA worked perfectly).

Re: From Bad to Worse

by Lowlander » Tue Oct 27, 2020 2:28 pm

Provide more details on your exact setup or capture this in a debug log (step 4b) and attach it to a Support Ticket: https://www.mediamonkey.com/forum/viewt ... p?f=7&t=69.

Are you syncing directly to the SD card or the SD card in a device?

From Bad to Worse

by CosmicKnowledge » Tue Oct 27, 2020 12:42 pm

I bought MM about 2-3 months ago and I haven't been able to make it work since. My music player is a paperweight since I can't sync to it properly.

At first
---------------------------------
The majority of songs wouldn't sync for whatever reason. I use auto-playlists for everything. Then, playing around with file masks, I could get most songs to sync but it would create a massive amount of unnecessary duplicates on the device's SD card, which would use up all the available space on it.

Now
--------------------------------
I've installed the latest update (4.1.30.1914?) and now it syncs some songs but NO M3U playlist files are ever created on the SD card. No matter what I do, it just never creates M3U playlist files. So, I don't know if the first problem is fixed but now I have this second problem which has made a paperweight of the music player for months.

Come on guys.... This should've been fixed with MM 0.1 BETA.

Re: Sony NW-A55 not all songs appear on playlist

by Peke » Tue Sep 08, 2020 4:48 pm

Hi,
Most likely their software have limit of 999 tracks.

Re: Sony NW-A55 not all songs appear on playlist

by CosmicKnowledge » Mon Sep 07, 2020 1:26 pm

Murdie wrote: Fri Sep 04, 2020 1:33 am Hi guys I posted on the the other sony playlist thread yesterday so this information is fresh in my head for the a40 series and the unit hasnt changed that much

"Hint
Up to 999 tracks can be added to a playlist."
This line is also in your online manual from sony page (sorry cant share the url it wont let me) the same as it was for the a45 as i put in my https://www.mediamonkey.com/forum/viewt ... 23#p472323
Hope this helps
I just synced a larger playlist and the A55 doesn't appear to have a 999 file limit per playlist. One playlist have > 1800 songs.

Re: Sony NW-A55 not all songs appear on playlist

by Murdie » Fri Sep 04, 2020 1:33 am

Hi guys I posted on the the other sony playlist thread yesterday so this information is fresh in my head for the a40 series and the unit hasnt changed that much

"Hint
Up to 999 tracks can be added to a playlist."
This line is also in your online manual from sony page (sorry cant share the url it wont let me) the same as it was for the a45 as i put in my https://www.mediamonkey.com/forum/viewt ... 23#p472323
Hope this helps

Edit
Also in case it applies to you for APE files you cant add files larger that 2gb and for any other file type larger that 4 gb. Also I havent tested it yet you cant add songs to a playlist thats not on that storage. i.e you cant add a song from the sd to a playlist stored on the internal memory or vice versa. should you want to start editing playlist on the device.

Oh and also I havent typed this out yet on that other thread. But single large transfers to the sony walkman can be interupted via power saving measures in windows. Now i aint sure this is a mm thing or a usb thing but its easy to check (I suspect another user on that thread had this issue). So if your screensaver comes on to a lock screen I think that trips the sync if so you will songs on the device but no playlist files as they are written at the end of the sync. its also happens when i change the energy profile where the computer wont sleep for an hour but the screen saver (to lock screen) comes on.

The fix is easy just restart the sync MM knows whats on the device and just continues on (although i usually tick the delete all other files option in sync just in case i get duplicates).

AND
I assume you are using plug in V1.2 as i typed yesterday in that thread not all the file types are in that plugin and if you have unticked auto conversion the sync might have just ignored flac wav files syncing only compatabile files so the fix is also on that forum link in that post. but MM i expected should have displayed a message saying that the files where missed for this reason upon sync completion

Re: Sony NW-A55 not all songs appear on playlist

by CosmicKnowledge » Tue Aug 11, 2020 1:53 am

Peke wrote: Mon Aug 10, 2020 11:11 pm Hi,
Thank you for update.

When you are done can you please export Device profile and send me a DL link so that I can compare with last plugin and see what is different?
Will do.

I'm now trying to sync a much larger collection of smartplaylists to the device. I'm having it output everything in a flat directory structure to \music\{autonumber}.

Re: Sony NW-A55 not all songs appear on playlist

by Peke » Mon Aug 10, 2020 11:11 pm

Hi,
Thank you for update.

When you are done can you please export Device profile and send me a DL link so that I can compare with last plugin and see what is different?

Re: Sony NW-A55 not all songs appear on playlist

by CosmicKnowledge » Mon Aug 10, 2020 2:34 pm

Peke wrote: Thu Aug 06, 2020 10:31 am Hi,
Yes, each Device profile have have path+filename destination masks that can be tweaked.

I do not have Sony on hand but if I remember correctly it shows as Drive letter. If yes you can try to play M3U from MM by Drag and Drop from device and you will see if all 1690 are loaded. Maybe some Format conversion needs to be adjusted for Sony. That is why profile existed and started in first place.

Keep safe, talk when you get back.
Ok, I'm back. So how are the filenames/paths put on the device simplified so that it doesn't have problems with special characters, long file names, or whatever?
  • The .m3u8 file has 1690 lines.
  • The SmartPlaylist in MM has 1690 files.
  • When I open the .m3u8 playlist from the device (drive letter H:) using Foobar 2000, it finds 1722 songs.
  • In Foobar2000, if I do Edit --> Remove Dead Items, the list shrinks to 1688 items.
Update 1: I'm trying a few experiments with masks under: (select SD card on tree) --> Options --> Music. By using \Music\<Playlist>\<Auto Number>, it might work. I did get all 1690 songs to be indexed and registered by the Walkman using the mask <Auto Number> and nothing else so I'm now trying a slightly more complex mask.

Re: Sony NW-A55 not all songs appear on playlist

by CosmicKnowledge » Thu Aug 06, 2020 4:47 pm

Peke wrote: Thu Aug 06, 2020 10:31 am Hi,
Yes, each Device profile have have path+filename destination masks that can be tweaked.

I do not have Sony on hand but if I remember correctly it shows as Drive letter. If yes you can try to play M3U from MM by Drag and Drop from device and you will see if all 1690 are loaded. Maybe some Format conversion needs to be adjusted for Sony. That is why profile existed and started in first place.

Keep safe, talk when you get back.
I might have to modify the profile somehow to simply/collapse/shorten paths and filenames (e.g. /MUSIC/BX/JA8JAL91829AKSO.mp3). I have no need for the device to retain original directory/filename labels. It's just playing music.

Top