Remote Speaker Output - Configuration Help Anyone..??

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Remote Speaker Output - Configuration Help Anyone..??

Remote Speaker Plug in - Configuration Puzzle

by sdelany » Tue Apr 07, 2020 3:23 pm

I'm a newbie to MM, trying to configure Eric Milles' remote speaker plugin on my Windows 10 PC. The plugin was successfully installed, and when I configure for remote speaker output in the output plugin panel, my AirPort Express appears as the sole choice. I selected it (right click > blue backing), hit "apply" and closed out the configuration window. However, when I try to play, I get an error message:"no remote speaker was selected."

The player works fine on my computer speakers when "MediaMonkey Direct Sound output" is selected.
The AirPort express connects and plays when connected to itunes (I did disconnect it from itunes before trying to configure MM, and also tried to configure when connected to itunes. Same error message on mm either way).

What am I missing? Is there something more that I need to do to configure and connect to AirPort express?

Thanks!

Re: Remote Speaker Output - Configuration Help Anyone..??

by wojki » Thu Jan 27, 2011 7:20 pm

HI
any news on this subject?
I have a problem with rso too. first MM with rso plugin doesn't start. i dont have the code yet, but it started once and then it doesn't. just after the window that ask for the activation code, when i choose evaluate nothing happens.
also, about the splash problem, what should i do to deactivate it when MM starts automatically at startup?
wojtek

Re: Remote Speaker Output - Configuration Help Anyone..??

by Peke » Mon Nov 22, 2010 2:30 pm

Re: Remote Speaker Output - Configuration Help Anyone..??

by New2MM » Sun Nov 21, 2010 7:21 pm

Trying out the Remote Speaker Output plugin along with MM. I used the /nosplash option since the activation dialog box gets hidden behind the Splash screen. However, on continuing to use the trial version, MM crashes and exits. I do not have the airport express connected yet (it's enroute to me) ... will this cause MM to crash and exit? I am using MM version 3.2.3.

[Update] I uninstalled the remote speaker software and MediaMonkey works without crashing.

Re: Remote Speaker Output - Configuration Help Anyone..??

by chauncey » Sun Oct 31, 2010 10:31 am

Just wanted to let you know that I had the same problem accessing the Remote Speaker (v2.5) dialog box when I started MM (3.2.2.1300). I added /NoSplash to the shortcut path and it worked. Now I'm just waiting for my activation code! Thanks Eric!

Re: Remote Speaker Output - Configuration Help Anyone..??

by hughmacph » Thu Aug 26, 2010 1:26 pm

emilles wrote:You could also enter that in the Start > Run dialog to test it quickly before going through the effort of changing your shortcut(s).
Starman!!

Tried this with the switch "\nosplash" (note the capitalisation) and I'm in!! I can see the Remote Speakers in the Outputs plug-in. I'm now away to do some testing!!

Many thanks Eric - looking forward to sending you USD25 shortly.

Best wishes from Scotland

Hugh

Re: Remote Speaker Output - Configuration Help Anyone..??

by emilles » Wed Aug 25, 2010 4:35 pm

It looks like running MM with the /NoSplash option (to disable the splash screen during startup) is a viable workaround. I was able to correctly interact with the Remote Speakers output dialog box and continue on to start MM normally.

To disable the splash screen, right-click your MediaMonkey shortcut and add /NoSplash to the Target. So, for example, my MediaMonkey shortcut is:

"C:\Program Files\MediaMonkey\MediaMonkey.exe" /NoSplash

You could also enter that in the Start > Run dialog to test it quickly before going through the effort of changing your shortcut(s).

Re: Remote Speaker Output - Configuration Help Anyone..??

by emilles » Wed Aug 25, 2010 3:41 pm

I was able to recreate the problem on my Windows XP box with MediaMonkey 3.2.2.1300. I vaguely remember this same issue with an earlier version of MM and I thought they made a change to fix it. I am thinking we should submit this as a MM bug to be fixed in a future version. In the meantime, I'll see if there is anything that can be done quickly in my plug-in to work around the problem.

Re: Remote Speaker Output - Configuration Help Anyone..??

by hughmacph » Tue Aug 24, 2010 5:30 pm

emilles wrote:Could you try running this version of Remote Speakers output with MediaMonkey to see if the startup issue is still occurring? http://emilles.dyndns.org/software/out_ ... -3.0b7.zip

Eric
Hi Eric

Sorry, been busy with work commitments for last few days. I've not tried the WinAmp suggestion mentioned earlier, but I did try this version of RSO. The same issue is occurring. The MM black start-up screen loads, and RSO is loading when viewed through Windows Task Manager, but MM does not fully load. I have to "End Task" for the RSO option in Task Manager for MM to load. Once up and running, RSO is not visible in Tools > Options> Player.

Two minor observations
(1) When I hover the mouse over the loading MM on the task-bar, I can't seen the RSO "days remaining" window - I could view this when I hovered over the earlier versions
(2) On my first attempt at setting this up, I copied the files to the MM directory (but ommitted to copy the out_apx.dll file to the plug-in directory). On this first attempt, MM loaded OK, but the plug-in was not visible in Tools > Options> Player etc.

Not sure if these help narrow-down what my problem is. I'll try the WinAmp suggestion from an earlier post, but it may be a day or two before I can get it done. Thanks again for your continued assistance here.

Hugh

Re: Remote Speaker Output - Configuration Help Anyone..??

by emilles » Fri Aug 20, 2010 9:01 pm

Could you try running this version of Remote Speakers output with MediaMonkey to see if the startup issue is still occurring? http://emilles.dyndns.org/software/out_ ... -3.0b7.zip

Eric

Re: Remote Speaker Output - Configuration Help Anyone..??

by hughmacph » Tue Aug 17, 2010 10:37 am

emilles wrote:You could try installing Winamp lite quickly to see if the activation dialog works there. If you can get the plug-in registered with Winamp, it will also be registered for MM. Then, MM might be able to start up normally. (Once the plug-in is registered, you could uninstall Winamp.) I'll also see if I can put together a more recent build for you to test, but that may take a day or two.
Ok, thanks for the suggestion. I'll try that later and post back the outcome.

Thanks

Hugh

Re: Remote Speaker Output - Configuration Help Anyone..??

by emilles » Mon Aug 16, 2010 10:33 pm

You could try installing Winamp lite quickly to see if the activation dialog works there. If you can get the plug-in registered with Winamp, it will also be registered for MM. Then, MM might be able to start up normally. (Once the plug-in is registered, you could uninstall Winamp.) I'll also see if I can put together a more recent build for you to test, but that may take a day or two.

Re: Remote Speaker Output - Configuration Help Anyone..??

by hughmacph » Mon Aug 16, 2010 3:40 pm

emilles wrote:
hughmacph wrote:When I load up Media Monkey, a dialog box warns "Cannot locate pcgw32.dll" When I look at the plug-in directory, the file pcgw32.dll is in the plug-in folder, along another dll file called pcgw32_rso.dll (which I guess looks like some sort of RSO variant or linking file).
pcgw32.dll and pcgw32_rso.dll should go in the same folder as MediaMonkey, not its plugins. If you move the files, the issue should be fixed. However, it is best to use the installer, choosing the MM directory instead of the Winamp directory, to manage this. If any new files are added, you would not need to do any additional work if using the installer to manage.
Hi Eric

I uninstalled all files installed for RSO (including pcgw32.dll and pcgw32_rso.dll) and started again with the installer. I think I had manually moved them at one stage to see if this would "fix" loading of MM & RSO.

The installer correctly places the 2 x pcgw32 files in MediaMonkey and the out_apx.dll in the plug-ins directory. Alas, it is still not working. When I start MM, the black dialog box showing MM is loading appears, but MM does not start. If I look in Windows Task manager, I can see an application "Remote Speakers Ouput" is loading, and if I hover the mouse over the MM icon in the toolbar, I can see the RSO "Evlauate/Activate/Days Remaining" dialog box, but it does not fully load to allow me to select any of the options. I am kept in limbo - I have to "kill" the RSO application in Windows Task Manager which allows MM to fully load (RSO plug-in not visible in Tools > Options > Player etc).

I'm really stuck here and I really want to use RSO...!! Bought a nice new shiny Airport to stream all my MM content and Remote Speaker was my last linkin the chain!! Any suggestions would be very gratefully received. Please let me know if you need more info or detail. Thanks again, Eric.

Hugh

Re: Remote Speaker Output - Configuration Help Anyone..??

by emilles » Mon Aug 16, 2010 7:33 am

hughmacph wrote:When I load up Media Monkey, a dialog box warns "Cannot locate pcgw32.dll" When I look at the plug-in directory, the file pcgw32.dll is in the plug-in folder, along another dll file called pcgw32_rso.dll (which I guess looks like some sort of RSO variant or linking file).
pcgw32.dll and pcgw32_rso.dll should go in the same folder as MediaMonkey, not its plugins. If you move the files, the issue should be fixed. However, it is best to use the installer, choosing the MM directory instead of the Winamp directory, to manage this. If any new files are added, you would not need to do any additional work if using the installer to manage.

Re: Remote Speaker Output - Configuration Help Anyone..??

by Melloware » Sun Aug 15, 2010 6:13 pm

hughmacph wrote:PS I also use MonkeyTunes - could that be causing RSO problems...?? Just a thought....
It might be. See this post when I discovered RemoteSpeakers was causing interference and what Eric did to fix his code.

http://forum.melloware.com/viewtopic.php?f=16&t=7889

Top