Syncing Copies All Tracks Again

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Syncing Copies All Tracks Again

Re: Syncing Copies All Tracks Again

by Lowlander » Wed Feb 12, 2014 11:47 am

The update checked doesn't check for beta releases.

Re: Syncing Copies All Tracks Again

by daodb » Wed Feb 12, 2014 11:41 am

Lowlander wrote:Your MMW is outdated as the latest release is 1690.
I just updated. Haven't tried to use the sync button yet and just did the manual sync that I described, then remember I had a forum post. Do you know why my Mediamonkey did not detect I was out of date, and had to manually re-download the new version?

Thanks

Re: Syncing Copies All Tracks Again

by meljmartin » Sun Feb 02, 2014 9:07 am

I figured out what happened. Problem was on server side. Thanks anyway. GL.

Re: Syncing Copies All Tracks Again

by Lowlander » Fri Jan 24, 2014 9:31 pm

Your MMW is outdated as the latest release is 1690.

Re: Syncing Copies All Tracks Again

by daodb » Fri Jan 24, 2014 5:49 pm

Lowlander wrote:Which version of MMA and MMW are you using?
I got it to work by going into my media servers, selecting the media monkey server, going to playlists, newly added, and selecting the 6 songs I wanted to add.

The MMA is the "Build 222", just updated yesterday.
The MMW is 4.1.0.1685

Re: Syncing Copies All Tracks Again

by Lowlander » Fri Jan 24, 2014 4:33 pm

Which version of MMA and MMW are you using?

Re: Syncing Copies All Tracks Again

by daodb » Fri Jan 24, 2014 4:27 pm

BigInJapan wrote:If you start from a clean state and only ever use Wifi sync, do you still see this issue?

My experience so far has been that if I stick to Wifi 100% of the time, syncing works fine. When I start trying to switch between Wifi and USB, things get screwy. I'm also finding that Wifi sync copies tracks about as fast as USB, so I'm not finding a need to go back to USB once I have Wifi working.

I'm still tinkering, so I'm curious if others are having similar experiences with this.
I was having this problem using only USB. Then, I deleted all of my music (4100 files), and went strictly to WiFi. The nightmare has continued, as it is doing the same... saying it's recopying the whole library.

Please tell me you all found a fix!

Re: Syncing Copies All Tracks Again

by BigInJapan » Tue Mar 19, 2013 9:45 am

If you start from a clean state and only ever use Wifi sync, do you still see this issue?

My experience so far has been that if I stick to Wifi 100% of the time, syncing works fine. When I start trying to switch between Wifi and USB, things get screwy. I'm also finding that Wifi sync copies tracks about as fast as USB, so I'm not finding a need to go back to USB once I have Wifi working.

I'm still tinkering, so I'm curious if others are having similar experiences with this.

Re: Syncing Copies All Tracks Again

by MarkODD » Wed Mar 13, 2013 4:17 pm

Well after a week of frustration of trying to get sync working over MTP with my Samsung SII I have given up. In the end it would not even copy over any new tracks that I placed in the sync list, even after I took the SD Card out of the phone and synced to the internal storage.

I have gone back to connecting in USB mode. It still copies all tracks again every sync but at least it does copy what is in the list. Also after I followed captainmcl's advise and cleaned up my device profiles two way syncing seems to be working again. That is plays and rating changes on the phone are being synced back to MMW. Yay!

MMW1627, MMA 106, Windows 7

Re: Syncing Copies All Tracks Again

by MarkODD » Fri Mar 08, 2013 3:05 am

Synced 2 albums to Samsung Galaxy SII 16GB external SD card over MTP. The existing ratings from MMW were not exported to MMA. Played 1 song with a play count of 0 in MMW on the phone and rated it. Reconnected over MTP and auto synced. The play count in MMW was not increased, the rating was not updated in MMW.

At least all the tracks were not copied over again.

Re: Syncing Copies All Tracks Again

by captainmcl » Thu Mar 07, 2013 10:26 pm

This is the same problem I was having, but I am not any more. Of course it's always hard to say why something changes, but I think that part of my problem was the introduction of WiFi synching. It appears (and someone with more behind-the-scenes knowledge can correct me here) that MMW creates a new profile for the WiFi connection, separate from the USB sync profile. It may also have created a separate one for MMA via USB since I already had a non-MMA USB profile for my device. This would make sense because (it would seem) that synching to its own db on the device would be a different protocol than synching to an Android device for use with a non-MM player.

Anyway, I went through my device profiles and cleaned out a bunch of extras. Once the WiFi sync profile is created, it appears that MMW uses that every time going forward. I think that solved at least a portion of my struggles.

Re: Syncing Copies All Tracks Again

by MarkODD » Thu Mar 07, 2013 4:09 pm

Hi Ludek

I tested using MMW 4.1.0.1626, MMA 1.0.4.0106, but I connected via USB mode. I will try MTP tonight.

Re: Syncing Copies All Tracks Again

by Ludek » Thu Mar 07, 2013 11:04 am

Hi, I cannot replicate.

Tested MMW 4.1.0.1626, MMA 1.0.4.0106, Galaxy Nexus connected in MTP mode.

What is your phone/USB mode? Could you re-test with the newest versions whether it is still issue for you?

Re: Syncing Copies All Tracks Again

by MarkODD » Fri Mar 01, 2013 1:52 am

I checked and the files are not being duplicated anywhere. MM just recopies them to same location they were already in (external_sd/music) every time I sync. Interestingly the phone refers to the path as /sdcard/external_sd/music.

Re: Syncing Copies All Tracks Again

by BigInJapan » Thu Feb 28, 2013 1:18 pm

In some of my sync experiments, I've managed to confuse MM over whether it should be writing to the internal or external storage. When I did this, it looked like sync was recopying all tracks over every time I switched from WiFi to USB. I think I see what I did wrong, but I don't want to get into it here until I'm sure.

The issue in this thread may well be 100% different from my own. I'm curious though, for the people in this thread who see all tracks copied again, have you checked to see if you have files duplicated between your internal and external storage?

Top