Extension versioning requirements

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Extension versioning requirements

Re: Extension versioning requirements

by TIV73 » Tue Aug 04, 2020 1:20 am

Excellent, thanks for the clarification!

Re: Extension versioning requirements

by Ludek » Mon Aug 03, 2020 4:20 pm

Currently only

Code: Select all

"version": "2.5.9"
is valid.

So typically start with

Code: Select all

"version": "1.0.0"

Extension versioning requirements

by TIV73 » Sun Aug 02, 2020 1:51 pm

Hi there,
is there any documentation available on how versioning is handled for extension? I understand info.json should contain a version attribute, and if the version of an extension is higher than the version of an already installed extension with the same id, mediamonkey will upgrade it.

What I'm curious about is how that version needs to look like. Can I just use an integer and count up, or do should proper semver 2.0 version numbers be used? To provide some examples, which of the examples below would be considered valid for mediamonkey in order to correctly detect extension updates if the version is increased?

Code: Select all

"version": 2
"version": "2"
"version": "2.5"
"version": "2.5.9"
"version": "2.5.9-beta"

Top