Convert Format: Missing 'Added' timestamp for first two tracks

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Convert Format: Missing 'Added' timestamp for first two tracks

Re: Convert Format: Missing 'Added' timestamp for first two tracks

by PeterXXX » Mon Jul 27, 2020 6:01 am

Experienced this again in MM4 while ripping from CD.
- one track (say #5) had an error
- after the rip of the rest the window with the failed track popped up and I selected 'Retry' for this track
- next popup said that the item already exists, 'Replace' was selected
- rip finished successfully, but without 'Added' timestamp for this track.
Maybe this can help.

Re: Convert Format: Missing 'Added' timestamp for first two tracks

by PeterXXX » Sat Jul 11, 2020 10:20 am

Sorry, but I really can't remember whether I was questioned to replace existing files or not.
Obviously this happens rather rarely, as after checking my library (about 28.000 tracks, 3.800 of them FLAC) there was only 1 additional track without Added-date in MM5 and 2 (total) in MM4.
The additional track from MM5 is ripped with MM4 and has no Added-date there too.
For the other track in MM4 I'm rather sure to remember that there was a problem with the rip, also the timestamp shows that it was created 1 day later than the rest of the album.

As this neither occurs often nor is a big bug I wouldn't mind if you drop the whole thing.

Re: Convert Format: Missing 'Added' timestamp for first two tracks

by Lowlander » Fri Jul 10, 2020 9:16 pm

Are you saying that the first 2 files failed both conversions (WAV > FLAC and FLAC to MP3) ?

Re: Convert Format: Missing 'Added' timestamp for first two tracks

by PeterXXX » Fri Jul 10, 2020 8:15 pm

Sorry, could not reproduce BUT
maybe it is something I already realized in MM4:
If a rip/format conversion failed for one track or another and you select the 'Repeat' option for those tracks they don't have an 'Added' timestamp.

Re: Convert Format: Missing 'Added' timestamp for first two tracks

by Lowlander » Fri Jul 10, 2020 12:38 pm

A debug log as requested above would be best to help resolve this.

Re: Convert Format: Missing 'Added' timestamp for first two tracks

by PeterXXX » Fri Jul 10, 2020 12:29 pm

Image
Screenshot of affected files.
They are not corrupted or changed in audio content.

Re: Convert Format: Missing 'Added' timestamp for first two tracks

by Lowlander » Fri Jul 10, 2020 10:57 am

Screenshots: https://www.mediamonkey.com/support/ind ... orum-posts

Or open a Support Ticket and attach the files there if that's easier.

Re: Convert Format: Missing 'Added' timestamp for first two tracks

by PeterXXX » Fri Jul 10, 2020 10:05 am

Lowlander wrote: Thu Jul 09, 2020 5:02 pm Which version of MediaMonkey?
Build 2259 was used with Win 10 (2004, x64).
Don't know how to attach a screenshot here.
Lowlander wrote: Thu Jul 09, 2020 5:02 pm In that case the result is expected as both FLAC and MP3 copy belong to the same Album.
Already thought that this behaviour is intended.

Re: Convert Format: Missing 'Added' timestamp for first two tracks

by Lowlander » Thu Jul 09, 2020 5:02 pm

Which version of MediaMonkey?

I tried to convert an Album (WAV) not in the Library to an Album (MP3) to be added to the Library and all files show Added as expected. If you can reproduce on build 2259 can you capture this in a debug log (step 4b) and attach the log to a Support Ticket: https://www.mediamonkey.com/forum/viewt ... 30&t=86643
PeterXXX wrote: Thu Jul 09, 2020 4:39 pmIf I click one of these albums in one of these playlists the tracks are listed twice showing both formats.
Do you mean that you're viewing the Album in MediaMonkey after this? In that case the result is expected as both FLAC and MP3 copy belong to the same Album. If this is not it, please detail exactly (a screencast or screenshots may help) what you're doing when you 'click on an Album'.

Convert Format: Missing 'Added' timestamp for first two tracks

by PeterXXX » Thu Jul 09, 2020 4:39 pm

Format conversion from WAV files (not in library) to FLAC (to library) had no 'Added' timestamp in the first 2 (of 10) tracks. Also after later conversion from FLAC to MP3 of these files, stored in different folders of the library, the same occured.
Furthermore I have different playlists for 'Recently added (FLAC)' resp. '... (MP3)', which often contain the same albums (in different folders). If I click one of these albums in one of these playlists the tracks are listed twice showing both formats.

Top