ActiveX Browser Version [#7383]

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: ActiveX Browser Version [#7383]

Re: ActiveX Browser Version [#7383]

by Ludek » Mon Dec 11, 2017 4:19 pm

Aff wrote:Hi Ludek

MonkeyRock doesn't work with DEC value 11001 (IE11)!
I don't know why, but it works with up to 10000 or 10001 (IE10), which is sufficient for my case of the web radio.
OK, I will lower it to 10000.
Aff wrote: MM doesn't set the registry value (using your exe), but I've tested in portable mode only, so maybe that's intended behaviour?
Yes, in the portable mode the registry key is untouched.

Re: ActiveX Browser Version [#7383]

by Aff » Mon Dec 11, 2017 3:16 pm

Hi Ludek

MonkeyRock doesn't work with DEC value 11001 (IE11)!
I don't know why, but it works with up to 10000 or 10001 (IE10), which is sufficient for my case of the web radio.

MM doesn't set the registry value (using your exe), but I've tested in portable mode only, so maybe that's intended behaviour?

Re: ActiveX Browser Version [#7383]

by Ludek » Fri Dec 08, 2017 9:59 am

Hmm, but running MediaMonkey.exe re-writes the value back to 9999.

So you just need to replace your current MediaMonkey.exe file (in your MM install dir) by this one:
https://www.dropbox.com/s/fsqtmnbyz1t2e ... y.exe?dl=0
and the value will be set to 11001 automatically on MM atart (Internet Explorer 11), more about the values here https://msdn.microsoft.com/en-us/librar ... s.85).aspx

EDIT: Fixed as http://www.ventismedia.com/mantis/view.php?id=7383 in build 4.1.20.1860

Re: ActiveX Browser Version [#7383]

by Ludek » Fri Dec 08, 2017 9:47 am

Hi, could you please do this test:

1) Run regedit (press WinKey and type regedit)
2) In regedit go to:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION\
and check the value under all "MediaMonkey" entries, the value should be 0x270f (9999), try to increase it to 0x2af8 (11000) for all MediaMonkey entries and, does it solve the issue for you?

Re: ActiveX Browser Version [#7383]

by Aff » Fri May 01, 2015 7:36 am

Same issue with 4.1.6.1736 (portable mode) and IE 11 on Windows 7 64.
I remarked it when I wanted to load a web radio (http://player.gds.fm/) inside MM (bookmark in Web node) and the page told me that the IE version was too old.

I've fixed it by adding a registry key:

Code: Select all

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION]
"mediamonkey.exe"=dword:00002af8
Source of information:
http://weblog.west-wind.com/posts/2011/ ... IE-Version

Is there any progress in fixing this issue?

Re: ActiveX Browser Version [#7383]

by CarlitoGil » Sat Dec 14, 2013 2:40 am

Hey, I think this can be ready for 4.1 after all.

There are two methods for loading web pages to the ActiveX browser in MediaMonkey.
  • .Interf.Navigate
  • .SetHTMLDocument
It seems that ".SetHTMLDocument" is triggering some kind of quirks mode, because the same document works fine if loaded with ".Interf.Navigate"

When generating content with a script, ".SetHTMLDocument" is the one to use, so please, fix this.

Save this to the scripts Auto folder as TEST_IE9.html

Code: Select all

<!DOCTYPE HTML>
<html>
	<head>
		<style type="text/css">
			span:first-child {text-decoration: underline;}
			span:last-child {color: red;}
		</style>
	</head>
	<body>
		<span>This should be red</span>
	</body>
</html>
Save this to the scripts Auto folder as TEST_IE9.vbs

Code: Select all

Sub OnStartUp()
    
	Dim oForm, sFile
	
	sFile = Left(Script.ScriptPath, InStrRev(Script.ScriptPath,"\")) &"TEST_IE9.html"

	Set oForm = SDB.UI.NewForm
	With oForm
		.Common.SetRect 0, 0, 300, 100
		.FormPosition = 4
		.Caption = ".SetHTMLDocument"
		With SDB.UI.NewActiveX(oForm, "Shell.Explorer")
			.Common.Align = 5
			.SetHTMLDocument(oFSO.OpenTextFile(sFile, 1, False, 0).ReadAll)
		End With
		.ShowModal
	End With

	Set oForm = SDB.UI.NewForm
	With oForm
		.Common.SetRect 0, 0, 300, 100
		.FormPosition = 4
		.Caption = ".Interf.Navigate"
		With SDB.UI.NewActiveX(oForm, "Shell.Explorer")
			.Common.Align = 5
			.Interf.Navigate(sFile)
		End With
		.ShowModal		
	End With	
	
 End Sub

Re: ActiveX Browser Version [#7383]

by CarlitoGil » Fri Dec 13, 2013 2:18 pm

As far as I can tell, even if it says it's IE9, CSS and JavaScript work the same as in IE7.

Re: ActiveX Browser Version [#7383]

by nohitter151 » Fri Dec 13, 2013 11:13 am

CarlitoGil wrote:
Ludek wrote:It is fixed in MM 4.1
Not quite, but you're getting there.

Thanks for working on this, it's important to me.
I've re-opened the issue for developer feedback.

Re: ActiveX Browser Version [#7383]

by CarlitoGil » Fri Dec 13, 2013 11:10 am

Ludek wrote:It is fixed in MM 4.1
Not quite, but you're getting there.

Thanks for working on this, it's important to me.


Before, the browser was limited to IE7, and now to IE9.
I'm going to assume that's by design.

But, the CSS property "border-radius" is supposed to work on IE9, and it doesn't in the MM browser.
The black square in this example should have rounded corners, but it doesn't.

Code: Select all

Dim Form, WB

Sub TestIE()
    
    Set Form = SDB.UI.NewForm
    Form.Common.SetRect 50, 50, 600, 400
    Form.FormPosition = 4
    Form.StayOnTop = False
    Form.Caption = "Test IE"

    Set WB = SDB.UI.NewActiveX(Form, "Shell.Explorer")
    WB.Common.Align = 5
 
    WB.SetHTMLDocument("<!DOCTYPE HTML><html><head><style>#TEST{border-radius:10px;background:#000;width:100px;height:100px;}</style></head><body><script>document.write(navigator.userAgent.match(/MSIE [\d.]+/)||'EDGE')</script><div id='TEST'></div</body></html>")
    
    Form.Common.Visible = True

End Sub
My system:
Windows 8.1 x64
Internet Explorer 11
MM 4.1.0.1672

Re: ActiveX Browser Version [#7383]

by Ludek » Fri Dec 13, 2013 5:35 am

Re: ActiveX Browser Version [#7383]

by CarlitoGil » Wed Sep 19, 2012 9:48 am

This was given an issue number a year and six months ago and I see no progress at all, yet.
We're up to Internet Explorer 10 and MM still forces IE7 mode.
Google doesn't support IE8, anymore.

I wonder if it's hard to implement or is just not regarded as important.

Re: ActiveX Browser Version [#7383]

by CarlitoGil » Sun Apr 08, 2012 11:00 pm

Shouldn't this have a higher priority?

Re: ActiveX Browser Version

by Lowlander » Tue Feb 15, 2011 11:21 am

ActiveX Browser Version [#7383]

by CarlitoGil » Fri Oct 01, 2010 11:00 pm

I have Internet Explorer 8 installed on Windows 7 x64,
yet I can't get a ActiveX Browser from a MM Script to get out of IE7 compatibility mode,

I'd like to know if this is a MM limitation or somehow it's IE8 configuration's fault.
IE9 is coming so it'll be nice to use CSS3 and other stuff.

With this script press Shift+B and if you have IE8 installed it should output "MSIE 8.0", does it?

Scripts.ini

Code: Select all

[TestBrowser]
Filename=TestBrowser.vbs
Procname=Test
Order=100
DisplayName=Test Browser
Language=VBScript
ScriptType=0
Description=Testing
TestBrowser.vbs

Code: Select all

Option Explicit

Sub Test()
    Dim Form, WB
    
    Set Form = SDB.UI.NewForm
    Form.Common.SetRect 50, 50, 600, 400
    Form.Common.MinWidth = 400
    Form.Common.MinHeight = 300
    Form.FormPosition = 4
    Form.StayOnTop = False
    Form.Caption = "Test"

    Set WB = SDB.UI.NewActiveX(Form, "Shell.Explorer")
    WB.Common.Align = 5
    WB.Common.ControlName = "WB"

    SDB.Objects("TestWindow") = Form
    SDB.Objects("TestWebBrowser") = WB
    
    WB.SetHTMLDocument("<!DOCTYPE HTML><html><head><meta http-equiv='Content-Type' content='text/html; charset=utf-8'><title></title></head><body><script type='text/javascript'>document.write(navigator.userAgent.match(/MSIE [\d.]+/))</script></body></html>")
    
    Form.Common.Visible = True

End Sub

Top