1436 Crashes after pressing Keyboard Media Buttons [#8421]

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: 1436 Crashes after pressing Keyboard Media Buttons [#8421]

Re: 1436 Crashes after pressing Keyboard Media Buttons [#842

by Lowlander » Mon Oct 17, 2011 6:07 pm

I think the issue is the exclusive access Maintain Library needs so when the playing track changes I've seen it cause problems too.

Re: 1436 Crashes after pressing Keyboard Media Buttons [#842

by Pman » Mon Oct 17, 2011 4:01 pm

Something i forgot to report about (found this bug around 1420ish) which i found by accident was if you have 2 or more songs in your playlist and then you run Complete Optimize Database on Maintain library, if you press play on your media touch key then the song plays for some strange reason.
But what's worse is when you press forward, the track will change but then Maintain Library window crashes and then occasionally Monkey crashes.

With current 1445 its much more stable and doesnt happen that often (whatever you did seemed to have done has fixed optimize library's speed...i once left it on for 15 hours and it still didnt finish and now it takes about 2 minutes :lol:).

Re: 1436 Crashes after pressing Keyboard Media Buttons [#842

by romeyinfc » Wed Sep 28, 2011 9:29 pm

Hi Jiri,

You're exactly right! After I stopped that process Media Monkey worked just fine! After installing IntelliType, I haven't had any more problems today.

Thanks for looking into this! I really appreciate it and am glad there's no issues with MM!

-Jeromey

Re: 1436 Crashes after pressing Keyboard Media Buttons [#842

by jiri » Tue Sep 27, 2011 4:24 pm

Jeromey, I found out the following (copied from our bug-tracking app):

Originally I thought that I'm able to reproduce the issue as follows: Rapid successive clicking of Play/Pause button on my Microsoft Natural Ergonomic Keyboard 4000 e.g. while Chrome was in focus caused random termination of either Chrome, Explorer or other applications.

However, then I found that it isn't related to MM at all, that I'm able to reproduce the very same issue e.g. while WinAmp or WMP is playing. It turned out that it's a bug in iType.exe application (IntelliType) that's installed with the keyboard. Once iType.exe is killed in Task Manager, the issue is gone.

Is it the same in your case?

Thanks,
Jiri

Re: 1436 Crashes after pressing Keyboard Media Buttons [#842

by romeyinfc » Tue Sep 27, 2011 8:57 am

Hello, I have the ELF file here: http://dl.dropbox.com/u/80676/MediaMonkey8421Elf.zip

If there's anything else I can provide, please don't hesitate to ask.

Regards,
Jeromey

Re: 1436 Crashes after pressing Keyboard Media Buttons [#842

by jiri » Tue Sep 27, 2011 2:17 am

Please try to locate MediaMonkey.elf file in the MediaMonkey installation folder. In case you can't find it, please try to reproduce again and if the error occurs, choose 'Copy to Clipboard' and send it to me. This would be more useful in this case.

Thanks,
Jiri

Re: [1436] App Crashes after pressing Keyboard Media Buttons

by rusty » Mon Sep 26, 2011 4:48 pm

Hi Jaromey,

Thanks. I'm unable to replicate, but am tracking the issue at:
http://www.ventismedia.com/mantis/view.php?id=8421

-Rusty

1436 Crashes after pressing Keyboard Media Buttons [#8421]

by romeyinfc » Mon Sep 26, 2011 4:01 pm

Hello,

This is related to bug #8200, where pressing the Prev & Next buttons on the multimedia keyboard would cause tracks to skip twice. I was originally impacted by this on the machine I'm using for MediaMonkey. After installing build 1436 I was streaming songs from my iPod and pressed the "Next" button on my keyboard, causing a 2x skip. After pressing it again, I got some errors that caused the application to crash.

I installed the Debugged version and saved the output, which can be downloaded at: http://dl.dropbox.com/u/80676/MediaMonk ... sh0926.zip
After the version detected the crash, it attempted to send a report, but that failed as well (I'm behind a proxy, which may be why).

Some details: Running Win 7 32-bit with 3GB of RAM. I have a Microsoft Digital Media Pro Keyboard plugged in that is causing the errors.

Steps to reproduce:
1)Started MM
2)Started iPod playback
3)Skipped song using "Next" button - worked
4) Waited ~ 15 Seconds, Skipped song again - which resulted in 2x skip
5) Waited ~ 15 seconds, Skipped song again, resulted in crash.

Let me know if I can provide any other detail.

Thanks,
Jeromey

Top