Song Startup Delay

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

aalphons1

Song Startup Delay

Post by aalphons1 »

Whenever I double click on a song in windows explorer, MM begins immediately, but the song takes 17 seconds to start. I've tried most suggestions on this forum without success. If I select a song within MM application it begins instantly. I don't have this issue with other media players.
Using Win7 x64 with Phenom quad cpu, 4gb ram. Help!
rovingcowboy
Posts: 14163
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: Song Startup Delay

Post by rovingcowboy »

other players don't do library or now playing playlist start up scans is my guess as to why they dont do that.
but in starting monkey you can never and have never been albe to play a song the instant you start mediamonkey.
he does not load that song at the same time he gets loaded and then looks for the song.

i've had monkey to launch with timers and start playlists at the same time, each time i do that monkey starts and does not
play the songs. its because monkey needs loaded first before you start a song or start a playlist.
if you are going to want to start songs you download and see if they are keepers then i suggest you start monkey before you do any of the downloading and let monkey sit there in the background waiting to play the songs.

:D
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy A51 5G Android ) 6. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.
Dreadlau
Posts: 1967
Joined: Sun Nov 25, 2007 6:49 am

Re: Song Startup Delay

Post by Dreadlau »

rovingcowboy wrote:other players don't do library or now playing playlist start up scans is my guess as to why they dont do that.
but in starting monkey you can never and have never been albe to play a song the instant you start mediamonkey.
he does not load that song at the same time he gets loaded and then looks for the song.

i've had monkey to launch with timers and start playlists at the same time, each time i do that monkey starts and does not
play the songs. its because monkey needs loaded first before you start a song or start a playlist.
if you are going to want to start songs you download and see if they are keepers then i suggest you start monkey before you do any of the downloading and let monkey sit there in the background waiting to play the songs.

:D
No, 17 seconds delay is not normal. There must be some problem.
Seven Ultimate X64 SP1 / Sansa Clip 2go (with RockBox)
Lowlander
Posts: 50176
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Song Startup Delay

Post by Lowlander »

A debug log send to support might be helpful: http://www.mediamonkey.com/forum/viewforum.php?f=7
Lowlander (MediaMonkey user since 2003)
rovingcowboy
Posts: 14163
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: Song Startup Delay

Post by rovingcowboy »

Dreadlau you telling me that mm 3 has been having this trouble since day one of mm 3 and it is not normal?
because its been in need of starting mm prior to starting the playback of any song for as long as i can remember.
maybe even back to mm 2.4.

if it was an issue back then, why was it not tracked as bug way back then.?

i've had to start my jukebox playing songs only after i have had mediamonkey up and waiting to play songs for at least one minute. no matter if i start songs from in the explorer or with the task scheduler or start the playlist from task scheduler
and my jukebox uses mm 3.1304 i just tried to open both again at the same time and monkey opens but the song does not play. there is no other reason for it then monkey did not have the time needed to see the play command or the file to play or both because monkey was trying to load, now remember of course i've got all songs on other harddrives. so there is a little lag time on that.
which i don't know if the first poster has other hds now or not but that could also be the cause of monkey not seeing the song when he is started.

of course that lag time statement might just answered why i have to do that and have had to for a long time., man ranting like that and i make the statment to make me stop ranting? i did it again. :roll:
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy A51 5G Android ) 6. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.
Dreadlau
Posts: 1967
Joined: Sun Nov 25, 2007 6:49 am

Re: Song Startup Delay

Post by Dreadlau »

@rc
If I open a song from windows explorer.
MM opens and plays the song.

It seems to me that this is the expected behavior.
I suspect there is some issue with MM on your setup.

For the lag. Sure it's not supposed to be instant.
But the original poster has a fast computer and 17 seconds is abnormal.
Seven Ultimate X64 SP1 / Sansa Clip 2go (with RockBox)
rovingcowboy
Posts: 14163
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: Song Startup Delay

Post by rovingcowboy »

i don't have a fast win 7 computer with a quad core and mediamonkey on it.
but this xp computer with a dual core is fast. :)
and it does the same thing to me on this one it makes me start monkey first then the song or it won't play the song,
even though the songs are on the same hd here on this computer.

the jukebox of mine is only a single core amd. but it is only runing mediamonkey and very few things like timers on windows so there is no clutter being held in ram to slow it up. so when giving it a command its faster then this one is
because this is running tons of things to stay online and all the blocking software needed for safe surfing.

their error could be something simple like their av program is scanning the file that caused monkey to start up? :o

so i really doubt the 17 seconds is caused by monkey but a debug report like lowlander asked for should find the error.

8)
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy A51 5G Android ) 6. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.
GzyOnline
Posts: 21
Joined: Sat Dec 03, 2011 10:18 pm

Re: Song Startup Delay

Post by GzyOnline »

aalphons1 wrote:Whenever I double click on a song in windows explorer, MM begins immediately, but the song takes 17 seconds to start. I've tried most suggestions on this forum without success. If I select a song within MM application it begins instantly. I don't have this issue with other media players.
Using Win7 x64 with Phenom quad cpu, 4gb ram. Help!
oh good, i thought i was the ONLY one having this bug/lag/delay issue, however the posting date of this topic leads me to believe that my issue is completely separate from the OP's..

very very long time user of MM here, since Winamp glory days.. I only notice the lag/delay issue after I installed Win8, and now Win8.1 (after many years of suffering, I'm thinking my last resolution is to quit w/Win8.1 and revert back to Win7 [yes, just for MM] and see if my problem ceases).. suffering with this bug over the past years, I'm inclined to lean towards the side that this may be the long standing Run As Admin/permissions issue that MM has been suffering from in Win8.. idk? it's been a VERY LONG time since I've updated my MM (or it seems like!?),

current MM version: 4.5.1718
Windows 8.1 Pro 64-bit | 8 GB RAM | Custom-Built Intel Core 2 Duo

Any ideas? Has a resolution to this issue been introduced in some updates that I'm behind on?
THANKS!!!

edit: and just to be clear it's not just during initial opening of MM (to eliminate the start-up library monitoring reasoning), it's even many hours after MM has been open.. simply using the mouse double.click.to.open method in Windows Explorer to begin playing a media file results in a marginal delay before playback begins.. one temporary and longstanding solution I have discovered is that if the file is dragged from Windows Explorer to MM Now Playing frame, playback begins immediately.
dtsig
Posts: 3432
Joined: Mon Jan 24, 2011 6:34 pm

Re: Song Startup Delay

Post by dtsig »

This is not an answer to your question and to my thinking the problem is a combination of win8 and ... In win7 if mmw is open it will start playing almost instantaneous when dclick a file in explorer as it should.

But I have to ask, you say even after hours of MM this still happens when you double click on explorer. Why would you be using explorer instead of MMW to look at your music files? It sounds like you are just using mmw to just play your tracks. No biggs .. just curious
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig
rovingcowboy
Posts: 14163
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: Song Startup Delay

Post by rovingcowboy »

Old information of mine above. I now have win 7 4 core. 8 gb ram songs on separate hd. No lag time i use free mm 4 and it plays as soon as i click the play button. But I'm wondering that I get this speed on win 7 because I still use mm in real-time priority.
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy A51 5G Android ) 6. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.
GzyOnline
Posts: 21
Joined: Sat Dec 03, 2011 10:18 pm

Re: Song Startup Delay

Post by GzyOnline »

dtsig wrote:This is not an answer to your question and to my thinking the problem is a combination of win8 and ... In win7 if mmw is open it will start playing almost instantaneous when dclick a file in explorer as it should.

But I have to ask, you say even after hours of MM this still happens when you double click on explorer. Why would you be using explorer instead of MMW to look at your music files? It sounds like you are just using mmw to just play your tracks. No biggs .. just curious
I'm short of all convinced it's a win8 issue.. when win8 first came out, there was a lot of issues w/ MM, specifically with rights/permissions/etc.. if MM was opened 'as administrator, windows explorer would have to be opened 'as administrator' as well, which isn't the easiest task to do...

but to address your question, i have over 3TB of music, i have mastered the organization of my files & folders in windows explorer and MM simply just can't accomplish that task.. a quick example: i have all my new/incoming albums sorted by date, and when i try to browse this collection in MM, it just list them by alphabetical order in the Media Tree, not to mention i have all of the screen to view my folders versus the very limited space in MM.. and I want to browse them by folder, not by each mp3 file
imagehopper

Re: Song Startup Delay

Post by imagehopper »

you are mistaken to say mediamonkey can not handle your setup.
monkey has the ability to handle your set up you just need to turn on the user friendly masks in the option of mm then set up the path you want in the text line of the auto organizer and monkey will put the songs in the order you set up if that is not enough then the add on script of magic nodes has added tons of ways to set up the pathways. this is what mm is better at then any other program. you just need to learn what monkey wants you to do in order to set it up the same way.
MMFrLife
Posts: 2803
Joined: Fri Oct 26, 2012 9:04 pm

Re: Song Startup Delay

Post by MMFrLife »

GzyOnline wrote:i have over 3TB of music, i have mastered the organization of my files & folders in windows explorer and MM simply just can't accomplish that task.. a quick example: i have all my new/incoming albums sorted by date, and when i try to browse this collection in MM, it just list them by alphabetical order in the Media Tree,
Can you write out an example of how you name a date sorted folder in explorer and how MM writes it out when sorting to the tree?
GzyOnline wrote:not to mention i have all of the screen to view my folders versus the very limited space in MM.. and I want to browse them by folder, not by each mp3 file
I know what you are saying and it isn't the same thing, but you can view through folders in MM (in MM's "my computer", sort on path column from MC or library, library's "location
node")
MM user since 2003 (lifetime lic. 2012) "Trying to imagine life without music gives me a headache"
Top 2 scripts: RegExp Find & Replace (e.v.) and Magic Nodes (e.v.) ZvezdanD's scripts site
others: Adv. Dup. Find & Fix and Backup 6.0, but buggy || software for power users: "Q-Dir"
(free alt. to explorer) and file/folder renamer- "ReNamer" (den4b)
MMW 4.1.31.1919; ...back it up...frequently!
timrh
Posts: 1
Joined: Sat Sep 20, 2014 11:34 am

Re: Song Startup Delay

Post by timrh »

I'm glad I am not the only one. With MM open, double click from Explorer takes ages to play the song. Launching from within MM is immediate. The reason I do it from Explorer rather than MM is that I have songs I don't particularly want to make part of my library, cos I am just listening to it one time. I agree that it seems to have appeared after upgrading to Win 8.
Lowlander
Posts: 50176
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Song Startup Delay

Post by Lowlander »

timrh wrote:The reason I do it from Explorer rather than MM is that I have songs I don't particularly want to make part of my library, cos I am just listening to it one time.
You can use the My Computer mode for that.
Lowlander (MediaMonkey user since 2003)
Post Reply