My AV receiver and TV cause MM to crash

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

robimart
Posts: 9
Joined: Mon Sep 29, 2008 2:46 am
Contact:

My AV receiver and TV cause MM to crash

Post by robimart »

I've been using MM for many years on my huge music collection and love everything about it. Everything except for it crashing and hanging all the time. I've had problems for years despite using different PCs, OS versions and Windows installations.

The problem is somehow related to the HDMI connection between my HTPC and my AV Receiver (Onkyo sr605, bought in 2008). Any of the following scenarios will either cause MM to lock up completely or require a MM close and restart for it work properly:
- pressing play on a song when my AV amp is not switched on
- switching sound channel on my amp while MM is playing
- switching tv on/off while music is playing

This is driving me MAD as I accidentally trigger the above conditions all the time. I've got a macro on my remote to kill all MM processes and restart as a workaround but there must be a better way. I've held off from asking here for a long time because it's not really a MM issue per se, but some guru here must have some ideas...? Anything I can try with the output plugins or other settings?

FWIW, I have one of those Zotac HTPCs with an Intel media chipset but sound is set to 'pass through' without processing. Any and all suggestions gratefully received :)

Thanks
Robimart
Lowlander
Posts: 47910
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: My AV receiver and TV cause MM to crash

Post by Lowlander »

Have you tried using a different Output Plugin?
Lowlander (MediaMonkey user since 2003)
robimart
Posts: 9
Joined: Mon Sep 29, 2008 2:46 am
Contact:

Re: My AV receiver and TV cause MM to crash

Post by robimart »

Hi Lowlander,

Yes, I've tried with 'MediaMonkey DirectSound output', 'MediaMonkey WASAPI output', and 'waveOut output v2.0.2a'. Same problem with all of them.

The AV receiver must be sending some commands to my HTPC to notify it of things like channel changes, which in turn crashes MM. Is there a way to suppress this bi-directional communication and make the PC just blast sound regardless of what's happening on the receiver?

The Intel HDMI pass-thru on my PC is a very common setup and my AV receiver is also a very common model, I'd be surprised if I'm the only one with such issues...?

Thanks
robimart
Lowlander
Posts: 47910
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: My AV receiver and TV cause MM to crash

Post by Lowlander »

Then I suggest capturing the crashes in a debug log (step 4b) and sending the log to support for developer analysis: http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=69
Lowlander (MediaMonkey user since 2003)
robimart
Posts: 9
Joined: Mon Sep 29, 2008 2:46 am
Contact:

Re: My AV receiver and TV cause MM to crash

Post by robimart »

So I spent a chunk of time last night trying to understand how the different plug-ins work.

I've switched to using WASAPI in 'exclusive' mode and that has (largely) fixed the problem. The downside of this is that it causes my amp to 'pause and click' every time I stop/start an audiostream as it appears to reinitialise. I also no longer have PC volume control and need to change that on the amp directly (hassle when using a remote control app etc.). However, these issues are a small price to pay for much greater stability!!

Thanks for the suggestions above.
Post Reply