Tags not sync'ing

Get answers about syncing the current release of MediaMonkey with iPods and other devices.

Moderator: Gurus

djmt99
Posts: 151
Joined: Sat Jan 31, 2009 2:36 pm
Location: Worcester, MA
Contact:

Tags not sync'ing

Post by djmt99 »

Device is an HDD. Initial Auto-Sync>Device copies OK. If I edit tags on device and Auto-Sync>Library, they sync ok back to the library. If I edit tags on from the library, it doesn't sync to the device. I have tried "Synchronize Tags" on both library and device, post sync.
Disc Jockey (DJ & VJ) ; AV & Lighting Tech ; Music Lover of all types
MediaMonkey Gold - Proud Lifetime License holder, Since Aug 2008
Lowlander
Posts: 47885
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Tags not sync'ing

Post by Lowlander »

Which version of MediaMonkey and what plugin do you use for syncing?
Lowlander (MediaMonkey user since 2003)
djmt99
Posts: 151
Joined: Sat Jan 31, 2009 2:36 pm
Location: Worcester, MA
Contact:

Re: Tags not sync'ing

Post by djmt99 »

4.1.28.1905 & Portable Device Sync. Unless there's a better option for this? I'm not updating every single file, so I figured auto-organize wasn't the best option. I haven't used PDS in a long time, but I'm fairly confident that I had it working good before! Thanks!
Disc Jockey (DJ & VJ) ; AV & Lighting Tech ; Music Lover of all types
MediaMonkey Gold - Proud Lifetime License holder, Since Aug 2008
Lowlander
Posts: 47885
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Tags not sync'ing

Post by Lowlander »

Under Tools > Options > Portable Device Sync it shows which dll is being used. Which are you using for the device?
Lowlander (MediaMonkey user since 2003)
djmt99
Posts: 151
Joined: Sat Jan 31, 2009 2:36 pm
Location: Worcester, MA
Contact:

Re: Tags not sync'ing

Post by djmt99 »

Ah, that could possibly it. It was WMDM, and since you pointed that out, I seem to recall it being USBMass. I installed that plugin, but it's pulling up settings from an old device. Many old devices, actually.

I also notice that even with USBMass, Sync>Library is empty, with no folders to select from. With WMDM, this auto-populated once I selected the folder in the tab prior, Sync>Device.

I'm running MM portable.
Disc Jockey (DJ & VJ) ; AV & Lighting Tech ; Music Lover of all types
MediaMonkey Gold - Proud Lifetime License holder, Since Aug 2008
djmt99
Posts: 151
Joined: Sat Jan 31, 2009 2:36 pm
Location: Worcester, MA
Contact:

Re: Tags not sync'ing

Post by djmt99 »

Any ideas on how to get things to sync both ways? And how to clear out old devices? I've tried deleting and reinstalling USBMass.
Disc Jockey (DJ & VJ) ; AV & Lighting Tech ; Music Lover of all types
MediaMonkey Gold - Proud Lifetime License holder, Since Aug 2008
Lowlander
Posts: 47885
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Tags not sync'ing

Post by Lowlander »

As far as I know bi-directional sync is only available with Android sync (ie. MediaMonkey only syncs to the device). So I'm not sure how you're having changed tags synced to MediaMonkey, but not to the drive.

You may have to open a Support Ticket with a debug log (step 4b) attached that captured the sync and lack of tag sync to the drive: viewtopic.php?f=12&t=69
Lowlander (MediaMonkey user since 2003)
djmt99
Posts: 151
Joined: Sat Jan 31, 2009 2:36 pm
Location: Worcester, MA
Contact:

Re: Tags not sync'ing

Post by djmt99 »

Lowlander wrote: Mon May 18, 2020 11:45 am As far as I know bi-directional sync is only available with Android sync (ie. MediaMonkey only syncs to the device). So I'm not sure how you're having changed tags synced to MediaMonkey, but not to the drive.

You may have to open a Support Ticket with a debug log (step 4b) attached that captured the sync and lack of tag sync to the drive: viewtopic.php?f=12&t=69
Bummer! I swear I was able to sync both ways before with the same configuration (main drive and usb drive). I'll submit a ticket and see where it goes.

Any idea how to clear out old data from the sync options? There are some old devices appearing that I haven't used in a years.
Disc Jockey (DJ & VJ) ; AV & Lighting Tech ; Music Lover of all types
MediaMonkey Gold - Proud Lifetime License holder, Since Aug 2008
Lowlander
Posts: 47885
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Tags not sync'ing

Post by Lowlander »

Right click on device under Tools > Options > Portable Devices to delete or select device there and use Delete button.
Lowlander (MediaMonkey user since 2003)
djmt99
Posts: 151
Joined: Sat Jan 31, 2009 2:36 pm
Location: Worcester, MA
Contact:

Re: Tags not sync'ing

Post by djmt99 »

Lowlander wrote: Mon May 18, 2020 3:23 pm Right click on device under Tools > Options > Portable Devices to delete or select device there and use Delete button.
That would be the obvious thing to do, however the Delete option is not available for 4 out of 6 devices. It's greyed out.
Disc Jockey (DJ & VJ) ; AV & Lighting Tech ; Music Lover of all types
MediaMonkey Gold - Proud Lifetime License holder, Since Aug 2008
Lowlander
Posts: 47885
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Tags not sync'ing

Post by Lowlander »

I believe you need to leave 1 iPod, iPhone and iRiver device, although you can remove the dll itself from the plugins folder if you don't use those devices.
Lowlander (MediaMonkey user since 2003)
Post Reply