Sony NW-A55 not all songs appear on playlist

Get answers about syncing the current release of MediaMonkey with iPods and other devices.

Moderator: Gurus

CosmicKnowledge
Posts: 110
Joined: Sun Mar 15, 2020 11:24 am
Contact:

Re: From Bad to Worse

Post by CosmicKnowledge »

Peke wrote: Tue Oct 27, 2020 3:04 pm Hi,
Are you referring to Sony NW-A55 from https://www.mediamonkey.com/forum/viewt ... 70#p472470 ?

Duplicates are worked on thru https://www.ventismedia.com/mantis/view.php?id=16901 and main issue is that A55 is not Android player where you can install MMA.

During summer I had few hours with A100 at my friends shop https://www.sony.com/electronics/walkma ... s#features and installed nightly build of MMA 2.0 it was amazing experience not a single issue with syncing to https://www.lexar.com/portfolio_page/hi ... s-i-cards/ and https://www.amazon.com/Lexar-Profession ... B088K39RBN Write speeds were around 60MB/s Direct to SDCard and around 25MB/s over Wi-Fi 802.11ac (450mbit connection). No duplicates playlist there at its place, clean folder structure, Sony native player registered all track and playlist (few tweaks needed, eg. relative path and playlists directly to music. But that is native player limitation Power player alongside MMA worked perfectly).
I'm not talking about MMA or Android. Let's not get sidetracked.

The Sony NW-A55 does nothing more than act as an SD card reader. MM simply copies files to the mounted filesystem. When are you guys going to fix this? A month ago, I gave you guys remote desktop access to my system, let you collect debug logs, gave you the MM database, etc.

I still have a paperweight.
Lowlander
Posts: 48371
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Sony NW-A55 not all songs appear on playlist

Post by Lowlander »

1) What do you have selected for sync? Is it parts of Collections or do AutoPlaylists you created?

2) What settings do you have set for Playlist sync in the Device Profile?

3) Do the Playlist files not get created on the card (check with File Explorer) or can the device not read the Playlist files on the card?

4) How exactly do you initiate sync?

Be as detailed as possible as sync is generally working.
Lowlander (MediaMonkey user since 2003)
CosmicKnowledge
Posts: 110
Joined: Sun Mar 15, 2020 11:24 am
Contact:

Re: From Bad to Worse

Post by CosmicKnowledge »

Lowlander wrote: Tue Oct 27, 2020 2:28 pm Provide more details on your exact setup or capture this in a debug log (step 4b) and attach it to a Support Ticket: https://www.mediamonkey.com/forum/viewt ... p?f=7&t=69.

Are you syncing directly to the SD card or the SD card in a device?
What happened with all the logs and database you guys got from me for the first issue? Is that problem fixed?
CosmicKnowledge
Posts: 110
Joined: Sun Mar 15, 2020 11:24 am
Contact:

Re: Sony NW-A55 not all songs appear on playlist

Post by CosmicKnowledge »

Lowlander wrote: Tue Oct 27, 2020 4:13 pm 1) What do you have selected for sync? Is it parts of Collections or do AutoPlaylists you created?
I don't know what you mean by parts of collections.... isn't any playlist or autoplaylist contained in a collection, even if it's just the default one? But I am syncing only autoplaylists.
Lowlander wrote: Tue Oct 27, 2020 4:13 pm 2) What settings do you have set for Playlist sync in the Device Profile?
I'm 1500 miles from home so I can't take screenshots right now but basically the same sync settings I had prior to the latest MM release. The prior settings worked. (although MM has an indexing problem that results in not all songs mentioned in the playlist being replicated to the device).
Lowlander wrote: Tue Oct 27, 2020 4:13 pm 3) Do the Playlist files not get created on the card (check with File Explorer) or can the device not read the Playlist files on the card?
Glad you asked because there's much misunderstanding.
a) If you browse the filesystem using any file explorer (e.g. explorer.exe, cmd.exe), you will find no M3U playlist text files anywhere on the SD card.

b) Since (a) is true, naturally the device will show no playlists.
Lowlander wrote: Tue Oct 27, 2020 4:13 pm 4) How exactly do you initiate sync?
I disabled/unchecked sync on initial connect. I press the sync button on the bottom right of the interface when the proper SD card is selected on the directory tree. The same way I've always done it.
Lowlander wrote: Tue Oct 27, 2020 4:13 pm Be as detailed as possible as sync is generally working.
It *was* (generally) working. It just didn't sync half the playlist contents.

This recent release definitely broke everything.
Post Reply