Page 27 of 52

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Tue Dec 23, 2008 11:45 am
by sonicendeavor
wolfzell wrote:
sonicendeavor wrote:The script died at between 400 and 500 records most times, although one time it died after 16 records, and one time I got over 600 records. There doesn't seem to be any rhyme or reason to it. A couple times when it died after 100 records or so, I reran the exact same selection of 500 records over again and it ran fine.
Yep. Although I love this script, I made the same observation. I am trying to avoid using it right now as with 20.000+ tracks it is a lot of work doing this in 50+ batches and still I will get the occasional fatal error. Good thing is that I never had any damages to the tags or the database with the errors. It is just time consuming to find the track where the script stopped working to start it over again from there...

Nevertheless: Thanks a lot to trixmoto for a great and very useful script. I am confident you will hunt down this bug sometime.

bye
Wolfgang
Fortunately the status bar towards the bottom of the screen tells you what record it was on when it died, and since the selection is highlighted, you can approximate where that last record is and do a shift-click and MM will tell you which record you're on in the selection.
I could be wrong, but I'm guessing this is not a problem with the script itself, but a problem with the MM scripting engine (if I have my terminology correct).

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Wed Dec 24, 2008 5:13 am
by Metacog
This question has probably already been answered in this thread, but I've been unable to find an answer.

When I "whitewash" my album art tags/links the album art still displays even after restarting media monkey and refreshing the entries. I can see that some of it has stopped displaying, but a majority of it remains. When I right click on the album, or have an album selected with the album art viewer, no artwork displays. So it seems that it is just residual. But why does the art still display and how do I get rid of it so I can be absolutely sure that the new art I add is what shows up when I view the album?

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Sat Mar 07, 2009 10:49 am
by sonofjon
Hi,

I've come across a problem with option 6: Remove artwork not matching size.

My artwork files are stored in the album folder and each track has link to the artwork files. When I run AAT to remove all artwork with size smaller than 100x100 (and having "Delete Image Files" checked) AAT deletes the album artwork jpg but only removes the link in the first track of the album, leaving empty links in the second to last tracks of the album. The expected behavior is of course that all links are removed.

Has anybody else come across this problem?

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Sat Mar 07, 2009 11:22 am
by nohitter151
sonofjon wrote:Hi,

I've come across a problem with option 6: Remove artwork not matching size.

My artwork files are stored in the album folder and each track has link to the artwork files. When I run AAT to remove all artwork with size smaller than 100x100 (and having "Delete Image Files" checked) AAT deletes the album artwork jpg but only removes the link in the first track of the album, leaving empty links in the second to last tracks of the album. The expected behavior is of course that all links are removed.

Has anybody else come across this problem?
Can't you just re-run AAT with remove invalid artwork setting?

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Sat Mar 07, 2009 1:56 pm
by sonofjon
Thanks for the tip. That did it!

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Mon Mar 09, 2009 4:33 pm
by trixmoto
The script should only need to remove the artwork from the first track because updating it should update all the tracks in the album. This assumes that you have that tickbox ticked on the properties screen though. I'm glad you've found another way to sort it anyway.

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Wed Mar 18, 2009 11:36 am
by HeistMonkey
Just installed the script and i'm getting the line 982 column 8 error when i select option "07. Remove artwork which is invalid" too. Any ideas on this? Edit- nevemind.

** EDIT ** Just a note, after removing some unused genres with another of Trixmotos great scripts and upgrading my db after installing the latest beta version, I have been able to run option 7 with much greater success. Thanks for an awesome script which has saved me hours of manually removing that unwanted default folder.jpg image from each mp3.

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Wed Mar 18, 2009 4:44 pm
by trixmoto
Thanks, I'm glad you've found my scripts useful. :)

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Tue Mar 24, 2009 11:27 pm
by DaveFrischknecht
Hello,

I tried to install the script using the ".exe" file you have available for download, but I see nothing on the Scripts sub-menu. I'm using MediaMonkey 3.0.7.1191. Any help would be appreciated.

Many thanks,

Dave

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Wed Mar 25, 2009 12:35 am
by DaveFrischknecht
I forgot to mention that I'm using Windows Vista.

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Wed Mar 25, 2009 1:50 am
by Bex
You should download the .mmip by clicking the MM3 monkey icon on trixmoto's site.

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Wed Mar 25, 2009 2:01 am
by DaveFrischknecht
I did that, too, but got an error message saying that there was a problem installing it.

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Wed Mar 25, 2009 2:07 am
by Bex
Avoid "Product installation error"
- Vista Users:
- - To be able to install scripts you must Run MM as an administrator.
- - It means that you must right click the MM icon and select "Run as administrator" even if you are logged in as an administrator.
- All Users:
- - Check in your task manager that you only have one instance of MediaMonkey.exe running.

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Wed Mar 25, 2009 8:47 am
by Sebastian78
If I go to a folder in the music three, select it and then start the script. I get an error message after 2-300 songs (of approx. 4000 songs). BUT if I select all these in the list of songs and do the same, I get no error message.

Edit: YES I DID! I got

"Error #-2147418113 -
File: "C:\Program Files\MediaMonkey 3\Scripts\AlbumArtTagger.vbs", Line: 982, Column: 8"

Re: Album Art Tagger 4.2 [MM2+3]

Posted: Wed Mar 25, 2009 12:09 pm
by trixmoto
Hmmm, well the script is obviously doing the same thing. I guess it must be something to do with the way that the tracks are read by MM. I'll contact the devs and see what they say.