sporadic MM client lockups when interacting with UPNP/DLNA

Get answers about how to share with different devices.

Moderator: Gurus

freedomfries323
Posts: 38
Joined: Thu Nov 12, 2015 5:24 pm
Contact:

sporadic MM client lockups when interacting with UPNP/DLNA

Post by freedomfries323 »

I have 2 PCs. Both run Windows 10, and both run the same version of MM (4.1.28.1905). One PC has my music library, and has the DLNA media server enabled and configured in Media Monkey. The other, is just a client. I'm having a lot of issues with the client side (or maybe it comes from the server?).

What tends to happen often is that, I'll see the server listed on my client MM under media servers. I can navigate to it, but I can't play the songs. I can see the playlists, and albums listed in the music folders. I can browse fine and queue up whatever I want into the playlist, but as soon as I hit play, media monkey hangs. The play button turns into a pause button, as if playing, but there's no playback. No progress bar. Hitting pause doesn't revive it. I can still browse the folder tree on the left, and queue to the playlist, but the play button is stuck, nothing plays. Like the server is not sending files to MM, or something.

Now if I were to manually browse through windows explorer and drag and drop the same music files directly into my client pc's playlist, (rather than find it under the media server in MM), I get them to play. I noticed if the file is an mp3, it will playback fine if I dragged it from an explorer window to queue it up, but it will give me a missing codec error if I try to play it from the playlist on the DLNA media server.

What's even stranger is that I don't experience this issue when I use my Onkyo receiver to browse the DLNA server. It seems much more reliable in getting things to play than the MM client. Any ideas?

This is sporadic. I just wish it worked reliably instead of having to waste time troubleshooting it on the regular, not knowing how to fix this.
Lowlander
Posts: 47964
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: sporadic MM client lockups when interacting with UPNP/DLNA

Post by Lowlander »

Capture this in a debug log (step 4b) at the client side and attach the log to a Support Ticket: https://www.mediamonkey.com/forum/viewt ... ?f=20&t=69
Lowlander (MediaMonkey user since 2003)
freedomfries323
Posts: 38
Joined: Thu Nov 12, 2015 5:24 pm
Contact:

Re: sporadic MM client lockups when interacting with UPNP/DLNA

Post by freedomfries323 »

Thanks Lowlander.

I just spent the time to capture a debug log. Not sure if there are clues in there. It's too nebulous for me.
My trouble ticket ref: #EZA-930-61706
Post Reply