Syncing Copies All Tracks Again

Report bugs & feature requests for MediaMonkey for Android and learn about the newest beta build.

Moderator: Gurus

captainmcl
Posts: 48
Joined: Sat Jun 18, 2011 9:55 pm
Location: Frisco, TX, USA
Contact:

Re: Syncing Copies All Tracks Again

Post by captainmcl »

This is the same problem I was having, but I am not any more. Of course it's always hard to say why something changes, but I think that part of my problem was the introduction of WiFi synching. It appears (and someone with more behind-the-scenes knowledge can correct me here) that MMW creates a new profile for the WiFi connection, separate from the USB sync profile. It may also have created a separate one for MMA via USB since I already had a non-MMA USB profile for my device. This would make sense because (it would seem) that synching to its own db on the device would be a different protocol than synching to an Android device for use with a non-MM player.

Anyway, I went through my device profiles and cleaned out a bunch of extras. Once the WiFi sync profile is created, it appears that MMW uses that every time going forward. I think that solved at least a portion of my struggles.
CaptainMCL
Frisco, TX, USA

My environment:
Win8, always latest version/build (or beta version) of MMW
LG V20, Android 8.0, all music/podcasts/audiobooks on 64GB external SD card (which may be the source of half of my problems...), always the latest build of MMA
MarkODD
Posts: 45
Joined: Mon Jan 23, 2012 4:09 pm
Location: Australia
Contact:

Re: Syncing Copies All Tracks Again

Post by MarkODD »

Synced 2 albums to Samsung Galaxy SII 16GB external SD card over MTP. The existing ratings from MMW were not exported to MMA. Played 1 song with a play count of 0 in MMW on the phone and rated it. Reconnected over MTP and auto synced. The play count in MMW was not increased, the rating was not updated in MMW.

At least all the tracks were not copied over again.
MarkODD
Posts: 45
Joined: Mon Jan 23, 2012 4:09 pm
Location: Australia
Contact:

Re: Syncing Copies All Tracks Again

Post by MarkODD »

Well after a week of frustration of trying to get sync working over MTP with my Samsung SII I have given up. In the end it would not even copy over any new tracks that I placed in the sync list, even after I took the SD Card out of the phone and synced to the internal storage.

I have gone back to connecting in USB mode. It still copies all tracks again every sync but at least it does copy what is in the list. Also after I followed captainmcl's advise and cleaned up my device profiles two way syncing seems to be working again. That is plays and rating changes on the phone are being synced back to MMW. Yay!

MMW1627, MMA 106, Windows 7
BigInJapan
Posts: 192
Joined: Mon Jan 02, 2012 10:42 pm
Contact:

Re: Syncing Copies All Tracks Again

Post by BigInJapan »

If you start from a clean state and only ever use Wifi sync, do you still see this issue?

My experience so far has been that if I stick to Wifi 100% of the time, syncing works fine. When I start trying to switch between Wifi and USB, things get screwy. I'm also finding that Wifi sync copies tracks about as fast as USB, so I'm not finding a need to go back to USB once I have Wifi working.

I'm still tinkering, so I'm curious if others are having similar experiences with this.
Remember when Last.fm had those cool imagegen charts for use in signatures?
daodb
Posts: 13
Joined: Sun Jan 05, 2014 11:48 pm
Contact:

Re: Syncing Copies All Tracks Again

Post by daodb »

BigInJapan wrote:If you start from a clean state and only ever use Wifi sync, do you still see this issue?

My experience so far has been that if I stick to Wifi 100% of the time, syncing works fine. When I start trying to switch between Wifi and USB, things get screwy. I'm also finding that Wifi sync copies tracks about as fast as USB, so I'm not finding a need to go back to USB once I have Wifi working.

I'm still tinkering, so I'm curious if others are having similar experiences with this.
I was having this problem using only USB. Then, I deleted all of my music (4100 files), and went strictly to WiFi. The nightmare has continued, as it is doing the same... saying it's recopying the whole library.

Please tell me you all found a fix!
Lowlander
Posts: 48134
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Syncing Copies All Tracks Again

Post by Lowlander »

Which version of MMA and MMW are you using?
Lowlander (MediaMonkey user since 2003)
daodb
Posts: 13
Joined: Sun Jan 05, 2014 11:48 pm
Contact:

Re: Syncing Copies All Tracks Again

Post by daodb »

Lowlander wrote:Which version of MMA and MMW are you using?
I got it to work by going into my media servers, selecting the media monkey server, going to playlists, newly added, and selecting the 6 songs I wanted to add.

The MMA is the "Build 222", just updated yesterday.
The MMW is 4.1.0.1685
Lowlander
Posts: 48134
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Syncing Copies All Tracks Again

Post by Lowlander »

Your MMW is outdated as the latest release is 1690.
Lowlander (MediaMonkey user since 2003)
meljmartin
Posts: 36
Joined: Fri Jun 07, 2013 6:45 pm
Location: Montreal, Quebec
Contact:

Re: Syncing Copies All Tracks Again

Post by meljmartin »

I figured out what happened. Problem was on server side. Thanks anyway. GL.
daodb
Posts: 13
Joined: Sun Jan 05, 2014 11:48 pm
Contact:

Re: Syncing Copies All Tracks Again

Post by daodb »

Lowlander wrote:Your MMW is outdated as the latest release is 1690.
I just updated. Haven't tried to use the sync button yet and just did the manual sync that I described, then remember I had a forum post. Do you know why my Mediamonkey did not detect I was out of date, and had to manually re-download the new version?

Thanks
Lowlander
Posts: 48134
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Syncing Copies All Tracks Again

Post by Lowlander »

The update checked doesn't check for beta releases.
Lowlander (MediaMonkey user since 2003)
Post Reply