Page 1 of 1

[BUG] Wifi sync failure

Posted: Tue Jun 25, 2013 9:41 am
by bkenobi69
MMW 1644
MMA 145

In last MMA, sync worked fine for the most part (aside from one bug with a hidden confirmation dialog). I updated yesterday and wifi sync'ed. The process looked like it was working, so I let the phone sit while it did its thing. I checked back 15 minutes later and there was no sync status, it was just sitting on the main display of MMA. I figured it was a problem with low battery and/or the screen turning off, so I plugged the phone in and disabled display sleep. When I tried again, I found that the sync went through the "checking sync list" a couple times but eventually failed somehow. A debug log was automatically uploaded. I tried syncing 2-3 times, so there are probably that many debug logs available.

Details of the sync:
no new songs to download
no new playlists to download
only needed to perform sync back of play count and ratings

Re: [BUG] Wifi sync failure

Posted: Wed Jun 26, 2013 9:42 am
by bkenobi69
I rebooted my PC, rebooted my phone, and yet I still cannot get wifi sync to work. I have not tried USB yet, but that has never been a problem for me. When I try to sync, I am seeing the sync start and the analysis progress bars move, but at some point (after the screen turns off 30 seconds of inactivity later) the sync fails. When I next check, the phone is sitting on the first MMA screen.

As I mentioned before, I did catch it crash once. In that instance, a debug log was sent and it appeared that the OS reported that MMA crashed. I still do not have a specific log file to reference but I tried syncing last night around 6-7pm PDT.

Re: [BUG] Wifi sync failure

Posted: Wed Jun 26, 2013 8:53 pm
by BigInJapan
Failing here too. It gets to the end of the Analyzing bar. Then a debug log notification pops up. Then a force close.

Re: [BUG] Wifi sync failure

Posted: Wed Jun 26, 2013 10:31 pm
by bkenobi69
Ok, good. I'm glad I'm not the only one. With multiple logs hopefully this will be resolved shortly. I think I'll go ahead and submit a help desk ticket.

EDIT: submitted here
http://www.mediamonkey.com/support/inde ... etid=21573

Re: [BUG] Wifi sync failure

Posted: Thu Jun 27, 2013 11:26 pm
by bkenobi69
If I disable confirm delete, I don't get a force close.

Re: [BUG] Wifi sync failure

Posted: Fri Jun 28, 2013 2:44 am
by bhiefer
Hi, there was a compatibility issue. It will be fixed in next build. Thanks

Re: [BUG] Wifi sync failure

Posted: Fri Jun 28, 2013 10:22 am
by BigInJapan
bkenobi69 wrote:If I disable confirm delete, I don't get a force close.
Thanks for the tip. That got me pointed in the right direction, but I found I had to disable the "Delete Unselected Content" option entirely. Just disabling the confirmation still led to FC for me.

I've got a sync running now. It's bringing about 2900 tracks over, so it will be a while before I know if it completes correctly.

I'm not sure if this matters, but I had wiped everything before trying to sync with 145. In other words, I had uninstalled the previous version, deleted the MM folders, and deleted all content from the external card that I sync to. Then I installed 145, recreated the profile in MMW, and then tried to sync. I'm curious if the lack of any existing content is related to the "Delete Unselected Content" option causing the force close.

Re: [BUG] Wifi sync failure

Posted: Fri Jun 28, 2013 12:38 pm
by bkenobi69
Probably not. In my case, I deleted several tracks to test another issue. When I tried to bring those deleted tracks back I started getting these errors.