Horrible performance under Oreo [#14845]

Report bugs & feature requests for MediaMonkey for Android and learn about the newest beta build.

Moderator: Gurus

martin.bohac
Posts: 157
Joined: Thu Nov 14, 2013 5:23 pm

Re: Horrible performance under Oreo [#14845]

Post by martin.bohac » Tue Jul 31, 2018 7:03 pm

I have added a new option (in build 823) to Developer options. You will get there via Options\About MediaMonkey\tap to MediaMonkey icon and disable the option "Allow Background process service". Then play some music and let me know whether it helped.

MaximusPrime
Posts: 403
Joined: Tue Aug 14, 2012 1:31 am

Re: Horrible performance under Oreo [#14845]

Post by MaximusPrime » Sat Aug 04, 2018 8:39 am

Hi. Tested it with disabled background process service but still crashes. thanks for your effort

martin.bohac
Posts: 157
Joined: Thu Nov 14, 2013 5:23 pm

Re: Horrible performance under Oreo [#14845]

Post by martin.bohac » Tue Sep 04, 2018 12:12 pm

Don't you have some battery saver installed or don't you have enabled some battery optimization in a system setting?
Similar issues also occurred on Huawei phones. The system update helped or change a setting (described below) helped too.
I am afraid that this issue is not fixable on MMA side.
RBS wrote:
Tue Sep 04, 2018 5:35 am
SOLUTION regarding Huawei Mate 9 Pro (and maybe others)
I have been in contact with Huawei Consumer support here in DK, and their solution i powersaving related

Anyway here's the solution that made it work for me:

Go to your phones 'settings' > 'battery' > 'settings' (upper right corner) > disable 'power-intensive prompt' > > go back to the prior page, and select 'launch' > 'disable 'manage all automatically' - now it works, and my MediaMonkey has now played flawless for more than an hour, and suddenly I became glad for my phone again ;-)

Post Reply