Playback continues muted on Android

Get answers about the current release of MediaMonkey for Android

Moderator: Gurus

Patrickt333
Posts: 12
Joined: Fri Apr 15, 2016 6:37 am

Playback continues muted on Android

Post by Patrickt333 »

Pixel 3, Android version 10, Media Monkey Pro version 1.4.0.0934. This version number comes from the app help. But if I go to the playstore and pull up the app to check for updates, it says version 1.3.0017 under app info. So, that's another mystery.

I thought this was related to Bluetooth, but during testing when my phone was not connected to BT, just playing standalone, the music audio is muted. It continues to play (i.e., the time counter continues) but no sound comes out. If I forward to the next song, I might get sound, but sometimes I need to go 4 or 5 songs, then if I go back to the original song, it plays, so it's not a file format problem. This problem happens 2 different cars bluetooth and now just standalone phone speakers. It feels like this has persisted over a few Android updates and it's highly frustrating, looking down at a song you want to hear, that's playing (not paused) and no sound comes out.

I've seen other issues with Huawei phones kill BG processes, but this is clearly not the case here. What can I do? Is this a known problem that my searching didn't turn up?
Lowlander
Posts: 51949
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Playback continues muted on Android

Post by Lowlander »

Have you tried a device restart and do other Apps have no problem producing sound when MMA can't?

Is the problem with both BT and internal speakers, or with internal speakers after disconnecting from a BT device?
Patrickt333
Posts: 12
Joined: Fri Apr 15, 2016 6:37 am

Re: Playback continues muted on Android

Post by Patrickt333 »

I have done multiple restarts, issue has been around for what feels like a few months now. I also use Plex occassionally, but I will try that as well. Today, I just decided to try it with internal speakers, haven't been on Bluetooth since yesterday. But I can also restart, try it with no prior BT connections and see what happens.
Patrickt333
Posts: 12
Joined: Fri Apr 15, 2016 6:37 am

Re: Playback continues muted on Android

Post by Patrickt333 »

I just listened to Plex for nearly an hour with zero issues. Very first song on Media Monkey exhibited the described symptons. Visually looks like it's playing, no sound coming out of the internal speakers.
Peke
Posts: 15011
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Playback continues muted on Android

Post by Peke »

Hi,
Can you make sure that EQ is disabled and that MMA do not cast to any other device (Icon in top right would show)?
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum
Patrickt333
Posts: 12
Joined: Fri Apr 15, 2016 6:37 am

Re: Playback continues muted on Android

Post by Patrickt333 »

I finally got the opportunity to test this. EQ is off. When the issue happens, I click on the top right corner and click cast. It says wifi not connected, and I click ignore and it says no cast device. This happened many, many times on a 2 hour drive and I was in the middle of nowhere, so I can't imagine what could be interfering. Bluetooth remained connected to my vehicle throughout.
Patrickt333
Posts: 12
Joined: Fri Apr 15, 2016 6:37 am

Re: Playback continues muted on Android

Post by Patrickt333 »

I did a full uninstall/reinstall of MMA and MMA Pro. Got excited after 5 continous songs, but then the problem reappeared. Before posting this, I listened to Pandora and Plex for about 45 minutes each with no issues.
Patrickt333
Posts: 12
Joined: Fri Apr 15, 2016 6:37 am

Re: Playback continues muted on Android

Post by Patrickt333 »

Any further feedback? Honestly, I just subscribed to gold a few months ago, but this issue is already making me look at other media managers.
Patrickt333
Posts: 12
Joined: Fri Apr 15, 2016 6:37 am

Re: Playback continues muted on Android

Post by Patrickt333 »

It's possible I've resolved this by doing a factory reset on my phone. I will repost if I can reproduce over the next few days. Odd that it would have only impacted this one app but I've seen stranger things.
Patrickt333
Posts: 12
Joined: Fri Apr 15, 2016 6:37 am

Re: Playback continues muted on Android

Post by Patrickt333 »

Well, it was a nice try. The issue is still happening. It does not happen when I use Google Play Music reading the same library files.
GBoydSmith
Posts: 2
Joined: Wed Dec 08, 2021 10:38 am

Re: Playback continues muted on Android

Post by GBoydSmith »

It doesn't look like an answer was ever discovered for this but it has been happening to me for a while too. I also had a Pixel 3 and was running MM Pro and experienced the same issue occasionally, I recently upgraded to a Pixel 6 and now it seems to happen a lot more. Like the above poster, I validated that EQ was off and that I was not casting to any other devices.
One additional quirk of this, when it does go to a new song that doesn't play if I hit the skip back button (to restart the song) it always starts playing immediately.
ScottyPottie

Re: Playback continues muted on Android

Post by ScottyPottie »

Same issue here. Pixel 6. Back button starts sound up again.
dpmanthei
Posts: 1
Joined: Tue Oct 13, 2015 11:46 am

Re: Playback continues muted on Android

Post by dpmanthei »

Exact same here. Was happening on Pixel 3, upgraded to Pixel 6 Pro, same or worse than before. Nearly every automatic song advance plays muted, but skip or back will always play a song with audio. Happens just as much with internal speaker as it does over Bluetooth.

I suspect a permissions bug. When we press buttons that's the user initiating playback. When the song advances on its own that's the player...maybe crossfade plays a role too?

Edit: I might have actually got somewhere. I turned off audio transitions entirely and changed the playback notifications to "System". It was failing me nearly 100% of the time but now it has worked a couple times. We'll see.
GBoydSmith
Posts: 2
Joined: Wed Dec 08, 2021 10:38 am

Re: Playback continues muted on Android

Post by GBoydSmith »

@dpmanthei I think you are correct, I just turned off audio transitions and I am not five songs in with out a single issue with the audio playback failing...fingers crossed that it keeps up. Thank you so much for posting your solution.

Edit: I am now 20 songs in with out a single skip.
CaptSteel

Re: Playback continues muted on Android

Post by CaptSteel »

Turning off transitions seems to have worked for me. I recently upgraded from a Pixel 2 to 6 pro and had transitions set to "gapless". The sound seems to fade in a bit at the start of tracks, which I would prefer it didn't (why I was trying gapless), but I'll definitely take *some* audio over none! I was having to skip back to the start after practically every new track started to get audio output.
Post Reply