Devtools gone

To discuss development of addons / skins / customization of MediaMonkey.

Moderators: jiri, drakinite, Addon Administrators

TIV73
Posts: 126
Joined: Sat Nov 12, 2011 1:31 pm

Devtools gone

Post by TIV73 »

Hey there,
I just installed rev2268 and noticed that I can't open the devtools anymore. Ctrl+Alt+Shift does nothing, and the 'Open DevTools in Chrome' just opens a regular instance of chrome, without any context to mediamonkey.

I found a 'Developer Mode' flag in the About dialog window, but it's not sticky. If I enable it, close the window and re-open it, the option is deactivated again.

Is there a trick or method to re-enable the dev console?
Ludek
Posts: 3947
Joined: Fri Mar 09, 2007 9:00 am

Re: Devtools gone

Post by Ludek »

For me opening DevTools works in 2268 (both Ctrl+Alt+Shift) and 'Open DevTools in Chrome' works fine.

Is this still occuring? Probably just a temporary glitch?
TIV73
Posts: 126
Joined: Sat Nov 12, 2011 1:31 pm

Re: Devtools gone

Post by TIV73 »

I'm afraid it's still an issue. To verify this, I spun up a Windows 10 VM (version 2004, last updated about two weeks ago, no modifications done whatsoever after windows was installed) and tried it there:
https://streamable.com/fi3kcy

I also tried installing in portable mode, running mediamonkey as administrator, and restarting the application and windows. The result remained the same, unfortunately.

Is the flag adding settings in the persistent.json (or any other config file) that I can just set manually?
TIV73
Posts: 126
Joined: Sat Nov 12, 2011 1:31 pm

Re: Devtools gone

Post by TIV73 »

I just installed 2269 and, while the developer-mode flag is still not sticky, opening the devtools works again! Thanks a lot for the help!
Post Reply