Page 1 of 1

At launch, access too fast crashes

Posted: Sat Jan 19, 2019 4:26 am
by teodore
When the program v. 2148 is launched, immediate access to the folder explorer or collections results in the freezing of MM5.

By observation on Windows 10 with 8GB Ram, before selecting freely and promptly, it is necessary to leave the update, the refreshing of folders, the scanning operations of the different disks.

Otherwise it's definitely the crash.

In this case mm5 works among about twenty collections and nodes, three hard disks, a USB key, several partitions.

Re: At launch, access too fast crashes

Posted: Mon Jan 21, 2019 6:05 am
by Ludek
I cannot replicate, but most probably it is related to http://www.mediamonkey.com/forum/viewto ... 70#p455023
Where listing your external HDDs as MTP/WMDM devices takes a long time that resulted in https://www.ventismedia.com/mantis/view.php?id=15332 with pre 2149 builds

Are your HDDs external (usb connected) ? If yes, could you try to temporarily disconnect them to see whether it fixes the temporal Windows explorer freeze?
Also, when they are connected, could you generate debug log for me (item 4b here: http://www.mediamonkey.com/forum/viewto ... 30&t=86643 ) this way:
1) start DbgView
2) start MM5 (build 2149!) and verify that Windows Explorer is frozen after the start
3) wait 2 minutes (or until the Windows Explorer is responsible again)
4) save the log from DBGView and attach

Thanks!

Re: At launch, access too fast crashes

Posted: Mon Jan 21, 2019 3:01 pm
by teodore
With 2049 i can reproduce the freeze, but if i close quickly, so crash : id 370EF60F (i'm not sure it could be send)
But i'm waiting to have more informations about mpeg repeat scans.

Re: At launch, access too fast crashes

Posted: Tue Jan 22, 2019 3:18 pm
by Ludek
Thx, 370EF60F just confirms the freeze.

Could you please answer my questions above?

Are your HDDs external (usb connected) ? If yes, could you try to temporarily disconnect them to see whether it fixes the temporal Windows explorer freeze?
Also, could you please generate the debug log and attach a link to it (or PM me the link)?

Re: At launch, access too fast crashes

Posted: Fri Jan 25, 2019 4:22 am
by teodore
Yes MM5 and the data is installed in an external 4TB hard disk on a salcam dock.
In addition I cleaned my files (see other posts) which relieves MM5 at startup.
So I don't seem to have this problem anymore, even if I'm trying to reach about ten nodes in a few seconds.