Album Art Lost With Move

Get answers about the current version of MediaMonkey 5

Moderator: Gurus

wallyp
Posts: 16
Joined: Wed Oct 14, 2020 3:33 pm

Album Art Lost With Move

Post by wallyp »

I have MM5 Gold working on both a desktop (Win7) and a laptop (Win10). Virtually all ripping, organization, etc. are done on the desktop, while the laptop lives in the shop building as a player. I recently collected about thirty thrift-shop CDs on a trip, and ripped them on the desktop.
I have spent quite a bit of time in the past getting the album art correct on the desktop, and it seems to be okay, including the new stuff.
I decided to update the laptop player by copying the music files from the desktop to the laptop. After that was finished, I deleted the laptop database, and restarted MM5. After the database was rebuilt, I discovered that many albums now have incorrect artwork, and many of those with the correct artwork now have the "best guess" icon in the upper left corner.
Obviously, I don't understand how the tagging works - I thought that having the artwork correct in the desktop files would result in having the artwork correct in the copied files on the laptop.
What am I missing?
Wally
Lowlander
Posts: 50846
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Album Art Lost With Move

Post by Lowlander »

How was the Artwork saved?

If you embed, this shouldn't be an issue as the Artwork is always in the media files themselves. If you use external Artwork you need a really good organization of files as you each time rely on that for Artwork to be found when any software scans the files. This media files in an Album/Series folder with their appropriate Artwork is recommended.

Also did you have Scan file directories for Artwork enabled under Tools > Options > Library? This option is used to find the external Artwork: https://www.mediamonkey.com/wiki/WebHel ... cans_Files
wallyp
Posts: 16
Joined: Wed Oct 14, 2020 3:33 pm

Re: Album Art Lost With Move

Post by wallyp »

All artwork is (or at least I think should be?) embedded - I used the "properties" to install the artwork, always associating it with every file in the album, also clicking in the "replace existing artwork", even if I was just approving the "best guess". I have never used external artwork.

Since I don't use external artwork, I did not have the "Scan File Directories for Artwork" enabled.

I also forgot to mention, I am on 5.0.1.2431 (latest version as of yesterday).
Wally
Lowlander
Posts: 50846
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Album Art Lost With Move

Post by Lowlander »

When adding Artwork through Properties MediaMonkey can either embed or save the Artwork as external files: https://www.mediamonkey.com/wiki/WebHel ... k_Settings So that doesn't help to understand if the Artwork was embedded or not.

With embedded Artwork there really shouldn't be a problem, it's external Artwork that can cause issues when scanning files in.

You may want to check if there Artwork files in the folders you store your media files. This may be the case in which case the option to "Scan File Directories for Artwork" needs to be enabled to associate them with your media files on scanning.

Note that not all File Types (like WAV) support embedded Artwork: https://www.mediamonkey.com/wiki/WebHel ... erties/5.0
wallyp
Posts: 16
Joined: Wed Oct 14, 2020 3:33 pm

Re: Album Art Lost With Move

Post by wallyp »

Options include:
update tags when editing properties
save images to tags (if possible) otherwise save to file folders
first image album/series: folder.jpg
Wally
wallyp
Posts: 16
Joined: Wed Oct 14, 2020 3:33 pm

Re: Album Art Lost With Move

Post by wallyp »

I have never seen an image file in any of my music folders - only jpg or wma files.
I am not aware of having any wave files, although with 187 GB of music, it's possible I have a few, but none of the folder that I have checked thus far with the problem are wave files.
Wally
Lowlander
Posts: 50846
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Album Art Lost With Move

Post by Lowlander »

wallyp wrote: Mon Aug 02, 2021 6:50 pmI have never seen an image file in any of my music folders - only jpg or wma files.
jpg are image files and could be the Artwork files you're missing.
wallyp
Posts: 16
Joined: Wed Oct 14, 2020 3:33 pm

Re: Album Art Lost With Move

Post by wallyp »

Brain fart - make that mp3, not jpg. No jpg files...
Wally
Lowlander
Posts: 50846
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Album Art Lost With Move

Post by Lowlander »

Can you upload some sample files you believe have embedded Artwork, but don't show it in MediMonkey, to a fileshare like Dropbox/OneDrive and then add the link to the fileshare in a Support Ticket: https://www.mediamonkey.com/support That will allow us to analyze the files themselves.
Post Reply