No music [#18619]

Get answers about the current version of MediaMonkey 5

Moderator: Gurus

kevinp
Posts: 8
Joined: Fri Sep 06, 2019 6:10 am

No music [#18619]

Post by kevinp »

I've been searching the forums about the last four hours and haven't found an answer. I've seen it's been asked many times, but....

I've had my iPod Nano 6th gen for about 10 years (can't remember when they came out) and have been syncing it with MM since then. I still use my Nano everyday and decided to get another one just for use in my car (2013 Chevy - the radio supports iPod). So, I bought one off ebay. It was formatted for a Mac, so I downloaded iTunes (the desktop version) and reset the iPod. I closed iTunes and opened up MM, synced all the playlists and podcasts that I listen to on my original iPod, but when I disconnected, all I see is "No Music" under the playlist and music icons and "No Podcasts" under the podcast icon. I can expand my iPod in MM and see all the music that is on it and click on any of the songs and they will play, so I know it's syncing.

I have MM 4.1.31.1919 and 5.0.1.2433 installed on my Windows 11 computer and I've tried syncing with both with the same results. I connected it back to iTunes and got the message "iTunes can't read the device...". So, I formatted it again and tried syncing a playlist in iTunes. When I disconnected my iPod, the playlist showed up and the music played fine.

I can't remember why anymore, but I formatted my original iPod in iTunes and copied that playlist to it. I then connected it to my car and my car couldn't see the playlist or any of the songs. So, I thought maybe I just need an older version of iTunes, so I installed v12.5.5.5. The problem is, it still downloads the latest iPod software when it formats it.

I'm on a new computer I just bought a couple months ago. I installed MM, but never iTunes (until today) and have been syncing my old iPod just fine up until today.
Barry4679
Posts: 1875
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: No music

Post by Barry4679 »

kevinp wrote: Sat Nov 27, 2021 10:48 pmI closed iTunes and opened up MM, synced all the playlists and podcasts that I listen to on my original iPod, but when I disconnected, all I see is "No Music" under the playlist and music icons and "No Podcasts" under the podcast icon. I can expand my iPod in MM and see all the music that is on it and click on any of the songs and they will play, so I know it's syncing.
I presume that this an Apple specific issue. I have no Apple devices, nor sw, so don't pay too much attention to this post. :)

It is nor real clear (to me) what you are doing.
You are trying to sync music to the new iPod. Right?
And when you say
all I see is "No Music" under the playlist and music icons and "No Podcasts" under the podcast icon
You mean on the iPod. Right?

Are you sure that you are syncing the media to the iPod folder which is being monitored by the iPod's Media Server?
ie. Check the File Locations tab in MM5's Devices&Services><your phone> in the Sync Profile panel. Make sure it is exporting to wherever the IPod Media Server is looking.
Want a dark skin for MM5? This is the one that works best for me .. elegant, compact & clear.
kevinp
Posts: 8
Joined: Fri Sep 06, 2019 6:10 am

Re: No music

Post by kevinp »

Yes, I mean "No Music" on the iPod. In Windows Explorer I can see all the files in E:\iPod_Control\Music\F00, F01, F02, etc. How do I know where the "iPod Media Server" is looking?

"File Locations" doesn't show up in the Sync Profile tab for iPods.

E:\iPod_Control\iTunes\iTunesDB is 0kb on my "old" Nano. My "new" Nano that I've only synced to iTunes doesn't even have that file.
Last edited by kevinp on Sun Nov 28, 2021 9:45 am, edited 1 time in total.
Barry4679
Posts: 1875
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: No music

Post by Barry4679 »

kevinp wrote: Sun Nov 28, 2021 8:16 am How do I know where the "iPod Media Server" is looking?
"File Locations" doesn't show up in the Sync Profile tab for iPods.
Out of my depth, sorry.
Things are under user control in Android world.

If locations are fixed in Apple, presumably MM5 has automatically put the files where they are expected to be, and that will be why there is no File Locations tab.

Hopefully someone with Apple experience will help you after the weekend.

Update. One other thought. What file format are you exporting to the iPod. The Ipod supports that format?
Want a dark skin for MM5? This is the one that works best for me .. elegant, compact & clear.
kevinp
Posts: 8
Joined: Fri Sep 06, 2019 6:10 am

Re: No music

Post by kevinp »

These are all songs that have been on my "old" Nano, so I don't think it has anything to do with the format. But, just for giggles, I had it convert everything to M4A. Still nothing shows up.

See my edit in my post above - my iTunesDB file is empty. Could this be the problem?
Lowlander
Posts: 52039
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: No music

Post by Lowlander »

Please reset the device in iTunes and try with the latest Build of MediaMonkey 5.0.2: viewtopic.php?f=30&t=86639
kevinp
Posts: 8
Joined: Fri Sep 06, 2019 6:10 am

Re: No music

Post by kevinp »

I've installed version 5.0.2.2523. I get the same thing. After "restoring" in iTunes, there is no iTunesDB file. After syncing with MM, I show an empty iTunesDB file and the music doesn't show on the iPod.
Image
Lowlander
Posts: 52039
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: No music

Post by Lowlander »

Please capture the Sync in a debug log (step 4b) and attach the log to a Support Ticket: viewtopic.php?f=30&t=86643

This will help a developer analyze why this happens in your setup.
dhanigan
Posts: 2
Joined: Sat Feb 15, 2020 12:00 pm

Re: No music

Post by dhanigan »

Same issue here on MM 5.0.1.2433. Windows machine. This is very new and doesn't seem to be related to the MM update. I recently went from v4 to 5 but things were working fine until sometime in the last 2 weeks. MM shows synced but the ipod screen shows no song or podcasts. itunes no longer recognizes it as soon as I do anything inside MM with the ipod. Itunes will still sync things to it just fine.

Did we get a ticket opened? I don't want to duplicate.

Edit: should have added this is an iPod Nano 4. I see a ticket that is related to the newest version of Itunes (issue 0018619) but want to note that I have not update itunes in years.
kevinp
Posts: 8
Joined: Fri Sep 06, 2019 6:10 am

Re: No music

Post by kevinp »

I opened a ticket and went back and forth with Ludek. He determined that the latest version of iTunes has broken the compatibility between the iTunes files on my iPod and MM. He is working on a fix, but I haven't heard anything in the past few days.

From Ludek:
the issue will be fixed in the next build 5.0.2.2525
Ludek
Posts: 4491
Joined: Fri Mar 09, 2007 9:00 am

Re: No music

Post by Ludek »

Yes, this has been fixed as https://www.ventismedia.com/mantis/view.php?id=18619 for the next build 5.0.2.2525
tokyohammage
Posts: 5
Joined: Mon Dec 06, 2021 8:25 pm

Re: No music [#18619]

Post by tokyohammage »

I am having the same problem.

Ipod classic, Windows 10, newest Mediamonkey version (1.2433) , and the newest Itunes version is on the pod.

Today all of a sudden, after my sync ended, I eject the pod and then look down - "no music."

I've been restarting the computer and trying it again and again, but no luck.

Like an idiot, I then plugged in my OTHER ipod classic, and now IT doesn't work either.
And yes, I can put music from Itunes onto the pods, no problem.

I was reading on this thread, that the issue had been fixed, but we have to wait until the next update for the fix to become available? Is that right, or did I miss something? And when do you think the next update will be?

Thanks
tokyohammage
Posts: 5
Joined: Mon Dec 06, 2021 8:25 pm

Re: No music [#18619]

Post by tokyohammage »

Hello again, I did find the links to the unreleased Mediamonkey 5.0.2.2524 AND the debug.exe file.
I've installed both, and neither one helps. I don't know what else to do. . .
Lowlander
Posts: 52039
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: No music [#18619]

Post by Lowlander »

This is set to be fixed in Build 2525, the latest available is currently 2524. Build 2525 still needs to be released.
Ludek
Posts: 4491
Joined: Fri Mar 09, 2007 9:00 am

Re: No music [#18619]

Post by Ludek »

Until 2525 is available you can just replace your current d_iPod.dll from 2524 by this one:
https://www.dropbox.com/s/j6eohfyfxgndh ... d.dll?dl=0
and it will does the trick.
Post Reply