long time Loading data after update 4.1.30

Beta Testing for Windows Products and plugins

Moderator: Gurus

Mike98
Posts: 1
Joined: Sun Dec 20, 2020 9:15 am

long time Loading data after update 4.1.30

Post by Mike98 »

I installed the latest Update und it takes a horribly long time to load now. The software is always reading files und it takes a long time until my disk with the music is shown. the file monitoring is switched off. I deinstalled it and installed my older version. The problem still remains. I have Windows 10 und the Media monkey Gold version. It would be nice if somebody could helb me.
Lowlander
Posts: 49812
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: long time Loading data after update 4.1.30

Post by Lowlander »

Reading depends on what you're loading in the Filelisting and into the Now Playing.

If the Now Playing is large reading will take a while as the Now Playing reads the files themselves and the MediaMonkey Library.

If the Filelisting loads a node from the My Computer node it will read from disc which depending on the amount of files can take long.

MediaMonkey itself can sometimes be sped up by running File > Maintain Library with complete optimization checked.
Lowlander (MediaMonkey user since 2003)
Gingeh1
Posts: 7
Joined: Mon Jun 27, 2005 11:14 am

Re: long time Loading data after update 4.1.30

Post by Gingeh1 »

I too have this problem, and I already have the File>Maintain Library setting already on, I have my files sat on an SSD, and although I do have a lot of music stored - I still think this is an exceptionally long time to have to read the files each time, my system is still reading after 20 minutes - cancel that, it's finished - but 20 minutes to update each time I start the program, something has changed, in my opinion not for the better! "Now playing" was somewhat faster than the "File Listing", this is tantamount to a big bug!
Lowlander
Posts: 49812
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: long time Loading data after update 4.1.30

Post by Lowlander »

It depends on what you're loading and how many files.
Lowlander (MediaMonkey user since 2003)
Gingeh1
Posts: 7
Joined: Mon Jun 27, 2005 11:14 am

Re: long time Loading data after update 4.1.30

Post by Gingeh1 »

Why isn't it held in a cache and then updated in the background, 20 minutes in my case just to see my music is a joke in my opinion!
Lowlander
Posts: 49812
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: long time Loading data after update 4.1.30

Post by Lowlander »

We don't know what you're loading, so it's hard to make any statement about this.

Avoid the My Computer node and a large Now Playing on startup.
Lowlander (MediaMonkey user since 2003)
dtsig
Posts: 3399
Joined: Mon Jan 24, 2011 6:34 pm

Re: long time Loading data after update 4.1.30

Post by dtsig »

Gingeh1 wrote: Thu Feb 11, 2021 4:49 am Why isn't it held in a cache and then updated in the background, 20 minutes in my case just to see my music is a joke in my opinion!
Have you tried File-Maintain Library?
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig
Ludek
Posts: 4020
Joined: Fri Mar 09, 2007 9:00 am

Re: long time Loading data after update 4.1.30

Post by Ludek »

Could you please install latest MM4 build: 4.1.31.1919 RC-2 from here: viewtopic.php?p=478258#p478258
and generate debug log (item 4b here: viewtopic.php?f=6&t=341 ) so that we can see why it is loading so long for you?
Gingeh1
Posts: 7
Joined: Mon Jun 27, 2005 11:14 am

Re: long time Loading data after update 4.1.30

Post by Gingeh1 »

Downloaded 4.1.31.1919 as requested, installed - on first installation it refused to play, although everything else seemed ok. Downloaded debug lo as requested, ran it and started media monkey. It took 6:30 minutes to show files - continually showed reading files.
Once music files appeared it worked fine, 6:30 is better than 20 but still not good.
If you wish me to run the log file again please let me know - if you want a copy of the 5k file also let me know.

Log file shows the following:

Code: Select all

[21988] x64MMHelper: iPhone: Loading library:  | app directory: C:\Program Files\Digi DNA\iMazing\
[21988] x64MMHelper: iPhone: iTunesMobileDevice.dll couldn't be loaded, error = 87
[9220] x64MMHelper: iPhone: Loading library: iTunesMobileDevice.dll | app directory: 
[9220] x64MMHelper: iPhone: iTunesMobileDevice.dll couldn't be loaded, error = 126
[5964] AAA Initialize 1
[5964] AAA Initialize 1
[1112] [2021.02.18-16.03.16:569][419]LogGeForceNowManager: GeForceNow SDK is running in cloud state: 0 
[13932] Suspending
[1112] [2021.02.18-16.08.16:603][340]LogGeForceNowManager: GeForceNow SDK is running in cloud state: 0 
[24888] AAA Initialize 1
[24888] AAA Initialize 1
[24888] 222222222222222222
[24888] AAA QueryContextMenu 1
[24888] RegQueryValueEx returns a value of C:\Program Files\Google\Drive\googledrivesync.exe and buffer_length of 100
[24888]  
[24888] *** CGDContextMenu::initialize ***
[24888]  
[24888] *** CGDContextMenu::Initialize Num files selected: ***1
[24888]  
[24888] RetrivePathLocation Unable to query client for folder path: IPC error.
[24888]  
[24888] *** CGDContextMenu::QueryContextMenu ***0
[24888]  
[24888] AAA Initialize 1
[24888] AAA Initialize 1
[24888] 222222222222222222
[24888] AAA QueryContextMenu 1
[24888] AAA QueryContextMenu 2
[24888] C:\Users\Ginge\AppData\Roaming\IObit\IObit Uninstaller\Main.ini
[24888] AAA QueryContextMenu 3
[24888] hIcon Get
[24888] hIcon <>NULL0
[24888] hIcon <>NULL1
[24888] AAA IconToBitmapPARGB32(IDB_BITMAP2);
[24888] AAA QueryContextMenu 4
[24888] *** CGDContextMenu::initialize ***
[24888]  
[24888] *** CGDContextMenu::Initialize Num files selected: ***1
[24888]  
[24888] RetrivePathLocation Unable to query client for folder path: IPC error.
[24888]  
[24888] *** CGDContextMenu::QueryContextMenu ***0
[24888]  
[5964] [6100]unHook, thread:6100, FreeAll:True
[5964] [6100]outdll :C:\WINDOWS\Explorer.EXE,5964
Ludek
Posts: 4020
Joined: Fri Mar 09, 2007 9:00 am

Re: long time Loading data after update 4.1.30

Post by Ludek »

Hi, this log does not include MM debug messages, it looks that you did not run the Debug build, but Release build 1919?

Please download and install the debug build: https://www.mediamonkey.com/sw/MediaMon ... _Debug.exe
and re-generate the log.

Thanks!
Gingeh1
Posts: 7
Joined: Mon Jun 27, 2005 11:14 am

Re: long time Loading data after update 4.1.30

Post by Gingeh1 »

I followed as I understood them the instructions, what ever the result, seems not to have worked quite as expected so I have run them again - log file as requested can be found at http://www.mediafire.com/file/lhsu9y6j0 ... R.LOG/file
Ludek
Posts: 4020
Joined: Fri Mar 09, 2007 9:00 am

Re: long time Loading data after update 4.1.30

Post by Ludek »

Hi,
analyzing your log and see that UpdateDriveLetters thread took more than 400 seconds (almost 7 minutes) !!
This is very unexpected -- it takes just several seconds in my case (even with several external drives/memories and CDs inserted).

Could you please eject all CDs and unplug all external drives and peripheral memories to see whether it resolves the issue?
If it resolves the issue then try to connect one drive after other to see which drive causes the slowdowns?

If it does not resolve (after ejecting CDs / external memories) then locate this file
C:\Users\Ginge\AppData\Roaming\MediaMonkey\MediaMonkey.ini
and add this line (temporarily) just below the first [SYSTEM] line:

Code: Select all

[System]
IgnoreDriveLetters=ABDEFGH
Where ABDEFGH means that drives A:\ , B:\, D:\, ... will be rejected from update.
If it helps then try to removing one letter after another to catch which drive is causing the slowdown.

------------------
EDIT: Alternativelly try to install latest MM5 debug build from here: viewtopic.php?p=478621#p478621
Currently it is https://www.mediamonkey.com/beta/MediaM ... _Debug.exe
And generate debug log from MM5 -- where I can see exactly which drive it is (due to enhanced debug messaging in MM5)

Thanks!
Gingeh1
Posts: 7
Joined: Mon Jun 27, 2005 11:14 am

Re: long time Loading data after update 4.1.30

Post by Gingeh1 »

Am working on this but it will take me a few days, I will keep you updated.
Gingeh1
Posts: 7
Joined: Mon Jun 27, 2005 11:14 am

Re: long time Loading data after update 4.1.30

Post by Gingeh1 »

Update 1,
changed the .ini file to reject all drives apart from the C:
[System]
IgnoreDriveLetters=ABDEFGHIJKLNOPQ)
- sadly it didn't seem to make any difference.
My system has an SSD as the C drive, attached to one of the folders in C: is another SSD.
MM xxxxx1919 was installed along with the Music files on the other SSD.
Moved MM and music from the attached drive to the main C: drive which seemed to make a slight difference. about 40% faster. Now about 3 minutes to fully populate
Cleared a lot of stuff from the C: Drive to the Attached drive doubling the amount of spare space on the C: Drive. At the same time, there are several versions of MM (Dev) etc, dotted about on the system - (from following your various requests). So while I was clearing the C: I also cleared all other varieties out (I mention this although I don't think it is relevant) but who knows yet?.
Rebooted system and it now takes 45 seconds to fully read in my files into the Entire Library part so acceptable, I will continue to investigate although it seems that the symbolic link is quite suspicious at this point, although there is obviously more.
Gingeh1
Posts: 7
Joined: Mon Jun 27, 2005 11:14 am

Re: long time Loading data after update 4.1.30

Post by Gingeh1 »

Having worked on this for whats seems forever now - but really only a few days, the only issue seems to be having an SSD attached as a link onto a system folder, with the system itself being on an SSD, why that should make a difference I can't as yet work out - but it does on my system, I will continue to work on this myself if I do discover why I will post something, for now, all I can say is I'm scratching my head and MM continues to work fine.
Thank you for your assistance. You may now close the support request.
Post Reply