[Bug] Grabbing mp3

Beta Testing for Windows Products and plugins

Moderator: Gurus

Me

[Bug] Grabbing mp3

Post by Me »

I changed the Virtual CD grabbing default from ogg to mp3. Yet, when I copied a song on Virtual CD, it name it with an ogg extension. I had to rename with an mp3 extension to be able to play it.
rusty
Posts: 7329
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada
Contact:

Post by rusty »

Hi,

I've tried reproducing this, but haven't been able to. Can you give me a bit more information?

1) What OS are you running
2) What version of Songs-DB
3) Is the bug consistently reproducible? If yes, can you give me the exact repro-steps? (including reconfiguration from OGG to MP3).

thx.

Rusty
Me

Post by Me »

After testing, unlikely possible bug for newbie.

1) Windows XP
2) build 506
3) Steps:

a) Option | Virtual CD | Audio format is OGG.
b) Enter CD. Copy a song to Virtual CD. The result is OGG.
c) Alt-Tab to a file manager and delete directly the OGG file from outside Songs-DB (I use Ztreewin).
d) Back to Songs-DB, Option | Virtual CD | Audio format is MP3
e) Enter CD. Copy a song to virtual CD. The result is named MP3 but still named MP3

The cause is external to Songs-DB, at step c). If the file is deleted within Songs-DB, no problem at all.

It is unlikely that newbies will manage files in their Virtual CD subdirs directly through an external file manager while Songs-DB is running, but power users might (I just did :-) )
rusty
Posts: 7329
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada
Contact:

Post by rusty »

thx. able to repro, but not consistently... Adding this to the to do list.
Post Reply