4.0.0.1446, auto conversion (mp3->mp3) to android fails

Beta Testing for Windows Products and plugins

Moderator: Gurus

see-beyond-me
Posts: 36
Joined: Mon May 04, 2009 12:57 pm
Contact:

4.0.0.1446, auto conversion (mp3->mp3) to android fails

Post by see-beyond-me »

hw: i7-quad core, 8gb mem, 750gb hd local, // QNAP TS-439 Pro II+ NAS (holding media files) // sony xperia arc smartphone
sw: 64-bit win7 sp1 (+all recent patches) // QNAP FW 3.5.1 Build 1002T // android 2.3.3

what I did:
- start mm4 1446
- define autoconversion for sony xperia arc (if mp3 > 192kbps then do mp3 = 160 kbps)
- select entire album from list
- right click and choose 'send to xperia arc'

what I see:
- status bar fires up and says (...'convert and copy'...)
- all 8 cpu threads of the i7-quad core are running 100% load (that's what I see as well on mm3 where autoconversion just works fine)
- sync finishes with no visible problem
- album is completely synced to xperia arc *BUT* all tracks are synced in their original high bit rate version (my media file repository whenever possible stores the media files in a vbr >200kbps format)

I have run above sequence with the dbg image and have prepared a DbgView log which I will send to 'helpdesk' after this entry is submitted.

Any ideas on what I might have done wrong are appreciated.

thx
/MD
see-beyond-me
Posts: 36
Joined: Mon May 04, 2009 12:57 pm
Contact:

Re: 4.0.0.1446, auto conversion (mp3->mp3) to android fails

Post by see-beyond-me »

ok, I now kind of know what is going wrong. The conversion itself works ok and the mediafile get synced to the andoid phone correctly in the newly calculated bitrate. What does not work is the display of installed music on the smartphone using mm4. It still displays bitrate and filesize of the original mediafile despite the fact that bitrate and filesize are now different. I could verify this easily by directly going to the files on the android phone, bypassing mm4. Using a standard explorer I see that the synced filesizes are smaller now and playing the files with an external player (AIMP3) reveals that the mediafiles synced with mm4 onto the smartphone indeed have the new 160kbps format.

So what would need to be done ? Fix mm4 to correctly read out mediafile properties that it finds on the smartphone.
In that respect, this is not a 'urgent' problem anymore but more some samll kind of annoyance.

thx
/MD
see-beyond-me
Posts: 36
Joined: Mon May 04, 2009 12:57 pm
Contact:

Re: 4.0.0.1446, auto conversion (mp3->mp3) to android fails

Post by see-beyond-me »

hm, just installed .1448, synced over some albums and still get the wrong bitrates and filesizes displayed when using mm4 to browse xperia arc contents. As before the synced tracks are converted correctly and when looking at them with an external player (AIMP3 in my case) they exhibit the converted bitrates and sizes.

/MD
nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: 4.0.0.1446, auto conversion (mp3->mp3) to android fails

Post by nohitter151 »

reopened the issue.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
Ludek
Posts: 3527
Joined: Fri Mar 09, 2007 9:00 am
Contact:

Re: 4.0.0.1446, auto conversion (mp3->mp3) to android fails

Post by Ludek »

Strange, it works fine for me with 1448.

1. Is your device accessible via a drive letter? i.e. Does it show Drive Letter on the Summary page?
2. Could you export and attach your Device Profile? Use the [Export device options...] button.
3. Could you generate a debug log? See item 4b here: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341
Guest

Re: 4.0.0.1446, auto conversion (mp3->mp3) to android fails

Post by Guest »

Ludek wrote:Strange, it works fine for me with 1448.

1. Is your device accessible via a drive letter? i.e. Does it show Drive Letter on the Summary page?
2. Could you export and attach your Device Profile? Use the [Export device options...] button.
3. Could you generate a debug log? See item 4b here: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341
currently away from home (working... :-) , will do above later (living in MET tz).
which steps should be in the debug log (ie. syncing, browsing, startup of mm4 with phone attached or not) ?

rgds
/MD
see-beyond-me
Posts: 36
Joined: Mon May 04, 2009 12:57 pm
Contact:

Re: 4.0.0.1446, auto conversion (mp3->mp3) to android fails

Post by see-beyond-me »

Ludek wrote:Strange, it works fine for me with 1448.

1. Is your device accessible via a drive letter? i.e. Does it show Drive Letter on the Summary page?
2. Could you export and attach your Device Profile? Use the [Export device options...] button.
3. Could you generate a debug log? See item 4b here: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341
ok, you can find all requested info posted to the associated ticket (AOA-802281), it's much easier to attach files to a ticket. I also have to stand corrected insofar that .1448 displays filesizes correctly, it's only the bitrates that it gets wrong. I also show another small problem with the device summary page, picture loaded to the ticket. Also you'll find there DbgView log, device export log and a number of screen shots.

Just to be clear, this stuff is far from being urgent since the core stuff, auto-conversion, just works fine and therefore likely any other issue should be resolved first.

thx
/MD
trinkner
Posts: 26
Joined: Sat Feb 12, 2011 10:02 am
Contact:

Re: 4.0.0.1446, auto conversion (mp3->mp3) to android fails

Post by trinkner »

I can confirm that the bit-rate display in MM 4.0.6.1501 continues to display the incorrect bit rate for auto-converted tracks on my iPod Classic. I have auto-convert set to convert from lossless FLAC files on my PC to 256-bit MP3 files for the iPod. The resulting files on the iPod have autoconverted to 256-bit MP3 files just fine; Windows Explorer indicates that they are truly 256-bit files. However, MM displays their bit rate as the same FLAC bit rate associated with the files on the PC, even though the display screen is generated when I'm browsing the iPod's contents through MM.
nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: 4.0.0.1446, auto conversion (mp3->mp3) to android fails

Post by nohitter151 »

trinkner wrote:I can confirm that the bit-rate display in MM 4.0.6.1501 continues to display the incorrect bit rate for auto-converted tracks on my iPod Classic. I have auto-convert set to convert from lossless FLAC files on my PC to 256-bit MP3 files for the iPod. The resulting files on the iPod have autoconverted to 256-bit MP3 files just fine; Windows Explorer indicates that they are truly 256-bit files. However, MM displays their bit rate as the same FLAC bit rate associated with the files on the PC, even though the display screen is generated when I'm browsing the iPod's contents through MM.
The bug tracker link says it won't be fixed until 4.1.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
Post Reply