High CPU usage when rating/tagging playing song [#14485]

Beta Testing for Windows Products and plugins

Moderator: Gurus

AnthonyM1229
Posts: 46
Joined: Fri Oct 14, 2011 2:59 pm
Contact:

High CPU usage when rating/tagging playing song [#14485]

Post by AnthonyM1229 »

Ever since I upgraded to build 1854, and still continuing in 1856, when I edit the tags or rating of a song currently playing, MM's CPU usage spikes until my playlist advances to the next song. I'm running Windows 7 x64 on an Intel Core i7-2630QM. It's a quad-core with hyperthreading. The behavior causes MM to max out one of my CPU cores. So, 12.5% of my CPU. I know it's not much for me in the grand scheme of things, but anyone who might be using a far weaker processor would be more heavily affected.

I did not observe this behavior in 1840 or earlier. When I was ready to upgrade, though, I skipped over 1852/1853 after reading there were some issues with crashes caused by tagging during playback. I've not observed any crashes so far, but I don't like the increased CPU usage, either.
Ludek
Posts: 3414
Joined: Fri Mar 09, 2007 9:00 am
Contact:

Re: 1856-High CPU usage when rating/tagging current playing

Post by Ludek »

Anthony, thanks soooo much for reporting this!!

Will be fixed as http://www.ventismedia.com/mantis/view.php?id=14485
AnthonyM1229
Posts: 46
Joined: Fri Oct 14, 2011 2:59 pm
Contact:

Re: High CPU usage when rating/tagging playing song [#14485]

Post by AnthonyM1229 »

Thanks for the reply and the quick fix! I can confirm I'm not observing the issue anymore in 1857.
Post Reply