Won't play 5.1 audio files

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

evetsnameloc
Posts: 4
Joined: Tue Jan 06, 2009 9:38 am
Contact:

Won't play 5.1 audio files

Post by evetsnameloc »

I'm currently using MediaMonkey 3.0.6.1190, Vista SP1 x64.

When trying to play wma lossless 5.1 audio files, MediaMonkey plays them but only puts out 2 (front) channels.

5.1 FLAC's and WavPack files (with the winamp wavpack filter installed and with "Allow multichannel playback" enabled) will not play at all with the MediaMonkey directshow output dll. With the "out_ds.dll" from Winamp 2.95, they will play but only 2 channels are put out.

I am using a Soundblaster X-Fi Extreme Music sound card. It is necessary to disable the surround processing in the sound card configuration to determine that there is no rear channel output with these files, otherwise it will create rear channel ambience and send this to the rear channels.

These files all play properly in Winamp 5.5 (or whatever their most recent version is) and in Windows Media Player 11 (with the proper filters installed).

Any fix?

Thanks.

Steve Coleman
evetsnameloc
Posts: 4
Joined: Tue Jan 06, 2009 9:38 am
Contact:

Re: Won't play 5.1 audio files

Post by evetsnameloc »

I spent a while scrolling through other posts both here and in the "Help" section (I wasn't allowed to search for "5.1") and I did find a few other posts about this sort of issue. I'm not sure that any of them were ever solved.

Just to be clear, I am talking about playing discreet 5.1 channel source material, not taking 2.0 channel sources and making 5.1 channels in playback. This, of course, is done by the surround processor in the sound card.

I hope there is a solution to this. I really prefer MM's GUI to Winamp's but at this time Winamp is the only player that will play all my files.

Steve Coleman
evetsnameloc
Posts: 4
Joined: Tue Jan 06, 2009 9:38 am
Contact:

Re: Won't play 5.1 audio files

Post by evetsnameloc »

After further testing, it appears that the only 5.1 files that won't play in 5.1 output are the wma's. For the others (flac and wv) to play, it is still necessary to use the winamp out_ds.dll output plugin.

I guess I could convert all my 5.1 wma's to either flac or wv, but this would be a big undertaking.

Any other options?
evetsnameloc
Posts: 4
Joined: Tue Jan 06, 2009 9:38 am
Contact:

Re: Won't play 5.1 audio files

Post by evetsnameloc »

OK, I think it's all working now.

For WMA's, use the Winamp in_wm.dll, either version 3.0 or 3.1 (other versions that I tried didn't work).

Use the Winamp out_ds.dll, version 2.2.6.

Maybe someone else will find this useful.
mhendu
Posts: 100
Joined: Thu Jan 12, 2006 11:18 am
Contact:

Re: Won't play 5.1 audio files

Post by mhendu »

This worked for me too! Was a real pain tracking down those DLL files though. Does MM4 support playback of 5.1 encoded WMA files natively or will we still have to jump through hoops to make these play properly? Is it OK for me to post the DLLs for the benefit of others trying to make this work or would that not be kosher?
Purplepants
Posts: 29
Joined: Mon Oct 11, 2010 10:01 am
Contact:

Re: Won't play 5.1 audio files

Post by Purplepants »

I can't seem the files needed. Can you guys point me in the right direction for the in_wm.dll (v3.0) and out_ds.dll (v2.2.6)?

I have tried using the files that come with the newest winamp installation, but they are not recognized by Mediamonkey :( Is there any trick to getting Mediamonkey to recognize .dll files?
Purplepants
Posts: 29
Joined: Mon Oct 11, 2010 10:01 am
Contact:

Re: Won't play 5.1 audio files

Post by Purplepants »

Found both files :)

out_ds.dll (v2.2.7) This works just as well with MM as the older version 2.2.6.

in_wm.dll (v3.1) can be found by downloading an older version of winamp like Winamp v5.21
Post Reply