Audiobooks crossfade after restarting MM [#11227]

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

sialivi
Posts: 26
Joined: Tue Aug 09, 2011 3:18 pm

Audiobooks crossfade after restarting MM [#11227]

Post by sialivi » Sun Jun 30, 2013 12:44 pm

The default playback behavior for audiobooks is to disable crossfading, as expected.

However, if you restart MM while listening to an audiobook, crossfading will be enabled when you resume playback after the restart.

Steps to reproduce:
1) Start playing an audiobook; crossfading is disabled
2) Exit MM
3) Restart MM
4) Click Play to resume the audiobook which is still in the playlist at this point
5) Result: Crossfading is now enabled

I'm using build 1644, but this bug has existed for a very long time.

rovingcowboy
Posts: 14162
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: Audiobooks crossfade after restarting MM

Post by rovingcowboy » Sun Jun 30, 2013 5:01 pm

sounds like crossfade is only turned off when you first start audiobooks. and since you just resume it doesn't get the signal to turn it off? :-?
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy 5 Android 5) 6. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.

sialivi
Posts: 26
Joined: Tue Aug 09, 2011 3:18 pm

Re: Audiobooks crossfade after restarting MM

Post by sialivi » Sat Aug 10, 2013 6:45 am

Any chance of getting this added to Mantis?

Peke
Posts: 13302
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Audiobooks crossfade after restarting MM

Post by Peke » Sun Aug 11, 2013 9:05 am

I can't replicate, for me Crossfade is always disabled when I'm playing Audiobooks check Playback rules.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

sialivi
Posts: 26
Joined: Tue Aug 09, 2011 3:18 pm

Re: Audiobooks crossfade after restarting MM

Post by sialivi » Mon Aug 12, 2013 11:48 am

The playback rules are fine since crossfading is correctly disabled when I start playing an audiobook. It seems MM is ignoring the playback rule for what's already in the playlist after you've restarted MM.

The only way around the problem is to navigate to the audiobook node in the library, find the book, find the right chapter file and double click it to resume. Only then will crossfading the disabled again.

Here's a video where I demonstrate the problem: https://www.youtube.com/watch?v=jhXTi9Gfrpw&hd=1

sialivi
Posts: 26
Joined: Tue Aug 09, 2011 3:18 pm

Re: Audiobooks crossfade after restarting MM

Post by sialivi » Thu Aug 29, 2013 6:51 pm

The steps shown in the video didn't help to replicate the problem?

Peke
Posts: 13302
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Audiobooks crossfade after restarting MM [#11227]

Post by Peke » Sat Aug 31, 2013 5:36 pm

Ha, I have been finally able to replicate and added to http://www.ventismedia.com/mantis/view.php?id=11227

I was somehow missed that you clicked Play directly I always started playback by double clicking on track in Now Playing Which loads tracks Collection Settings for player :(
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

Post Reply