MM4 tags artists with a "/" as separate artists [#16633]

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

DJSamhein
Posts: 132
Joined: Tue Oct 20, 2009 5:43 am
Contact:

MM4 tags artists with a "/" as separate artists [#16633]

Post by DJSamhein »

This happens every time:
-I have the "Split multiple-value fields with" option with the ";" character
-I have tracks where the artist has a "/" in the name, like "5/5/2000" or "De/vision"
-I add them to the library (usually just drop it on the monitored folder and wait for MM4 to detect it)
-MM4 changes it to a multi-artist ("5; 2000", "De; vision").
-If I check the album artist nodes, there's one for 5, one for 2000, etc.
-This doesn't happen in MM5

EDIT: If, after the track has been added to the library, I edit the properties and replace the artist name with the correct one, it will then be fixed. The tracks have the artist name as "5/5/2000" or "De/vision" and the library nodes are also correct
Lowlander
Posts: 47910
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: MM4 tags artists with a "/" as separate artists

Post by Lowlander »

Which software tagged the files? You can offer a file that exhibits this to Support. You may have to upload it to a filesharing like dropbox and include a link to it in your Support Ticket: http://www.mediamonkey.com/support/inde ... ets/Submit
Lowlander (MediaMonkey user since 2003)
DJSamhein
Posts: 132
Joined: Tue Oct 20, 2009 5:43 am
Contact:

Re: MM4 tags artists with a "/" as separate artists

Post by DJSamhein »

I used the MM properties to tag it.
To duplicate the situation, I simply copied any mp3 file outside the monitored folders, used the "My Computer" node to travel to the file's location, opened file properties, changed the artist and album artist to "5/5/2000" (other tags are irrelevant for this) and then dropped the file on the monitored folder.

This situation only happens when adding the file to the library. As I mentioned before, if I change the artist on a track that is already in the library, it will work fine, as expected.

I should also mention that this has always happened to me and I first detected it quite a few years ago. I never really bothered much about it because there aren't many artists with a "/" on the name and MM already has an exception in place for "AC/DC". I wouldn't even bother reporting it if it weren't for the fact that I found an artist that was mistagged for a few months and I hadn't noticed it.
Lowlander
Posts: 47910
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: MM4 tags artists with a "/" as separate artists

Post by Lowlander »

Lowlander (MediaMonkey user since 2003)
Post Reply